summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-11-30 04:01:32 +0000
committerMike Frysinger <vapier@gentoo.org>2004-11-30 04:01:32 +0000
commit056807a4ac91ca0ebc303b9f24b10173d41fcbb9 (patch)
tree82056e15f23c1d1a9044df096c126ef132b87c70 /sys-devel/libtool
parent~amd64 keyword added (diff)
downloadgentoo-2-056807a4ac91ca0ebc303b9f24b10173d41fcbb9.tar.gz
gentoo-2-056807a4ac91ca0ebc303b9f24b10173d41fcbb9.tar.bz2
gentoo-2-056807a4ac91ca0ebc303b9f24b10173d41fcbb9.zip
Move to unstable and include patch by Robin Johnson to fix locking issues #40992.
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/ChangeLog7
-rw-r--r--sys-devel/libtool/files/1.5.10/libtool-1.5.10-locking.patch11
-rw-r--r--sys-devel/libtool/libtool-1.5.10.ebuild11
3 files changed, 24 insertions, 5 deletions
diff --git a/sys-devel/libtool/ChangeLog b/sys-devel/libtool/ChangeLog
index 52465775281e..c4c67b9b4ba8 100644
--- a/sys-devel/libtool/ChangeLog
+++ b/sys-devel/libtool/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/libtool
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.59 2004/11/09 21:23:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/ChangeLog,v 1.60 2004/11/30 04:01:32 vapier Exp $
+
+ 29 Nov 2004; Mike Frysinger <vapier@gentoo.org>
+ +files/1.5.10/libtool-1.5.10-locking.patch, libtool-1.5.10.ebuild:
+ Move to unstable and include patch by Robin Johnson to fix locking issues
+ #40992.
09 Nov 2004; Mike Frysinger <vapier@gentoo.org>
+files/1.5.6/libtool-1.5-filter-host-tags.patch,
diff --git a/sys-devel/libtool/files/1.5.10/libtool-1.5.10-locking.patch b/sys-devel/libtool/files/1.5.10/libtool-1.5.10-locking.patch
new file mode 100644
index 000000000000..48b2791f1efc
--- /dev/null
+++ b/sys-devel/libtool/files/1.5.10/libtool-1.5.10-locking.patch
@@ -0,0 +1,11 @@
+--- libtool-1.5.10/ltmain.in.old 2004-11-16 22:21:32.849312264 -0800
++++ libtool-1.5.10/ltmain.in 2004-11-16 22:26:47.899417368 -0800
+@@ -1005,7 +1005,7 @@
+ # Lock this critical section if it is needed
+ # We use this script file to make the link, it avoids creating a new file
+ if test "$need_locks" = yes; then
+- until $run ln "$progpath" "$lockfile" 2>/dev/null; do
++ until $run ln "$srcfile" "$lockfile" 2>/dev/null; do
+ $show "Waiting for $lockfile to be removed"
+ sleep 2
+ done
diff --git a/sys-devel/libtool/libtool-1.5.10.ebuild b/sys-devel/libtool/libtool-1.5.10.ebuild
index e8124c9f2e8b..00d3d62e21db 100644
--- a/sys-devel/libtool/libtool-1.5.10.ebuild
+++ b/sys-devel/libtool/libtool-1.5.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10.ebuild,v 1.4 2004/11/12 15:21:00 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10.ebuild,v 1.5 2004/11/30 04:01:32 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils gnuconfig libtool
@@ -10,9 +10,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="1.5"
-# breaks building .so completely (emerge fam)
-KEYWORDS="-*"
-#KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="uclibc"
DEPEND="virtual/libc
@@ -110,6 +108,11 @@ src_unpack() {
# guessing is needed #67692
epatch ${FILESDIR}/1.5.6/libtool-1.5-filter-host-tags.patch
+ # Libtool uses links to handle locking object files with
+ # dependencies. Hard links can't cross filesystems though,
+ # so we have to use a diff source for the link. #40992
+ epatch ${FILESDIR}/1.5.10/libtool-1.5.10-locking.patch
+
einfo "Generate ltmain.sh ..."
gen_ltmain_sh || die "Failed to generate ltmain.sh!"