summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAron Griffis <agriffis@gentoo.org>2004-07-15 03:33:30 +0000
committerAron Griffis <agriffis@gentoo.org>2004-07-15 03:33:30 +0000
commit2e71dc35a0cc0ce84f851933a4fd359e4506016d (patch)
treed1ba3bed6c82d0c6f005b013353d2befd5ce227f /sys-devel/libtool
parentdon't assign S=${WORKDIR}/${P} (Manifest recommit) (diff)
downloadgentoo-2-2e71dc35a0cc0ce84f851933a4fd359e4506016d.tar.gz
gentoo-2-2e71dc35a0cc0ce84f851933a4fd359e4506016d.tar.bz2
gentoo-2-2e71dc35a0cc0ce84f851933a4fd359e4506016d.zip
sync IUSE (missing), don't dep on arch for gnuconfig_update, don't assign S=${WORKDIR}/${P}, trim trailing whitespace
Diffstat (limited to 'sys-devel/libtool')
-rw-r--r--sys-devel/libtool/libtool-1.4.1-r10.ebuild4
-rw-r--r--sys-devel/libtool/libtool-1.4.3-r3.ebuild12
-rw-r--r--sys-devel/libtool/libtool-1.4.3-r4.ebuild12
-rw-r--r--sys-devel/libtool/libtool-1.5.2-r3.ebuild15
-rw-r--r--sys-devel/libtool/libtool-1.5.2-r4.ebuild17
-rw-r--r--sys-devel/libtool/libtool-1.5.2-r5.ebuild18
-rw-r--r--sys-devel/libtool/libtool-1.5.6.ebuild18
7 files changed, 37 insertions, 59 deletions
diff --git a/sys-devel/libtool/libtool-1.4.1-r10.ebuild b/sys-devel/libtool/libtool-1.4.1-r10.ebuild
index c12857a0763b..96611d7e71e6 100644
--- a/sys-devel/libtool/libtool-1.4.1-r10.ebuild
+++ b/sys-devel/libtool/libtool-1.4.1-r10.ebuild
@@ -1,12 +1,11 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.1-r10.ebuild,v 1.13 2004/07/02 08:40:18 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.1-r10.ebuild,v 1.14 2004/07/15 03:33:30 agriffis Exp $
IUSE=""
inherit eutils
-S="${WORKDIR}/${P}"
DESCRIPTION="A shared library tool for developers"
SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz"
HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
@@ -60,4 +59,3 @@ src_install() {
dodoc AUTHORS COPYING ChangeLog* NEWS \
README THANKS TODO doc/PLATFORMS
}
-
diff --git a/sys-devel/libtool/libtool-1.4.3-r3.ebuild b/sys-devel/libtool/libtool-1.4.3-r3.ebuild
index 95f32b695067..313a4cbb7af1 100644
--- a/sys-devel/libtool/libtool-1.4.3-r3.ebuild
+++ b/sys-devel/libtool/libtool-1.4.3-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.3-r3.ebuild,v 1.8 2004/07/02 08:40:18 eradicator Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.3-r3.ebuild,v 1.9 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
IUSE=
@@ -9,7 +9,6 @@ inherit eutils gnuconfig
# NOTE: We install libltdl of libtool-1.3x for compat reasons ...
OLD_PV="1.3.5"
-S="${WORKDIR}/${P}"
OLD_S="${WORKDIR}/${PN}-${OLD_PV}"
DESCRIPTION="A shared library tool for developers"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
@@ -19,6 +18,7 @@ HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 x86 ppc sparc alpha mips hppa ia64 ppc64"
+IUSE=""
DEPEND="virtual/libc"
@@ -66,8 +66,7 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${PN}-1.3.5-nonneg.patch
epatch ${FILESDIR}/${PV}/${PN}-1.3.5-mktemp.patch
- use hppa && S="${OLD_S}" gnuconfig_update
- use amd64 && S="${OLD_S}" gnuconfig_update
+ gnuconfig_update
cd ${S}
echo
@@ -128,7 +127,7 @@ src_compile() {
cd ${OLD_S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
@@ -145,7 +144,7 @@ src_compile() {
cd ${S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
@@ -181,4 +180,3 @@ src_install() {
dodoc AUTHORS COPYING ChangeLog* NEWS \
README THANKS TODO doc/PLATFORMS
}
-
diff --git a/sys-devel/libtool/libtool-1.4.3-r4.ebuild b/sys-devel/libtool/libtool-1.4.3-r4.ebuild
index 9450004b4945..db9bc7ef629f 100644
--- a/sys-devel/libtool/libtool-1.4.3-r4.ebuild
+++ b/sys-devel/libtool/libtool-1.4.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.3-r4.ebuild,v 1.5 2004/07/02 08:40:18 eradicator Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.4.3-r4.ebuild,v 1.6 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
inherit eutils gnuconfig
@@ -9,7 +9,6 @@ IUSE="uclibc"
# NOTE: We install libltdl of libtool-1.3x for compat reasons ...
OLD_PV="1.3.5"
-S="${WORKDIR}/${P}"
OLD_S="${WORKDIR}/${PN}-${OLD_PV}"
DESCRIPTION="A shared library tool for developers"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
@@ -66,9 +65,7 @@ src_unpack() {
epatch ${FILESDIR}/${PV}/${PN}-1.3.5-mktemp.patch
epatch ${FILESDIR}/ltconfig-uclibc.patch
- use hppa && S="${OLD_S}" gnuconfig_update
- use amd64 && S="${OLD_S}" gnuconfig_update
- use uclibc && S="${OLD_S}" gnuconfig_update
+ gnuconfig_update
cd ${S}
echo
@@ -133,7 +130,7 @@ src_compile() {
cd ${OLD_S}
# Detect mips/mips64 and uclibc
- ( use mips || use uclibc ) && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
@@ -150,7 +147,7 @@ src_compile() {
cd ${S}
# Detect mips/mips64 and uclibc
- ( use mips || use uclibc ) && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
@@ -192,4 +189,3 @@ src_install() {
dodoc AUTHORS COPYING ChangeLog* NEWS \
README THANKS TODO doc/PLATFORMS
}
-
diff --git a/sys-devel/libtool/libtool-1.5.2-r3.ebuild b/sys-devel/libtool/libtool-1.5.2-r3.ebuild
index 9dab36f86f1f..eab7fa59e625 100644
--- a/sys-devel/libtool/libtool-1.5.2-r3.ebuild
+++ b/sys-devel/libtool/libtool-1.5.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r3.ebuild,v 1.5 2004/07/02 08:40:18 eradicator Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r3.ebuild,v 1.6 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
IUSE=
@@ -9,7 +9,6 @@ inherit eutils gnuconfig
# NOTE: We install libltdl of libtool-1.3x for compat reasons ...
OLD_PV="1.3.5"
-S="${WORKDIR}/${P}"
OLD_S="${WORKDIR}/${PN}-${OLD_PV}"
DESCRIPTION="A shared library tool for developers"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
@@ -19,6 +18,7 @@ HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~ia64 ppc64"
+IUSE=""
DEPEND="virtual/libc"
@@ -66,9 +66,7 @@ src_unpack() {
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-nonneg.patch
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
- use hppa && S="${OLD_S}" gnuconfig_update
- use amd64 && S="${OLD_S}" gnuconfig_update
- use ppc64 && S="${OLD_S}" gnuconfig_update
+ gnuconfig_update
cd ${S}
echo
@@ -142,10 +140,10 @@ src_compile() {
cd ${OLD_S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
# regen to allow for build,host,target ppc64
- use ppc64 && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
@@ -162,7 +160,7 @@ src_compile() {
cd ${S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
@@ -198,4 +196,3 @@ src_install() {
dodoc AUTHORS COPYING ChangeLog* NEWS \
README THANKS TODO doc/PLATFORMS
}
-
diff --git a/sys-devel/libtool/libtool-1.5.2-r4.ebuild b/sys-devel/libtool/libtool-1.5.2-r4.ebuild
index 9589387ab806..68c498472471 100644
--- a/sys-devel/libtool/libtool-1.5.2-r4.ebuild
+++ b/sys-devel/libtool/libtool-1.5.2-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r4.ebuild,v 1.3 2004/07/02 08:40:18 eradicator Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r4.ebuild,v 1.4 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 vapier Exp $
IUSE=
@@ -9,7 +9,6 @@ inherit eutils gnuconfig
# NOTE: We install libltdl of libtool-1.3x for compat reasons ...
OLD_PV="1.3.5"
-S="${WORKDIR}/${P}"
OLD_S="${WORKDIR}/${PN}-${OLD_PV}"
DESCRIPTION="A shared library tool for developers"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz
@@ -19,6 +18,7 @@ HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~mips ~hppa ~ia64 ppc64"
+IUSE=""
DEPEND="virtual/libc"
@@ -66,9 +66,7 @@ src_unpack() {
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-nonneg.patch
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
- use hppa && S="${OLD_S}" gnuconfig_update
- use amd64 && S="${OLD_S}" gnuconfig_update
- use ppc64 && S="${OLD_S}" gnuconfig_update
+ gnuconfig_update
cd ${S}
echo
@@ -103,7 +101,7 @@ src_unpack() {
# Mandrake patches
epatch ${FILESDIR}/1.4.3/${PN}-1.4.3-lib64.patch
epatch ${FILESDIR}/1.4.3/${PN}-1.4.2-fix-linkage-of-cxx-code-with-gcc.patch
-# Fix bug #43244
+# Fix bug #43244
# epatch ${FILESDIR}/1.4.3/${PN}-1.4.2-archive-shared.patch
epatch ${FILESDIR}/1.4.3/${PN}-1.4.3-ltmain-SED.patch
epatch ${FILESDIR}/1.4.3/${PN}-1.4.2-expsym-linux.patch
@@ -143,10 +141,10 @@ src_compile() {
cd ${OLD_S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
# regen to allow for build,host,target ppc64
- use ppc64 && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
@@ -163,7 +161,7 @@ src_compile() {
cd ${S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
@@ -199,4 +197,3 @@ src_install() {
dodoc AUTHORS COPYING ChangeLog* NEWS \
README THANKS TODO doc/PLATFORMS
}
-
diff --git a/sys-devel/libtool/libtool-1.5.2-r5.ebuild b/sys-devel/libtool/libtool-1.5.2-r5.ebuild
index 970e1c663579..e085e472c147 100644
--- a/sys-devel/libtool/libtool-1.5.2-r5.ebuild
+++ b/sys-devel/libtool/libtool-1.5.2-r5.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r5.ebuild,v 1.13 2004/07/02 08:40:18 eradicator Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.2-r5.ebuild,v 1.14 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils gnuconfig
# NOTE: We install libltdl of libtool-1.3x for compat reasons ...
OLD_PV="1.3.5"
-S="${WORKDIR}/${P}"
OLD_S="${WORKDIR}/${PN}-${OLD_PV}"
DESCRIPTION="A shared library tool for developers"
HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
@@ -69,10 +68,7 @@ src_unpack() {
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
epatch ${FILESDIR}/ltconfig-uclibc.patch
- use hppa && S="${OLD_S}" gnuconfig_update
- use amd64 && S="${OLD_S}" gnuconfig_update
- use ppc64 && S="${OLD_S}" gnuconfig_update
- use uclibc && S="${OLD_S}" gnuconfig_update
+ gnuconfig_update
cd ${S}
echo
@@ -147,13 +143,13 @@ src_compile() {
cd ${OLD_S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
# regen to allow for build,host,target ppc64
- use ppc64 && gnuconfig_update
+ gnuconfig_update
# detect uclibc
- use uclibc && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
@@ -170,9 +166,9 @@ src_compile() {
cd ${S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
- use uclibc && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \
diff --git a/sys-devel/libtool/libtool-1.5.6.ebuild b/sys-devel/libtool/libtool-1.5.6.ebuild
index 8572b25c84bc..99e82684f6eb 100644
--- a/sys-devel/libtool/libtool-1.5.6.ebuild
+++ b/sys-devel/libtool/libtool-1.5.6.ebuild
@@ -1,13 +1,12 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.6.ebuild,v 1.3 2004/07/10 04:03:27 lv Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.6.ebuild,v 1.4 2004/07/15 03:33:30 agriffis Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils gnuconfig
# NOTE: We install libltdl of libtool-1.3x for compat reasons ...
OLD_PV="1.3.5"
-S="${WORKDIR}/${P}"
OLD_S="${WORKDIR}/${PN}-${OLD_PV}"
DESCRIPTION="A shared library tool for developers"
HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
@@ -71,10 +70,7 @@ src_unpack() {
epatch ${FILESDIR}/1.4.3/${PN}-1.3.5-mktemp.patch
epatch ${FILESDIR}/ltconfig-uclibc.patch
- use hppa && S="${OLD_S}" gnuconfig_update
- use amd64 && S="${OLD_S}" gnuconfig_update
- use ppc64 && S="${OLD_S}" gnuconfig_update
- use uclibc && S="${OLD_S}" gnuconfig_update
+ gnuconfig_update
cd ${S}
echo
@@ -149,13 +145,13 @@ src_compile() {
cd ${OLD_S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
# regen to allow for build,host,target ppc64
- use ppc64 && gnuconfig_update
+ gnuconfig_update
# detect uclibc
- use uclibc && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${OLD_S##*/} ..."
./configure --host=${CHOST} \
@@ -172,9 +168,9 @@ src_compile() {
cd ${S}
# Detect mips/mips64
- use mips && gnuconfig_update
+ gnuconfig_update
- use uclibc && gnuconfig_update
+ gnuconfig_update
einfo "Configuring ${S##*/} ..."
./configure --host=${CHOST} \