summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2014-09-18 20:06:55 +0000
committerMichał Górny <mgorny@gentoo.org>2014-09-18 20:06:55 +0000
commit27dbbe6b1d391ba57dd7b6b04a50231ac9135837 (patch)
tree713068fde7be57e798538458cc38fb22ea066d2c /sys-devel/llvm
parentBlock gdb-7.8 because it breaks atomicity tests. (diff)
downloadgentoo-2-27dbbe6b1d391ba57dd7b6b04a50231ac9135837.tar.gz
gentoo-2-27dbbe6b1d391ba57dd7b6b04a50231ac9135837.tar.bz2
gentoo-2-27dbbe6b1d391ba57dd7b6b04a50231ac9135837.zip
Use simpler llvm::sys::fs::exists() form in gcc version detection code since the other one is deprecated. Bug #523082.
(Portage version: 2.2.12/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel/llvm')
-rw-r--r--sys-devel/llvm/ChangeLog7
-rw-r--r--sys-devel/llvm/files/clang-3.5-gentoo-runtime-gcc-detection-v3.patch13
2 files changed, 12 insertions, 8 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index c2fcda7f3d00..b2f38d5bb954 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.206 2014/09/17 23:29:09 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.207 2014/09/18 20:06:55 mgorny Exp $
+
+ 18 Sep 2014; Michał Górny <mgorny@gentoo.org>
+ files/clang-3.5-gentoo-runtime-gcc-detection-v3.patch:
+ Use simpler llvm::sys::fs::exists() form in gcc version detection code since
+ the other one is deprecated. Bug #523082.
17 Sep 2014; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.4.2.ebuild:
Also disable troublesome test in 3.4.2, fixes bug #516496
diff --git a/sys-devel/llvm/files/clang-3.5-gentoo-runtime-gcc-detection-v3.patch b/sys-devel/llvm/files/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
index 93c03642b9ce..1f81af0b7ff0 100644
--- a/sys-devel/llvm/files/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
+++ b/sys-devel/llvm/files/clang-3.5-gentoo-runtime-gcc-detection-v3.patch
@@ -1,17 +1,17 @@
-From 699d0b958b4d8fb42348d324ef805345b0cbc06b Mon Sep 17 00:00:00 2001
+From 916572e1243633ddf913c8f32771a3a7f70fd853 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Micha=C5=82=20G=C3=B3rny?= <mgorny@gentoo.org>
Date: Fri, 5 Sep 2014 16:49:35 +0200
Subject: [PATCH] Support obtaining active toolchain from gcc-config.
---
- tools/clang/lib/Driver/ToolChains.cpp | 20 ++++++++++++++++++++
- 1 file changed, 20 insertions(+)
+ tools/clang/lib/Driver/ToolChains.cpp | 19 +++++++++++++++++++
+ 1 file changed, 19 insertions(+)
diff --git a/tools/clang/lib/Driver/ToolChains.cpp b/tools/clang/lib/Driver/ToolChains.cpp
-index b46f69d..f3e986c 100644
+index b46f69d..2d4374d 100644
--- a/tools/clang/lib/Driver/ToolChains.cpp
+++ b/tools/clang/lib/Driver/ToolChains.cpp
-@@ -1253,6 +1253,26 @@ Generic_GCC::GCCInstallationDetector::init(
+@@ -1253,6 +1253,25 @@ Generic_GCC::GCCInstallationDetector::init(
Prefixes.push_back("/usr");
}
@@ -20,10 +20,9 @@ index b46f69d..f3e986c 100644
+ llvm::MemoryBuffer::getFile(D.SysRoot + "/etc/env.d/gcc/config-" + CandidateTripleAliases[k].str());
+ if (File)
+ {
-+ bool Exists;
+ const std::string VersionText = File.get()->getBuffer().rsplit('-').second.substr(0,5).str();
+ const std::string GentooPath = D.SysRoot + "/usr/lib/gcc/" + CandidateTripleAliases[k].str() + "/" + VersionText;
-+ if (!llvm::sys::fs::exists(GentooPath + "/crtbegin.o", Exists) && Exists)
++ if (llvm::sys::fs::exists(GentooPath + "/crtbegin.o"))
+ {
+ Version = GCCVersion::Parse(VersionText);
+ GCCInstallPath = GentooPath;