summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-11-20 04:28:42 +0000
committerMike Frysinger <vapier@gentoo.org>2010-11-20 04:28:42 +0000
commit34be5c8c032c9824cf8d65b5fb45459d67f659b7 (patch)
tree5acd395c80fb6011ed7ead0cf79207414df82ee2 /sys-devel/m4
parentVersion bump (bug #333017 by funtoo@dendryt.pl). Dropped md5sum-external USE ... (diff)
downloadgentoo-2-34be5c8c032c9824cf8d65b5fb45459d67f659b7.tar.gz
gentoo-2-34be5c8c032c9824cf8d65b5fb45459d67f659b7.tar.bz2
gentoo-2-34be5c8c032c9824cf8d65b5fb45459d67f659b7.zip
Add patch from OE to fix building with uClibc #336484 by Andrew Frink.
(Portage version: 2.2.0_alpha4/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/m4')
-rw-r--r--sys-devel/m4/ChangeLog6
-rw-r--r--sys-devel/m4/files/m4-1.4.15-uclibc-sched_param-def.patch19
-rw-r--r--sys-devel/m4/m4-1.4.15.ebuild9
3 files changed, 31 insertions, 3 deletions
diff --git a/sys-devel/m4/ChangeLog b/sys-devel/m4/ChangeLog
index 3a58f0ba1af2..7678d5130647 100644
--- a/sys-devel/m4/ChangeLog
+++ b/sys-devel/m4/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/m4
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.140 2010/09/06 20:26:45 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.141 2010/11/20 04:28:42 vapier Exp $
+
+ 20 Nov 2010; Mike Frysinger <vapier@gentoo.org> m4-1.4.15.ebuild,
+ +files/m4-1.4.15-uclibc-sched_param-def.patch:
+ Add patch from OE to fix building with uClibc #336484 by Andrew Frink.
06 Sep 2010; Brent Baude <ranger@gentoo.org> m4-1.4.14-r1.ebuild:
Marking m4-1.4.14-r1 ppc64 for bug 307633
diff --git a/sys-devel/m4/files/m4-1.4.15-uclibc-sched_param-def.patch b/sys-devel/m4/files/m4-1.4.15-uclibc-sched_param-def.patch
new file mode 100644
index 000000000000..50652d8babc2
--- /dev/null
+++ b/sys-devel/m4/files/m4-1.4.15-uclibc-sched_param-def.patch
@@ -0,0 +1,19 @@
+uclibc defines __GLIBC__ but it does not expose struct shed_param as much as glibc
+and is not needed too per standard. gnulib attempts to use it but we have to account
+for it because in this case uclibc does not behave like glibc.
+
+-Khem
+
+http://bugs.gentoo.org/336484
+
+--- m4-1.4.14/lib/spawn.in.h
++++ m4-1.4.14/lib/spawn.in.h
+@@ -31,7 +31,7 @@
+
+ /* Get definitions of 'struct sched_param' and 'sigset_t'.
+ But avoid namespace pollution on glibc systems. */
+-#ifndef __GLIBC__
++#if !defined __GLIBC__ || defined __UCLIBC__
+ # include <sched.h>
+ # include <signal.h>
+ #endif
diff --git a/sys-devel/m4/m4-1.4.15.ebuild b/sys-devel/m4/m4-1.4.15.ebuild
index 0cfa0ddd4755..a0e1c4f0f007 100644
--- a/sys-devel/m4/m4-1.4.15.ebuild
+++ b/sys-devel/m4/m4-1.4.15.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.15.ebuild,v 1.1 2010/08/31 17:50:17 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.15.ebuild,v 1.2 2010/11/20 04:28:42 vapier Exp $
EAPI="3"
+inherit eutils
+
DESCRIPTION="GNU macro processor"
HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.xz"
@@ -17,6 +19,10 @@ IUSE="examples"
DEPEND="app-arch/xz-utils"
RDEPEND=""
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-uclibc-sched_param-def.patch #336484
+}
+
src_configure() {
# Disable automagic dependency over libsigsegv; see bug #278026
export ac_cv_libsigsegv=no
@@ -39,5 +45,4 @@ src_install() {
dodoc examples/*
rm -f "${D}"/usr/share/doc/${PF}/examples/Makefile*
fi
- rm -f "${D}"/usr/lib/charset.alias #172864
}