summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-10-02 12:07:57 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-10-02 12:07:57 +0000
commit9d2cfd54161db20f8e54f6919b91746d5e45b5ef (patch)
tree98187deb7f944967a7b1c4266ccd2587ad9b276d /sys-devel/perl
parentlast of #7903, with #6820, #6300. Thanks to markus-krainer@chello.at. (diff)
downloadgentoo-2-9d2cfd54161db20f8e54f6919b91746d5e45b5ef.tar.gz
gentoo-2-9d2cfd54161db20f8e54f6919b91746d5e45b5ef.tar.bz2
gentoo-2-9d2cfd54161db20f8e54f6919b91746d5e45b5ef.zip
r7 addresses multiple bugs, incorporates the MakeMaker patch directly into perl
Diffstat (limited to 'sys-devel/perl')
-rw-r--r--sys-devel/perl/ChangeLog7
-rw-r--r--sys-devel/perl/files/digest-perl-5.6.1-r71
-rw-r--r--sys-devel/perl/perl-5.6.1-r7.ebuild169
3 files changed, 176 insertions, 1 deletions
diff --git a/sys-devel/perl/ChangeLog b/sys-devel/perl/ChangeLog
index 7a2fb4e55cc5..351a7676c0ac 100644
--- a/sys-devel/perl/ChangeLog
+++ b/sys-devel/perl/ChangeLog
@@ -1,7 +1,12 @@
# ChangeLog for sys-devel/perl
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.12 2002/09/14 03:16:15 mcummings Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.13 2002/10/02 12:07:57 mcummings Exp $
+*perl-5.6.1-r7 (02 Oct 2002)
+
+ 02 Oct 2002; mcummings <mcummings@gentoo.org> : Thanks entirely to seemant,
+ this release incorporates the MakeMaker fix directly into perl ebuild process.
+
*perl-5.8.0-r3 (13 Sep 2002)
13 Sep 2002; <mcummings@gentoo.org> : r3 is a cleaner ebuild that should have added support for other platforms.
diff --git a/sys-devel/perl/files/digest-perl-5.6.1-r7 b/sys-devel/perl/files/digest-perl-5.6.1-r7
new file mode 100644
index 000000000000..a1b30f92f979
--- /dev/null
+++ b/sys-devel/perl/files/digest-perl-5.6.1-r7
@@ -0,0 +1 @@
+MD5 ec1ff15464809b562aecfaa2e65edba6 perl-5.6.1.tar.gz 5983695
diff --git a/sys-devel/perl/perl-5.6.1-r7.ebuild b/sys-devel/perl/perl-5.6.1-r7.ebuild
new file mode 100644
index 000000000000..aa9fc0a57d81
--- /dev/null
+++ b/sys-devel/perl/perl-5.6.1-r7.ebuild
@@ -0,0 +1,169 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r7.ebuild,v 1.1 2002/10/02 12:07:57 mcummings Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
+SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${P}.tar.gz"
+HOMEPAGE="http://www.perl.org"
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="x86 ppc sparc sparc64"
+
+DEPEND="sys-apps/groff berkdb? ( >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1 ) gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="berkdb? ( >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1 ) gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use gdbm`" ]
+ then
+ myconf="-Di_gdbm"
+ fi
+ if [ "`use berkdb`" ]
+ then
+ myconf="${myconf} -Di_db -Di_ndbm"
+ else
+ myconf="${myconf} -Ui_db -Ui_ndbm"
+ fi
+
+ # configure for libperl.so
+ sh Configure -des \
+ -Darchname=${CHOST%%-*}-linux \
+ -Dcccdlflags='-fPIC' \
+ -Dccdlflags='-rdynamic' \
+ -Dprefix=/usr \
+ -Dlocincpth=' ' \
+ -Doptimize="${CFLAGS}" \
+ -Duselargefiles \
+ -Duseshrplib \
+ -Dlibperl=libperl.so \
+ -Dd_dosuid \
+ -Dd_semctl_semun \
+ ${myconf} || die
+ # add optimization flags
+ cp config.sh config.sh.orig
+ sed -e "s/optimize='-O2'/optimize=\'${CFLAGS}\'/" config.sh.orig > config.sh
+ # create libperl.so and move it out of the way
+ mv -f Makefile Makefile_orig
+ sed -e 's#^CCDLFLAGS = -rdynamic -Wl,-rpath,/usr/lib/perl5/.*#CCDLFLAGS = -rdynamic#' \
+ -e 's#^all: $(FIRSTMAKEFILE) #all: README #' \
+ Makefile_orig > Makefile
+ export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+ # fixes a bug in the make/testing on new systems
+ make -f Makefile depend || die
+ mv makefile makefile_orig
+ mv x2p/makefile x2p/makefile_orig
+ egrep -v "(<built-in>|<command line>)" makefile_orig >makefile
+ egrep -v "(<built-in>|<command line>)" x2p/makefile_orig >x2p/makefile
+ make -f Makefile libperl.so || die
+ mv libperl.so ${WORKDIR}
+
+ # starting from scratch again
+ cd ${WORKDIR}
+ rm -rf ${S}
+ unpack ${A}
+ cd ${S}
+
+ # configure for libperl.a
+# this is gross -- from Christian Gafton, Red Hat
+ cat > config.over <<EOF
+installprefix=${D}/usr
+#test -d \$installprefix || mkdir \$installprefix
+#test -d \$installprefix/bin || mkdir \$installprefix/bin
+installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
+installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
+#installman1dir=\$installprefix/share/man/man1
+#installman3dir=\$installprefix/share/man/man3
+installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
+installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
+installman1dir=\`echo \$installman1dir | sed "s!/man/!/share/man/!"\`
+installman3dir=\`echo \$installman3dir | sed "s!/man/!/share/man/!"\`
+man1ext=1
+man3ext=3pm
+installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
+installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
+installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
+installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
+EOF
+
+ sh Configure -des \
+ -Dprefix=/usr \
+ -Darchname=${CHOST%%-*}-linux \
+ -Duselargefiles \
+ -Dd_dosuid \
+ -Dlocincpth=' ' \
+ -Dd_semctl_semun \
+ ${myconf} || die
+
+ #Optimize ;)
+ cp config.sh config.sh.orig
+ sed -e "s/optimize='-O2'/optimize=\'${CFLAGS}\'/" config.sh.orig > config.sh
+ #THIS IS USED LATER:
+ export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+
+# Umm, for some reason this doesn't want to work, so we'll just remove
+# the makefiles and let make rebuild them itself. (It seems to do it
+# right the second time... -- pete
+# cp makefile makefile.orig
+# sed -e "s:^0::" makefile.orig > makefile
+
+ mv Makefile Makefile_orig
+ sed -e 's#^all: $(FIRSTMAKEFILE) #all: README #' \
+ Makefile_orig > Makefile
+
+ #for some reason, this rm -f doesn't seem to actually do anything. So we explicitly use "Makefile"
+ #(rather than the default "makefile") in all make commands below.
+ rm -f makefile x2p/makefile
+ make -f Makefile depend || die
+ mv makefile makefile_orig
+ mv x2p/makefile x2p/makefile_orig
+ egrep -v "(<built-in>|<command line>)" makefile_orig >makefile
+ egrep -v "(<built-in>|<command line>)" x2p/makefile_orig >x2p/makefile
+ make -f Makefile || die
+ cp ${O}/files/stat.t ./t/op/
+ # Parallel make fails
+ # dont use the || die since some tests fail on bootstrap
+ if [ `expr "$PARCH" ":" "sparc"` -gt 4 ]; then
+ echo "Skipping tests on this platform"
+ else
+ make -f Makefile test
+ fi
+}
+
+src_install() {
+
+ export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+
+ insinto /usr/lib/perl5/${PV}/${PARCH}/CORE/
+ doins ${WORKDIR}/libperl.so
+ dosym /usr/lib/perl5/${PV}/${PARCH}/CORE/libperl.so /usr/lib/libperl.so
+
+
+# make -f Makefile INSTALLMAN1DIR=${D}/usr/share/man/man1 INSTALLMAN3DIR=${D}/usr/share/man/man3 install || die
+ make DESTDIR=${D} INSTALLMAN1DIR=${D}/usr/share/man/man1 INSTALLMAN3DIR=${D}/usr/share/man/man3 install || die "Unable to make install"
+ install -m 755 utils/pl2pm ${D}/usr/bin/pl2pm
+
+
+#man pages
+
+# ./perl installman --man1dir=${D}/usr/share/man/man1 --man1ext=1 --man3dir=${D}/usr/share/man/man3 --man3ext=3
+
+
+# This removes ${D} from Config.pm
+
+ dosed /usr/lib/perl5/${PV}/${CHOST%%-*}-linux/Config.pm
+ dosed /usr/lib/perl5/${PV}/${CHOST%%-*}-linux/.packlist
+
+# DOCUMENTATION
+
+ dodoc Changes* Artistic Copying README Todo* AUTHORS
+ prepalldocs
+
+# HTML Documentation
+
+ dodir /usr/share/doc/${PF}/html
+ ./perl installhtml --recurse --htmldir=${D}/usr/share/doc/${PF}/html
+
+}