summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSeemant Kulleen <seemant@gentoo.org>2002-10-17 03:58:33 +0000
committerSeemant Kulleen <seemant@gentoo.org>2002-10-17 03:58:33 +0000
commitba50269e34df5702d73b4180809e1bfcc49c59ff (patch)
treefc6be4fcd5e950080c9d338126da9772dac6efa1 /sys-devel/perl
parentresolves bug #9144 (new sun minor version) (diff)
downloadgentoo-2-ba50269e34df5702d73b4180809e1bfcc49c59ff.tar.gz
gentoo-2-ba50269e34df5702d73b4180809e1bfcc49c59ff.tar.bz2
gentoo-2-ba50269e34df5702d73b4180809e1bfcc49c59ff.zip
removed buggy perl ebuild
Diffstat (limited to 'sys-devel/perl')
-rw-r--r--sys-devel/perl/files/digest-perl-5.6.1-r82
-rw-r--r--sys-devel/perl/perl-5.6.1-r8.ebuild199
2 files changed, 0 insertions, 201 deletions
diff --git a/sys-devel/perl/files/digest-perl-5.6.1-r8 b/sys-devel/perl/files/digest-perl-5.6.1-r8
deleted file mode 100644
index d47fed0f0eeb..000000000000
--- a/sys-devel/perl/files/digest-perl-5.6.1-r8
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 ec1ff15464809b562aecfaa2e65edba6 perl-5.6.1.tar.gz 5983695
-MD5 559896f9f222a750812c58b937a660f3 ExtUtils-MakeMaker-6.05.tar.gz 187528
diff --git a/sys-devel/perl/perl-5.6.1-r8.ebuild b/sys-devel/perl/perl-5.6.1-r8.ebuild
deleted file mode 100644
index abc265743f5a..000000000000
--- a/sys-devel/perl/perl-5.6.1-r8.ebuild
+++ /dev/null
@@ -1,199 +0,0 @@
-# Copyright 1999-2002 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r8.ebuild,v 1.2 2002/10/14 20:01:28 seemant Exp $
-
-MMPV=6.05
-MMPN=ExtUtils-MakeMaker
-MMP=${MMPN}-${MMPV}
-S=${WORKDIR}/${P}
-S2=${WORKDIR}/${MMP}
-DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
-SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${P}.tar.gz
- http://cpan.valueclick.com/modules/by-module/ExtUtils/${MMP}.tar.gz"
-HOMEPAGE="http://www.perl.org"
-
-SLOT="0"
-LICENSE="Artistic GPL-2"
-KEYWORDS="~x86 ~ppc ~sparc ~sparc64 ~alpha"
-
-
-RDEPEND="berkdb? ( >=sys-libs/db-3.2.3h-r3
- =sys-libs/db-1.85-r1 )
- gdbm? ( >=sys-libs/gdbm-1.8.0 )"
-
-DEPEND="sys-apps/groff
- ${RDEPEND}"
-
-src_compile() {
- local myconf
-
- use gdbm && myconf="-Di_gdbm"
-
- use berkdb \
- && myconf="${myconf} -Di_db -Di_ndbm" \
- || myconf="${myconf} -Ui_db -Ui_ndbm"
-
- # configure for libperl.so
- sh Configure -des \
- -Darchname=${CHOST%%-*}-linux \
- -Dcccdlflags='-fPIC' \
- -Dccdlflags='-rdynamic' \
- -Dprefix=/usr \
- -Dlocincpth=' ' \
- -Doptimize="${CFLAGS}" \
- -Duselargefiles \
- -Duseshrplib \
- -Dlibperl=libperl.so \
- -Dd_dosuid \
- -Dd_semctl_semun \
- ${myconf} || die
- # add optimization flags
- cp config.sh config.sh.orig
- sed -e "s/optimize='-O2'/optimize=\'${CFLAGS}\'/" config.sh.orig > config.sh
- # create libperl.so and move it out of the way
- mv -f Makefile Makefile_orig
- sed -e 's#^C\(CDLFLAGS = -rdynamic\) -Wl,-rpath,/usr/lib/perl5/.*#\1#' \
- -e 's#^all: $(FIRSTMAKEFILE) #all: README #' \
- Makefile_orig > Makefile
- export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
- # fixes a bug in the make/testing on new systems
- make -f Makefile depend || die
- mv makefile makefile_orig
- mv x2p/makefile x2p/makefile_orig
- egrep -v "(<built-in>|<command line>)" makefile_orig >makefile
- egrep -v "(<built-in>|<command line>)" x2p/makefile_orig >x2p/makefile
- make -f Makefile libperl.so || die
- mv libperl.so ${WORKDIR}
-
- # starting from scratch again
- cd ${WORKDIR}
- rm -rf ${S}
- unpack ${P}.tar.gz
- cd ${S}
-
- # configure for libperl.a
- # this is gross -- from Christian Gafton, Red Hat
- cat > config.over <<EOF
-installprefix=${D}/usr
-#test -d \$installprefix || mkdir \$installprefix
-#test -d \$installprefix/bin || mkdir \$installprefix/bin
-installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
-installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
-#installman1dir=\$installprefix/share/man/man1
-#installman3dir=\$installprefix/share/man/man3
-installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
-installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
-installman1dir=\`echo \$installman1dir | sed "s!/man/!/share/man/!"\`
-installman3dir=\`echo \$installman3dir | sed "s!/man/!/share/man/!"\`
-man1ext=1
-man3ext=3pm
-installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
-installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
-installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
-installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
-EOF
-
- sh Configure -des \
- -Dprefix=/usr \
- -Darchname=${CHOST%%-*}-linux \
- -Duselargefiles \
- -Dd_dosuid \
- -Dlocincpth=' ' \
- -Dd_semctl_semun \
- ${myconf} || die
-
- #Optimize ;)
- cp config.sh config.sh.orig
- sed -e "s/optimize='-O2'/optimize=\'${CFLAGS}\'/" config.sh.orig > config.sh
- #THIS IS USED LATER:
- export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
-
-# Umm, for some reason this doesn't want to work, so we'll just remove
-# the makefiles and let make rebuild them itself. (It seems to do it
-# right the second time... -- pete
-# cp makefile makefile.orig
-# sed -e "s:^0::" makefile.orig > makefile
-
- mv Makefile Makefile_orig
- sed -e 's#^all: $(FIRSTMAKEFILE) #all: README #' \
- Makefile_orig > Makefile
-
- #for some reason, this rm -f doesn't seem to actually do anything. So we explicitly use "Makefile"
- #(rather than the default "makefile") in all make commands below.
- rm -f makefile x2p/makefile
- make -f Makefile depend || die
- mv makefile makefile_orig
- mv x2p/makefile x2p/makefile_orig
- egrep -v "(<built-in>|<command line>)" makefile_orig >makefile
- egrep -v "(<built-in>|<command line>)" x2p/makefile_orig >x2p/makefile
- make -f Makefile || die
- cp ${O}/files/stat.t ./t/op/
- # Parallel make fails
- # dont use the || die since some tests fail on bootstrap
- if [ `expr "$PARCH" ":" "sparc"` -gt 4 ]; then
- echo "Skipping tests on this platform"
- else
- make -f Makefile test
- fi
-
-}
-
-src_install() {
-
- export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
-
- insinto /usr/lib/perl5/${PV}/${PARCH}/CORE/
- doins ${WORKDIR}/libperl.so
- dosym /usr/lib/perl5/${PV}/${PARCH}/CORE/libperl.so /usr/lib/libperl.so
-
-
-# make -f Makefile \
-# INSTALLMAN1DIR=${D}/usr/share/man/man1 \
-# INSTALLMAN3DIR=${D}/usr/share/man/man3 \
-# install || die
-
- make \
- DESTDIR=${D} \
- INSTALLMAN1DIR=${D}/usr/share/man/man1 \
- INSTALLMAN3DIR=${D}/usr/share/man/man3 \
- install || die "Unable to make install"
-
- install -m 755 utils/pl2pm ${D}/usr/bin/pl2pm
-
-
- #man pages
-
-# ./perl installman \
-# --man1dir=${D}/usr/share/man/man1 \
-# --man1ext=1 \
-# --man3dir=${D}/usr/share/man/man3 \
-# --man3ext=3
-
-
- # This removes ${D} from Config.pm
- dosed /usr/lib/perl5/${PV}/${CHOST%%-*}-linux/Config.pm
- dosed /usr/lib/perl5/${PV}/${CHOST%%-*}-linux/.packlist
-
- # DOCUMENTATION
- dodoc Changes* Artistic Copying README Todo* AUTHORS
- prepalldocs
-
- # HTML Documentation
- dodir /usr/share/doc/${PF}/html
- ./perl installhtml --recurse --htmldir=${D}/usr/share/doc/${PF}/html
-
- # MakeMaker Fix
- cd ${S2}
- ${D}/usr/bin/perl Makefile.PL ${myconf} PREFIX=${D}/usr
- make \
- PREFIX=${D}/usr \
- INSTALLMAN1DIR=${D}/usr/share/man/man1 \
- INSTALLMAN2DIR=${D}/usr/share/man/man2 \
- INSTALLMAN3DIR=${D}/usr/share/man/man3 \
- INSTALLMAN4DIR=${D}/usr/share/man/man4 \
- INSTALLMAN5DIR=${D}/usr/share/man/man5 \
- INSTALLMAN6DIR=${D}/usr/share/man/man6 \
- INSTALLMAN7DIR=${D}/usr/share/man/man7 \
- INSTALLMAN8DIR=${D}/usr/share/man/man8 \
- install || die
-}