summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2010-03-02 17:42:24 +0000
committerDoug Goldstein <cardoe@gentoo.org>2010-03-02 17:42:24 +0000
commit961ae7259ed71c310c6c8a514a71dcdc2b6b080f (patch)
treeb17d0abcba4acafce556722c23865a0fca48ac7a /sys-devel/sparse
parentVersion bump. (diff)
downloadgentoo-2-961ae7259ed71c310c6c8a514a71dcdc2b6b080f.tar.gz
gentoo-2-961ae7259ed71c310c6c8a514a71dcdc2b6b080f.tar.bz2
gentoo-2-961ae7259ed71c310c6c8a514a71dcdc2b6b080f.zip
version bump. 9999 version now is the same as 0.4.2
(Portage version: 2.1.7.17/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel/sparse')
-rw-r--r--sys-devel/sparse/ChangeLog10
-rw-r--r--sys-devel/sparse/sparse-0.4.2.ebuild52
-rw-r--r--sys-devel/sparse/sparse-9999.ebuild38
3 files changed, 89 insertions, 11 deletions
diff --git a/sys-devel/sparse/ChangeLog b/sys-devel/sparse/ChangeLog
index b4c2b1e8bf81..5e5074e773b8 100644
--- a/sys-devel/sparse/ChangeLog
+++ b/sys-devel/sparse/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/sparse
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.28 2008/09/23 11:45:36 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/ChangeLog,v 1.29 2010/03/02 17:42:24 cardoe Exp $
+
+*sparse-0.4.2 (02 Mar 2010)
+
+ 02 Mar 2010; Doug Goldstein <cardoe@gentoo.org> +sparse-0.4.2.ebuild,
+ sparse-9999.ebuild:
+ version bump. 9999 version now is the same as 0.4.2
23 Sep 2008; Jeroen Roovers <jer@gentoo.org> sparse-0.4.1.ebuild:
Stable for HPPA (bug #238272).
diff --git a/sys-devel/sparse/sparse-0.4.2.ebuild b/sys-devel/sparse/sparse-0.4.2.ebuild
new file mode 100644
index 000000000000..344f5a75eb3a
--- /dev/null
+++ b/sys-devel/sparse/sparse-0.4.2.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-0.4.2.ebuild,v 1.1 2010/03/02 17:42:24 cardoe Exp $
+
+EAPI="2"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
+ GIT_ECLASS="git"
+fi
+
+inherit eutils multilib flag-o-matic ${GIT_ECLASS}
+
+DESCRIPTION="C semantic parser"
+HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.kernel.org/pub/software/devel/sparse/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
+
+LICENSE="OSL-1.1"
+SLOT="0"
+IUSE=""
+
+DEPEND=""
+RDEPEND=""
+
+src_prepare() {
+ cd "${S}"
+ sed -i \
+ -e '/^PREFIX=/s:=.*:=/usr:' \
+ -e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
+ Makefile || die
+ append-flags -fno-strict-aliasing
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc FAQ README
+}
diff --git a/sys-devel/sparse/sparse-9999.ebuild b/sys-devel/sparse/sparse-9999.ebuild
index f19d127369a3..a93100f4bddf 100644
--- a/sys-devel/sparse/sparse-9999.ebuild
+++ b/sys-devel/sparse/sparse-9999.ebuild
@@ -1,29 +1,49 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.2 2007/09/17 19:28:20 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/sparse/sparse-9999.ebuild,v 1.3 2010/03/02 17:42:24 cardoe Exp $
-EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
-inherit eutils multilib git
+EAPI="2"
+
+if [[ ${PV} = *9999* ]]; then
+ EGIT_REPO_URI="git://git.kernel.org/pub/scm/devel/sparse/sparse.git"
+ GIT_ECLASS="git"
+fi
+
+inherit eutils multilib flag-o-matic ${GIT_ECLASS}
DESCRIPTION="C semantic parser"
-HOMEPAGE="http://kernel.org/pub/linux/kernel/people/josh/sparse/"
-SRC_URI=""
+HOMEPAGE="http://sparse.wiki.kernel.org/index.php/Main_Page"
+
+if [[ ${PV} = *9999* ]]; then
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.kernel.org/pub/software/devel/sparse/dist/${P}.tar.bz2"
+ KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+fi
LICENSE="OSL-1.1"
SLOT="0"
-KEYWORDS=""
IUSE=""
DEPEND=""
RDEPEND=""
-src_unpack() {
- git_src_unpack
+src_prepare() {
cd "${S}"
sed -i \
-e '/^PREFIX=/s:=.*:=/usr:' \
-e "/^LIBDIR=/s:/lib:/$(get_libdir):" \
Makefile || die
+ append-flags -fno-strict-aliasing
+}
+
+src_configure() {
+ :
+}
+
+src_compile() {
+ :
}
src_install() {