summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-01-12 01:09:18 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-01-12 01:09:18 +0000
commit5f2ab5f478b863a4a39ea5b9df6fad2954a61c8f (patch)
tree407bcd4bf7280c542f2c2aed8b6062b8d5a50494 /sys-devel/spython
parent*** empty log message *** (diff)
downloadgentoo-2-5f2ab5f478b863a4a39ea5b9df6fad2954a61c8f.tar.gz
gentoo-2-5f2ab5f478b863a4a39ea5b9df6fad2954a61c8f.tar.bz2
gentoo-2-5f2ab5f478b863a4a39ea5b9df6fad2954a61c8f.zip
a tiny fix
Diffstat (limited to 'sys-devel/spython')
-rw-r--r--sys-devel/spython/spython-2.0.ebuild7
1 files changed, 6 insertions, 1 deletions
diff --git a/sys-devel/spython/spython-2.0.ebuild b/sys-devel/spython/spython-2.0.ebuild
index a0426244a8b0..f397c2d602ee 100644
--- a/sys-devel/spython/spython-2.0.ebuild
+++ b/sys-devel/spython/spython-2.0.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0.ebuild,v 1.4 2001/01/11 23:22:36 drobbins Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0.ebuild,v 1.5 2001/01/12 01:09:18 drobbins Exp $
P=spython-1.5.2
S=${WORKDIR}/Python-2.0
@@ -35,6 +35,11 @@ src_unpack() {
mv md5.h ../md5_2.h
sed -e 's:"md5.h":"md5_2.h":' md5.c > ../md5_2.c
sed -e 's:"md5.h":"md5_2.h":' fchksum.c > ../fchksum.c
+
+ #for some reason, python 2.0 can't find /usr/lib/python2.0 without this fix to the source code.
+ cd ${S}/Python
+ cp pythonrun.c pythonrun.c.orig
+ sed -e 's:static char \*default_home = NULL:static char \*default_home = "/usr":' pythonrun.c.orig > pythonrun.c
}
src_compile() {