summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-06-10 05:27:22 +0000
committerMike Frysinger <vapier@gentoo.org>2010-06-10 05:27:22 +0000
commit04aac42bc473f09fc63a7ce0b51ede4ab6ccb616 (patch)
tree69307f92df06a9f44e1f1ffde426f60c26fb004d /sys-devel
parentStable for HPPA (bug #321153). (diff)
downloadgentoo-2-04aac42bc473f09fc63a7ce0b51ede4ab6ccb616.tar.gz
gentoo-2-04aac42bc473f09fc63a7ce0b51ede4ab6ccb616.tar.bz2
gentoo-2-04aac42bc473f09fc63a7ce0b51ede4ab6ccb616.zip
Version bump #318075 by Richard. This release includes fixes for #281907 by Patrick Lauer and for #313009 by Julien Etienne. Backports from upstream are included for #317211 by Javier Villavicencio, #317335 by Alexis Ballier, and #322031 by Nico Baggus.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog10
-rw-r--r--sys-devel/gcc/gcc-4.4.4.ebuild91
2 files changed, 100 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 7385de4e699e..79561a3ae193 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.756 2010/06/10 03:09:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.757 2010/06/10 05:27:22 vapier Exp $
+
+*gcc-4.4.4 (10 Jun 2010)
+
+ 10 Jun 2010; Mike Frysinger <vapier@gentoo.org> +gcc-4.4.4.ebuild:
+ Version bump #318075 by Richard. This release includes fixes for #281907
+ by Patrick Lauer and for #313009 by Julien Etienne. Backports from
+ upstream are included for #317211 by Javier Villavicencio, #317335 by
+ Alexis Ballier, and #322031 by Nico Baggus.
*gcc-4.3.5 (10 Jun 2010)
diff --git a/sys-devel/gcc/gcc-4.4.4.ebuild b/sys-devel/gcc/gcc-4.4.4.ebuild
new file mode 100644
index 000000000000..8ed6ae820b4b
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.4.4.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.4.4.ebuild,v 1.1 2010/06/10 05:27:22 vapier Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+ETYPE="gcc-compiler"
+
+# Hardened gcc 4 stuff
+#PIE_VER="10.1.5"
+#SPECS_VER="0.9.4"
+
+# arch/libc configurations known to be stable or untested with {PIE,SSP,FORTIFY}-by-default
+#PIE_GLIBC_STABLE="x86 amd64 ~ppc ~ppc64 ~arm ~sparc"
+#PIE_UCLIBC_STABLE="x86 arm"
+#SSP_STABLE="amd64 x86 ppc ppc64 ~arm ~sparc"
+#SSP_UCLIBC_STABLE=""
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=no #${SPLIT_SPECS-true} hard disable until #106690 is fixed
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+LICENSE="GPL-3 LGPL-3 || ( GPL-3 libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.2"
+KEYWORDS="~alpha ~amd64 ~arm -hppa ~ia64 ~mips ~ppc ~ppc64 ~sh -sparc ~x86 ~x86-fbsd"
+
+RDEPEND=">=sys-libs/zlib-1.1.4
+ >=sys-devel/gcc-config-1.4
+ virtual/libiconv
+ >=dev-libs/gmp-4.2.1
+ >=dev-libs/mpfr-2.3.2
+ graphite? (
+ >=dev-libs/ppl-0.10
+ >=dev-libs/cloog-ppl-0.15.4
+ )
+ !build? (
+ gcj? (
+ gtk? (
+ x11-libs/libXt
+ x11-libs/libX11
+ x11-libs/libXtst
+ x11-proto/xproto
+ x11-proto/xextproto
+ >=x11-libs/gtk+-2.2
+ x11-libs/pango
+ )
+ >=media-libs/libart_lgpl-2.1
+ app-arch/zip
+ app-arch/unzip
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+DEPEND="${RDEPEND}
+ test? ( >=dev-util/dejagnu-1.4.4 >=sys-devel/autogen-5.5.4 )
+ >=sys-apps/texinfo-4.8
+ >=sys-devel/bison-1.875
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ amd64? ( multilib? ( gcj? ( app-emulation/emul-linux-x86-xlibs ) ) )
+ ppc? ( >=${CATEGORY}/binutils-2.17 )
+ ppc64? ( >=${CATEGORY}/binutils-2.17 )
+ >=${CATEGORY}/binutils-2.15.94"
+PDEPEND=">=sys-devel/gcc-config-1.4"
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ gcc_src_unpack
+
+ use vanilla && return 0
+
+ sed -i 's/use_fixproto=yes/:/' gcc/config.gcc #PR33200
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.4.0/gcc-4.4.0-softfloat.patch
+}
+
+pkg_setup() {
+ gcc_pkg_setup
+
+ if use graphite ; then
+ ewarn "Graphite support is still experimental and unstable."
+ ewarn "Any bugs resulting from the use of Graphite will not be fixed."
+ fi
+}