summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2005-05-10 18:10:37 +0000
committerMartin Schlemmer <azarah@gentoo.org>2005-05-10 18:10:37 +0000
commit09fd05f78ad1bd0ca3a2af16da5031e79a89beb4 (patch)
treed9e395dd60995944b6e87960c22ef28ad041cde1 /sys-devel
parentremove configure check for arts (diff)
downloadgentoo-2-09fd05f78ad1bd0ca3a2af16da5031e79a89beb4.tar.gz
gentoo-2-09fd05f78ad1bd0ca3a2af16da5031e79a89beb4.tar.bz2
gentoo-2-09fd05f78ad1bd0ca3a2af16da5031e79a89beb4.zip
Fixup fixlafiles.awk detecting of gcc CHOST.
(Portage version: 2.0.51.21-r1)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/files/awk/fixlafiles.awk4
-rw-r--r--sys-devel/gcc/gcc-4.0.0.ebuild13
-rw-r--r--sys-devel/gcc/gcc-4.0.1_beta20050507.ebuild11
4 files changed, 28 insertions, 6 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index a9d5b9ee5b90..f5673e54d45c 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.402 2005/05/08 23:53:14 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.403 2005/05/10 18:10:37 azarah Exp $
+
+ 10 May 2005; Martin Schlemmer <azarah@gentoo.org>
+ files/awk/fixlafiles.awk, gcc-4.0.0.ebuild, gcc-4.0.1_beta20050507.ebuild:
+ Fixup fixlafiles.awk detecting of gcc CHOST.
*gcc-4.0.1_beta20050507 (08 May 2005)
diff --git a/sys-devel/gcc/files/awk/fixlafiles.awk b/sys-devel/gcc/files/awk/fixlafiles.awk
index dd8ba2e6145e..26567c288e45 100644
--- a/sys-devel/gcc/files/awk/fixlafiles.awk
+++ b/sys-devel/gcc/files/awk/fixlafiles.awk
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/files/awk/fixlafiles.awk,v 1.12 2005/01/18 01:58:18 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/files/awk/fixlafiles.awk,v 1.13 2005/05/10 18:10:37 azarah Exp $
#
# Helper functions
@@ -119,7 +119,7 @@ BEGIN {
#
# Get line from gcc's output containing CHOST
#
- pipe = "gcc -v 2>&1 | egrep '^Reading specs' 2>/dev/null"
+ pipe = "gcc -print-file-name=libgcc.a 2>/dev/null"
if ((!((pipe) | getline TMP_CHOST)) || (TMP_CHOST == "")) {
close(pipe)
diff --git a/sys-devel/gcc/gcc-4.0.0.ebuild b/sys-devel/gcc/gcc-4.0.0.ebuild
index 60e2dfe0afe5..70e7aa99cd19 100644
--- a/sys-devel/gcc/gcc-4.0.0.ebuild
+++ b/sys-devel/gcc/gcc-4.0.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.0.ebuild,v 1.1 2005/04/21 20:56:38 eradicator Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.0.ebuild,v 1.2 2005/05/10 18:10:37 azarah Exp $
ETYPE="gcc-compiler"
@@ -39,11 +39,20 @@ fi
DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
- >=sys-devel/binutils-2.15.90.0.1.1-r1"
+ >=sys-devel/binutils-2.15.97"
PDEPEND="sys-devel/gcc-config
!nocxx? ( !n32? ( !n64? ( !uclibc? ( !build? ( sys-libs/libstdc++-v3 ) ) ) ) )"
+src_unpack() {
+ gcc_src_unpack
+
+ cd ${S}
+ for x in $(cat /tmp/gcc4/list); do
+ [[ -f /tmp/gcc4/${x} ]] && epatch "/tmp/gcc4/${x}"
+ done
+}
+
pkg_postinst() {
toolchain_pkg_postinst
diff --git a/sys-devel/gcc/gcc-4.0.1_beta20050507.ebuild b/sys-devel/gcc/gcc-4.0.1_beta20050507.ebuild
index 09336fa54c9c..bad89788c5d6 100644
--- a/sys-devel/gcc/gcc-4.0.1_beta20050507.ebuild
+++ b/sys-devel/gcc/gcc-4.0.1_beta20050507.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.1_beta20050507.ebuild,v 1.1 2005/05/08 23:53:15 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.1_beta20050507.ebuild,v 1.2 2005/05/10 18:10:37 azarah Exp $
ETYPE="gcc-compiler"
@@ -44,6 +44,15 @@ DEPEND="${RDEPEND}
PDEPEND="sys-devel/gcc-config
!nocxx? ( !n32? ( !n64? ( !uclibc? ( !build? ( sys-libs/libstdc++-v3 ) ) ) ) )"
+src_unpack() {
+ gcc_src_unpack
+
+ cd ${S}
+ for x in $(cat /tmp/gcc4/list2); do
+ [[ -f /tmp/gcc4/${x} ]] && epatch "/tmp/gcc4/${x}"
+ done
+}
+
pkg_postinst() {
toolchain_pkg_postinst