summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRyan Hill <dirtyepic@gentoo.org>2013-05-15 01:09:36 +0000
committerRyan Hill <dirtyepic@gentoo.org>2013-05-15 01:09:36 +0000
commit15cd416d1f4601127892cf1d64fe978161e3b48b (patch)
treeb363ae8af4da7ce473c36efa053521a66314927a /sys-devel
parentRename test USE flag to regression-test. (diff)
downloadgentoo-2-15cd416d1f4601127892cf1d64fe978161e3b48b.tar.gz
gentoo-2-15cd416d1f4601127892cf1d64fe978161e3b48b.tar.bz2
gentoo-2-15cd416d1f4601127892cf1d64fe978161e3b48b.zip
Version bump, bug #465622. Also fixes bug #443092 (ICE with -fprofile-use
--coverage) and a wrong code bug with -mxop. Signed-off-by: Ryan Hill <dirtyepic@gentoo.org> (Portage version: 2.2.0_alpha174/cvs/Linux x86_64, signed Manifest commit with key 957A8463)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog9
-rw-r--r--sys-devel/gcc/gcc-4.7.3.ebuild67
-rw-r--r--sys-devel/gcc/metadata.xml1
3 files changed, 76 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 257b2a68d750..31499f03fd4b 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.947 2013/05/07 04:35:01 dirtyepic Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.948 2013/05/15 01:09:36 dirtyepic Exp $
+
+*gcc-4.7.3 (15 May 2013)
+
+ 15 May 2013; Ryan Hill <dirtyepic@gentoo.org> +gcc-4.7.3.ebuild,
+ metadata.xml:
+ Version bump, bug #465622. Also fixes bug #443092 (ICE with -fprofile-use
+ --coverage) and a wrong code bug with -mxop.
07 May 2013; Ryan Hill <dirtyepic@gentoo.org> gcc-4.8.0.ebuild:
4.8.0 p1.3: Fixes bug #465894 (wine memcopy breakage) and a couple of wrong
diff --git a/sys-devel/gcc/gcc-4.7.3.ebuild b/sys-devel/gcc/gcc-4.7.3.ebuild
new file mode 100644
index 000000000000..df26c5498f20
--- /dev/null
+++ b/sys-devel/gcc/gcc-4.7.3.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.7.3.ebuild,v 1.1 2013/05/15 01:09:36 dirtyepic Exp $
+
+PATCH_VER="1.0"
+UCLIBC_VER="1.0"
+
+# Hardened gcc 4 stuff
+PIE_VER="0.5.5"
+SPECS_VER="0.2.0"
+SPECS_GCC_VER="4.4.3"
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+PIE_GLIBC_STABLE="x86 amd64 ppc ppc64 arm ia64"
+PIE_UCLIBC_STABLE="x86 arm amd64 ppc ppc64"
+SSP_STABLE="amd64 x86 ppc ppc64 arm"
+# uclibc need tls and nptl support for SSP support
+# uclibc need to be >= 0.9.33
+SSP_UCLIBC_STABLE="x86 amd64 ppc ppc64 arm"
+#end Hardened stuff
+
+inherit toolchain
+
+DESCRIPTION="The GNU Compiler Collection"
+
+LICENSE="GPL-3+ LGPL-3+ || ( GPL-3+ libgcc libstdc++ gcc-runtime-library-exception-3.1 ) FDL-1.3+"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86
+~amd64-fbsd ~x86-fbsd"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ elibc_glibc? ( >=sys-libs/glibc-2.8 )
+ >=${CATEGORY}/binutils-2.18"
+
+if [[ ${CATEGORY} != cross-* ]] ; then
+ PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.8 )"
+fi
+
+src_unpack() {
+ if has_version '<sys-libs/glibc-2.12' ; then
+ ewarn "Your host glibc is too old; disabling automatic fortify."
+ ewarn "Please rebuild gcc after upgrading to >=glibc-2.12 #362315"
+ EPATCH_EXCLUDE+=" 10_all_default-fortify-source.patch"
+ fi
+
+ # drop the x32 stuff once 4.7 goes stable
+ if [[ ${CTARGET} != x86_64* ]] || ! has x32 $(get_all_abis TARGET) ; then
+ EPATCH_EXCLUDE+=" 90_all_gcc-4.7-x32.patch"
+ fi
+
+ toolchain_src_unpack
+
+ use vanilla && return 0
+
+ [[ ${CHOST} == ${CTARGET} ]] && epatch "${FILESDIR}"/gcc-spec-env.patch
+}
+
+pkg_setup() {
+ toolchain_pkg_setup
+
+ if use lto ; then
+ ewarn
+ ewarn "LTO support is still experimental and unstable."
+ ewarn "Any bugs resulting from the use of LTO will not be fixed."
+ ewarn
+ fi
+}
diff --git a/sys-devel/gcc/metadata.xml b/sys-devel/gcc/metadata.xml
index 3fe3ae1c93a7..a595b1856bfd 100644
--- a/sys-devel/gcc/metadata.xml
+++ b/sys-devel/gcc/metadata.xml
@@ -30,5 +30,6 @@
<flag name="objc++">Build support for the Objective C++ language</flag>
<flag name="objc-gc">Build support for the Objective C code language Garbage
Collector</flag>
+ <flag name="regression-test">Run the testsuite and install the results (requires FEATURES=test)</flag>
</use>
</pkgmetadata>