summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Haubenwallner <haubi@gentoo.org>2012-03-12 16:07:46 +0000
committerMichael Haubenwallner <haubi@gentoo.org>2012-03-12 16:07:46 +0000
commit22da5c35b37992d3c15e8da84c0954cfc235dc95 (patch)
tree7cd0c0e71335c3702938a442d6b5f277ccbf9ffa /sys-devel
parentMarking bash-4.2_p20 ppc64 for bug 407937 (diff)
downloadgentoo-2-22da5c35b37992d3c15e8da84c0954cfc235dc95.tar.gz
gentoo-2-22da5c35b37992d3c15e8da84c0954cfc235dc95.tar.bz2
gentoo-2-22da5c35b37992d3c15e8da84c0954cfc235dc95.zip
revbump
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/parity/ChangeLog9
-rw-r--r--sys-devel/parity/parity-1.2.5.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/sys-devel/parity/ChangeLog b/sys-devel/parity/ChangeLog
index fa733cb04d08..1d6f6ed34c37 100644
--- a/sys-devel/parity/ChangeLog
+++ b/sys-devel/parity/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/parity
-# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/parity/ChangeLog,v 1.1 2011/08/09 10:49:35 mduft Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/parity/ChangeLog,v 1.2 2012/03/12 16:07:46 haubi Exp $
+
+*parity-1.2.5 (12 Mar 2012)
+
+ 12 Mar 2012; Michael Haubenwallner <haubi@gentoo.org> +parity-1.2.5.ebuild:
+ revbump
*parity-9999 (09 Aug 2011)
*parity-1.2.4 (09 Aug 2011)
diff --git a/sys-devel/parity/parity-1.2.5.ebuild b/sys-devel/parity/parity-1.2.5.ebuild
new file mode 100644
index 000000000000..3ea26d89809b
--- /dev/null
+++ b/sys-devel/parity/parity-1.2.5.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/parity/parity-1.2.5.ebuild,v 1.1 2012/03/12 16:07:46 haubi Exp $
+
+EAPI=4
+
+DESCRIPTION="An Interix to native Win32 Cross-Compiler Tool (requires Visual Studio)."
+HOMEPAGE="http://www.sourceforge.net/projects/parity/"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit subversion
+ ESVN_REPO_URI="https://parity.svn.sf.net/svnroot/parity/trunk"
+ ESVN_BOOTSTRAP="confix --bootstrap"
+ ESVN_PROJECT="${PN}"
+ KEYWORDS=""
+
+ DEPEND="dev-util/confix"
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+ KEYWORDS="~x86-interix ~x86-winnt"
+fi
+
+LICENSE="LGPL-3"
+SLOT="0"
+IUSE=""
+
+pkg_setup() {
+ if [ -z "${MSSDK}" ]; then
+ einfo "NOTE: When using Visual Studio 2008, the Platform SDK is no longer"
+ einfo "installed alongside with the other components, but has it's own"
+ einfo "root directory, most likely something like this:"
+ einfo ""
+ einfo " C:\\Program Files\\Microsoft SDKs\\Windows\\v6.0A"
+ einfo ""
+ einfo "To make parity find it's paths correctly, please set MSSDK to the"
+ einfo "value correspoding to the above example for your system."
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ # create i586-pc-winnt*-g[++|cc|..] links..
+ local exeext=
+
+ [[ -f ${ED}/usr/bin/parity.gnu.gcc.exe ]] && exeext=.exe
+
+ # create cross compiler syms
+ dosym /usr/bin/parity.gnu.gcc${exeext} /usr/bin/i586-pc-winnt$(uname -r)-gcc
+ dosym /usr/bin/parity.gnu.gcc${exeext} /usr/bin/i586-pc-winnt$(uname -r)-c++
+ dosym /usr/bin/parity.gnu.gcc${exeext} /usr/bin/i586-pc-winnt$(uname -r)-g++
+ dosym /usr/bin/parity.gnu.ld${exeext} /usr/bin/i586-pc-winnt$(uname -r)-ld
+
+ # we don't need the header files installed by parity... private
+ # header files are supported with a patch from 2.1.0-r1 onwards,
+ # so they won't be there anymore, but -f does the job in any case.
+ rm -f "${ED}"/usr/include/*.h
+}