summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-03-09 02:13:41 +0000
committerMike Frysinger <vapier@gentoo.org>2005-03-09 02:13:41 +0000
commit2a4dff186b0ba44f517a51bdea02db0979e7daa9 (patch)
tree83d40c149dcbedc65ba879b045ffee0c94407c3a /sys-devel
parentAdded ~sparc keyword as it was mistakenly dropped in the version bump. (diff)
downloadgentoo-2-2a4dff186b0ba44f517a51bdea02db0979e7daa9.tar.gz
gentoo-2-2a4dff186b0ba44f517a51bdea02db0979e7daa9.tar.bz2
gentoo-2-2a4dff186b0ba44f517a51bdea02db0979e7daa9.zip
touchups
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bison/bison-1.875d.ebuild21
-rw-r--r--sys-devel/bison/bison-2.0.ebuild8
-rw-r--r--sys-devel/libtool/libtool-1.3.5.ebuild4
-rw-r--r--sys-devel/libtool/libtool-1.5.10-r4.ebuild6
-rw-r--r--sys-devel/libtool/libtool-1.5.10-r5.ebuild29
5 files changed, 32 insertions, 36 deletions
diff --git a/sys-devel/bison/bison-1.875d.ebuild b/sys-devel/bison/bison-1.875d.ebuild
index 1852c73ef8ac..7cf87ac9b00e 100644
--- a/sys-devel/bison/bison-1.875d.ebuild
+++ b/sys-devel/bison/bison-1.875d.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875d.ebuild,v 1.10 2005/03/04 21:47:59 kito Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-1.875d.ebuild,v 1.11 2005/03/09 02:12:08 vapier Exp $
-inherit toolchain-funcs flag-o-matic eutils gnuconfig
+inherit toolchain-funcs flag-o-matic eutils
DESCRIPTION="A yacc-compatible parser generator"
HOMEPAGE="http://www.gnu.org/software/bison/bison.html"
@@ -10,7 +10,7 @@ SRC_URI="ftp://alpha.gnu.org/pub/gnu/bison/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86 ~ppc-macos"
+KEYWORDS="alpha amd64 arm hppa ia64 m68k mips ppc ppc64 ppc-macos s390 sh sparc x86"
IUSE="nls static"
DEPEND="sys-devel/m4
@@ -18,9 +18,8 @@ DEPEND="sys-devel/m4
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-1.32-extfix.patch
- gnuconfig_update
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.32-extfix.patch
}
src_compile() {
@@ -44,23 +43,23 @@ src_compile() {
}
src_install() {
- make DESTDIR=${D} \
+ make DESTDIR="${D}" \
datadir=/usr/share \
mandir=/usr/share/man \
infodir=/usr/share/info \
install || die
# This one is installed by dev-util/yacc
- mv ${D}/usr/bin/yacc ${D}/usr/bin/yacc.bison || die
+ mv "${D}"/usr/bin/yacc "${D}"/usr/bin/yacc.bison || die
# We do not need this.
- rm -f ${D}/usr/lib/liby.a
+ rm -f "${D}"/usr/lib/liby.a
dodoc AUTHORS NEWS ChangeLog README REFERENCES OChangeLog doc/FAQ
}
pkg_postinst() {
- if [ ! -e "${ROOT}/usr/bin/yacc" ] ; then
- ln -s yacc.bison /usr/bin/yacc
+ if [[ ! -e ${ROOT}/usr/bin/yacc ]] ; then
+ ln -s yacc.bison "${ROOT}"/usr/bin/yacc
fi
}
diff --git a/sys-devel/bison/bison-2.0.ebuild b/sys-devel/bison/bison-2.0.ebuild
index e720e5870b1a..e5fe34fe89cf 100644
--- a/sys-devel/bison/bison-2.0.ebuild
+++ b/sys-devel/bison/bison-2.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.0.ebuild,v 1.1 2005/01/11 01:32:00 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bison/bison-2.0.ebuild,v 1.2 2005/03/09 02:12:08 vapier Exp $
inherit toolchain-funcs flag-o-matic eutils gnuconfig
@@ -10,7 +10,7 @@ SRC_URI="mirror://gnu/bison/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
IUSE="nls static"
DEPEND="sys-devel/m4
@@ -18,8 +18,8 @@ DEPEND="sys-devel/m4
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-1.32-extfix.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${PN}-1.32-extfix.patch
}
src_compile() {
diff --git a/sys-devel/libtool/libtool-1.3.5.ebuild b/sys-devel/libtool/libtool-1.3.5.ebuild
index 360098f51f24..7dc92347864f 100644
--- a/sys-devel/libtool/libtool-1.3.5.ebuild
+++ b/sys-devel/libtool/libtool-1.3.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.3.5.ebuild,v 1.4 2005/02/07 22:06:44 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.3.5.ebuild,v 1.5 2005/03/09 02:13:41 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils gnuconfig libtool
@@ -10,7 +10,7 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="1.3"
-KEYWORDS="~alpha amd64 arm hppa ia64 ~mips ~ppc ~ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE=""
DEPEND="virtual/libc
diff --git a/sys-devel/libtool/libtool-1.5.10-r4.ebuild b/sys-devel/libtool/libtool-1.5.10-r4.ebuild
index 40e95f96fcda..2012f3e1f138 100644
--- a/sys-devel/libtool/libtool-1.5.10-r4.ebuild
+++ b/sys-devel/libtool/libtool-1.5.10-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10-r4.ebuild,v 1.5 2005/03/04 17:21:18 morfic Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10-r4.ebuild,v 1.6 2005/03/09 02:13:41 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
inherit eutils gnuconfig libtool
@@ -10,10 +10,10 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="1.5"
-KEYWORDS="~alpha amd64 arm hppa ia64 mips ppc ppc64 s390 sh sparc x86"
+KEYWORDS="~alpha amd64 arm hppa ia64 m68k mips ppc ppc64 s390 sh sparc x86"
IUSE="uclibc"
-DEPEND="virtual/libc
+DEPEND="sys-devel/gnuconfig
>=sys-devel/autoconf-2.59
>=sys-devel/automake-1.9"
# the autoconf dep is due to it complaining 'configure.ac:55: error: Autoconf version 2.58 or higher is required'
diff --git a/sys-devel/libtool/libtool-1.5.10-r5.ebuild b/sys-devel/libtool/libtool-1.5.10-r5.ebuild
index ef2845c831c8..d42a0728e11a 100644
--- a/sys-devel/libtool/libtool-1.5.10-r5.ebuild
+++ b/sys-devel/libtool/libtool-1.5.10-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10-r5.ebuild,v 1.1 2005/02/23 17:17:01 azarah Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libtool/libtool-1.5.10-r5.ebuild,v 1.2 2005/03/09 02:13:41 vapier Exp ${P}-r1.ebuild,v 1.8 2002/10/04 06:34:42 kloeri Exp $
-inherit eutils gnuconfig libtool
+inherit eutils libtool
DESCRIPTION="A shared library tool for developers"
HOMEPAGE="http://www.gnu.org/software/libtool/libtool.html"
@@ -10,10 +10,10 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="1.5"
-KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="uclibc"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
-DEPEND="virtual/libc
+DEPEND="sys-devel/gnuconfig
>=sys-devel/autoconf-2.59
>=sys-devel/automake-1.9"
# the autoconf dep is due to it complaining 'configure.ac:55: error: Autoconf version 2.58 or higher is required'
@@ -127,10 +127,9 @@ src_unpack() {
done
eend 0
done
- cd ${S}
+ cd "${S}"
uclibctoolize
- gnuconfig_update ${WORKDIR}
epunt_cxx
}
@@ -144,13 +143,11 @@ src_install() {
make DESTDIR="${D}" install || die
dodoc AUTHORS ChangeLog* NEWS README THANKS TODO doc/PLATFORMS
- if use uclibc ; then
- for x in $(find ${D} -name config.guess -o -name config.sub) ; do
- rm -f ${x}; ln -sf ../gnuconfig/$(basename ${x}) ${x}
- done
- cd ${D}/usr/share/libtool/libltdl
- for x in config.guess config.sub ; do
- rm -f ${x} ; ln -sfn ../${x} ${x}
- done
- fi
+ for x in $(find "${D}" -name config.guess -o -name config.sub) ; do
+ rm -f "${x}" ; ln -sf ../gnuconfig/$(basename "${x}") "${x}"
+ done
+ cd "${D}"/usr/share/libtool/libltdl
+ for x in config.guess config.sub ; do
+ rm -f ${x} ; ln -sfn ../${x} ${x}
+ done
}