summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-11 05:58:58 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-11 05:58:58 +0000
commit3d1cbd41af3eec465c9b6edba73813cb559e3868 (patch)
tree56b4cdd923db7a514490587693f7ceacfbc5a2d0 /sys-devel
parentstable for x86 (diff)
downloadgentoo-2-3d1cbd41af3eec465c9b6edba73813cb559e3868.tar.gz
gentoo-2-3d1cbd41af3eec465c9b6edba73813cb559e3868.tar.bz2
gentoo-2-3d1cbd41af3eec465c9b6edba73813cb559e3868.zip
old
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.15.90.0.1.1-r3.ebuild179
-rw-r--r--sys-devel/binutils/binutils-2.15.90.0.3-r3.ebuild181
-rw-r--r--sys-devel/binutils/binutils-2.15.91.0.1.ebuild176
-rw-r--r--sys-devel/binutils/binutils-2.15.91.0.2.ebuild187
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.15.90.0.1.1-r32
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.15.90.0.3-r32
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.15.91.0.12
-rw-r--r--sys-devel/binutils/files/digest-binutils-2.15.91.0.22
8 files changed, 0 insertions, 731 deletions
diff --git a/sys-devel/binutils/binutils-2.15.90.0.1.1-r3.ebuild b/sys-devel/binutils/binutils-2.15.90.0.1.1-r3.ebuild
deleted file mode 100644
index e76f06420326..000000000000
--- a/sys-devel/binutils/binutils-2.15.90.0.1.1-r3.ebuild
+++ /dev/null
@@ -1,179 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.90.0.1.1-r3.ebuild,v 1.21 2005/01/03 00:00:16 ciaranm Exp $
-
-inherit eutils libtool flag-o-matic gnuconfig
-
-PATCHVER="1.3"
-DESCRIPTION="Tools necessary to build programs"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/${P}.tar.bz2
- http://dev.gentoo.org/~lv/${PN}-2.15.90.0.1-patches-${PATCHVER}.tar.bz2"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="-* amd64 -arm -hppa ppc s390 x86"
-IUSE="nls bootstrap build multitarget"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- !build? ( !bootstrap? ( dev-lang/perl ) )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- # The prescott patch is not ready yet.
- mkdir ${WORKDIR}/patch/skip
- mv ${WORKDIR}/patch/05* ${WORKDIR}/patch/skip/
-
- EPATCH_SUFFIX=patch epatch ${FILESDIR}/2.15
- epatch ${WORKDIR}/patch
-
- # Libtool is broken (Redhat).
- for x in ${S}/opcodes/Makefile.{am,in}
- do
- cp ${x} ${x}.orig
- gawk '
- {
- if ($0 ~ /LIBADD/)
- gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
-
- print
- }' ${x}.orig > ${x}
- rm -rf ${x}.orig
- done
-
- # Fix /usr/lib/libbfd.la
- elibtoolize --portage --no-uclibc
-
- gnuconfig_update
-}
-
-src_compile() {
- strip-linguas -i */po #42033
-
- # Generate borked binaries. Bug #6730
- filter-flags -fomit-frame-pointer -fssa
-
- local myconf=
- [ ! -z "${CBUILD}" ] && myconf="--build=${CBUILD}"
- use nls \
- && myconf="${myconf} --without-included-gettext" \
- || myconf="${myconf} --disable-nls"
-
- use multitarget && myconf="${myconf} --enable-targets=all"
- # Filter CFLAGS=".. -O2 .." on arm
- use arm && replace-flags -O? -O
-
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative. See
- # bug #47581 for more information.
- # Travis Tilley <lv@gentoo.org>
- has_version "=sys-devel/gcc-3.4*" && strip-flags && replace-flags -O3 -O2
-
- ./configure \
- --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} \
- || die
-
- make configure-bfd || die
- make headers -C bfd || die
- emake tooldir="${ROOT}/usr/bin" all || die
-
- if ! use build
- then
- if ! use bootstrap
- then
- # Nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm -f {} \; || :
- fi
- # Make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_install() {
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- # c++filt is included with gcc -- what are these GNU people thinking?
- # but not the manpage, so leave that!
-# We install it now, as gcc-3.3 do not have it any longer ...
-# rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
- # /usr/bin/strip we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- # The strip symlink gets created in the loop below
-
- # By default ar, as, ld, nm, ranlib and strip are in two places; create
- # symlinks. This will reduce the size of the tbz2 significantly. We also
- # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
- # appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x=
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv ${x} ../${CHOST}/bin/${x}
- else
- rm -f ${x}
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- if [ -n "${PROFILE_ARCH}" ] && \
- [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ]
- then
- dosym ${CHOST} /usr/${CHOST/-/64-}
-
- for x in `ls ${D}/usr/${CHOST}/bin/`
- do
- [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST/-/64-}-${x}
- done
- fi
-
- cd ${S}
- if ! use build
- then
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO gprof/bbconv.pl
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- # Install pre-generated manpages .. currently we do not ...
- else
- rm -rf ${D}/usr/share/man
- fi
-}
diff --git a/sys-devel/binutils/binutils-2.15.90.0.3-r3.ebuild b/sys-devel/binutils/binutils-2.15.90.0.3-r3.ebuild
deleted file mode 100644
index 9669e46e660d..000000000000
--- a/sys-devel/binutils/binutils-2.15.90.0.3-r3.ebuild
+++ /dev/null
@@ -1,181 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.90.0.3-r3.ebuild,v 1.17 2005/01/03 00:00:16 ciaranm Exp $
-
-inherit eutils libtool flag-o-matic
-
-PATCHVER="1.3"
-DESCRIPTION="Tools necessary to build programs"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/${P}.tar.bz2
- mirror://gentoo/${PN}-2.15.90.0.3-patches-${PATCHVER}.tar.bz2"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="-* arm ppc ppc64"
-IUSE="nls bootstrap build multitarget"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- !build? ( !bootstrap? ( dev-lang/perl ) )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- # The prescott patch is not ready yet.
- mkdir ${WORKDIR}/patch/skip
- mv ${WORKDIR}/patch/05* ${WORKDIR}/patch/skip/
-
- # w/ relro, move 20_* (replaced by 64_*), and 90_* (replaced by 63_*)
- mv ${WORKDIR}/patch/{20,90}_* ${WORKDIR}/patch/skip/
- # w/o relro, move 35_*, 64_* and 63_*
- #mv ${WORKDIR}/patch/{35,63,64}_* ${WORKDIR}/patch/skip/
-
- epatch ${FILESDIR}/2.15/05_all_binutils-2.15-elf32-arm-textrel.patch
- epatch ${FILESDIR}/2.15/40_all_binutils-uclibc-linker.patch
-
- epatch ${WORKDIR}/patch
-
- # Libtool is broken (Redhat).
- for x in ${S}/opcodes/Makefile.{am,in}
- do
- cp ${x} ${x}.orig
- gawk '
- {
- if ($0 ~ /LIBADD/)
- gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
-
- print
- }' ${x}.orig > ${x}
- rm -rf ${x}.orig
- done
-}
-
-src_compile() {
- strip-linguas -i */po #42033
-
- # Generate borked binaries. Bug #6730
- filter-flags -fomit-frame-pointer -fssa
- # Filter CFLAGS=".. -O2 .." on arm
- use arm && replace-flags -O? -O
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
- has_version "=sys-devel/gcc-3.4*" && strip-flags && replace-flags -O3 -O2
-
- local myconf=
- [ ! -z "${CBUILD}" ] && myconf="--build=${CBUILD}"
- use nls \
- && myconf="${myconf} --without-included-gettext" \
- || myconf="${myconf} --disable-nls"
- use multitarget && myconf="${myconf} --enable-targets=all"
-
- # Fix /usr/lib/libbfd.la
- elibtoolize --portage
-
- ./configure \
- --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} \
- || die
-
- make configure-bfd || die
- make headers -C bfd || die
- emake tooldir="${ROOT}/usr/bin" all || die
-
- if ! use build
- then
- if ! use bootstrap
- then
- # Nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm -f {} \; || :
- fi
- # Make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- # c++filt is included with gcc -- what are these GNU people thinking?
- # but not the manpage, so leave that!
-# We install it now, as gcc-3.3 do not have it any longer ...
-# rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
- # /usr/bin/strip we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- # The strip symlink gets created in the loop below
-
- # By default ar, as, ld, nm, ranlib and strip are in two places; create
- # symlinks. This will reduce the size of the tbz2 significantly. We also
- # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
- # appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x=
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv ${x} ../${CHOST}/bin/${x}
- else
- rm -f ${x}
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- if [ -n "${PROFILE_ARCH}" ] && \
- [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ]
- then
- dosym ${CHOST} /usr/${CHOST/-/64-}
-
- for x in `ls ${D}/usr/${CHOST}/bin/`
- do
- [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST/-/64-}-${x}
- done
- fi
-
- cd ${S}
- if ! use build
- then
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO gprof/bbconv.pl
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- # Install pre-generated manpages .. currently we do not ...
- else
- rm -rf ${D}/usr/share/man
- fi
-}
diff --git a/sys-devel/binutils/binutils-2.15.91.0.1.ebuild b/sys-devel/binutils/binutils-2.15.91.0.1.ebuild
deleted file mode 100644
index 5a44938ebc9c..000000000000
--- a/sys-devel/binutils/binutils-2.15.91.0.1.ebuild
+++ /dev/null
@@ -1,176 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.91.0.1.ebuild,v 1.8 2005/01/03 00:00:16 ciaranm Exp $
-
-inherit eutils libtool flag-o-matic
-
-PATCHVER="1.0"
-DESCRIPTION="Tools necessary to build programs"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/${P}.tar.bz2
- mirror://gentoo/${PN}-2.15.91.0.1-patches-${PATCHVER}.tar.bz2"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="-* ~ppc64"
-IUSE="nls bootstrap build multitarget"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- !build? ( !bootstrap? ( dev-lang/perl ) )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- # The prescott patch is not ready yet.
- mkdir ${WORKDIR}/patch/skip
- mv ${WORKDIR}/patch/05* ${WORKDIR}/patch/skip/
-
- # w/o relro, move 35_*, 64_* and 63_*
- #mv ${WORKDIR}/patch/{35,63,64}_* ${WORKDIR}/patch/skip/
-
- epatch ${WORKDIR}/patch
-
- # Libtool is broken (Redhat).
- for x in ${S}/opcodes/Makefile.{am,in}
- do
- cp ${x} ${x}.orig
- gawk '
- {
- if ($0 ~ /LIBADD/)
- gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
-
- print
- }' ${x}.orig > ${x}
- rm -rf ${x}.orig
- done
-}
-
-src_compile() {
- strip-linguas -i */po #42033
-
- # Generate borked binaries. Bug #6730
- filter-flags -fomit-frame-pointer -fssa
- # Filter CFLAGS=".. -O2 .." on arm
- use arm && replace-flags -O? -O
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
- has_version "=sys-devel/gcc-3.4*" && strip-flags && replace-flags -O3 -O2
-
- local myconf=
- [ ! -z "${CBUILD}" ] && myconf="--build=${CBUILD}"
- use nls \
- && myconf="${myconf} --without-included-gettext" \
- || myconf="${myconf} --disable-nls"
- use multitarget && myconf="${myconf} --enable-targets=all"
-
- # Fix /usr/lib/libbfd.la
- elibtoolize --portage
-
- ./configure \
- --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} \
- || die
-
- make configure-bfd || die
- make headers -C bfd || die
- emake tooldir="${ROOT}/usr/bin" all || die
-
- if ! use build
- then
- if ! use bootstrap
- then
- # Nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm -f {} \; || :
- fi
- # Make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_install() {
- make \
- prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- # c++filt is included with gcc -- what are these GNU people thinking?
- # but not the manpage, so leave that!
-# We install it now, as gcc-3.3 do not have it any longer ...
-# rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
- # /usr/bin/strip we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- # The strip symlink gets created in the loop below
-
- # By default ar, as, ld, nm, ranlib and strip are in two places; create
- # symlinks. This will reduce the size of the tbz2 significantly. We also
- # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
- # appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x=
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv ${x} ../${CHOST}/bin/${x}
- else
- rm -f ${x}
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- if [ -n "${PROFILE_ARCH}" ] && \
- [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ]
- then
- dosym ${CHOST} /usr/${CHOST/-/64-}
-
- for x in `ls ${D}/usr/${CHOST}/bin/`
- do
- [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST/-/64-}-${x}
- done
- fi
-
- cd ${S}
- if ! use build
- then
- make prefix=${D}/usr \
- mandir=${D}/usr/share/man \
- infodir=${D}/usr/share/info \
- install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO gprof/bbconv.pl
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- # Install pre-generated manpages .. currently we do not ...
- else
- rm -rf ${D}/usr/share/man
- fi
-}
diff --git a/sys-devel/binutils/binutils-2.15.91.0.2.ebuild b/sys-devel/binutils/binutils-2.15.91.0.2.ebuild
deleted file mode 100644
index ac6d5aa4b9ab..000000000000
--- a/sys-devel/binutils/binutils-2.15.91.0.2.ebuild
+++ /dev/null
@@ -1,187 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.15.91.0.2.ebuild,v 1.12 2005/01/03 00:00:16 ciaranm Exp $
-
-inherit eutils libtool flag-o-matic gnuconfig
-
-PATCHVER="1.3"
-DESCRIPTION="Tools necessary to build programs"
-HOMEPAGE="http://sources.redhat.com/binutils/"
-SRC_URI="mirror://kernel/linux/devel/binutils/${P}.tar.bz2
- mirror://kernel/linux/devel/binutils/test/${P}.tar.bz2
- mirror://gentoo/${PN}-2.15.91.0.1-patches-${PATCHVER}.tar.bz2"
-
-LICENSE="|| ( GPL-2 LGPL-2 )"
-SLOT="0"
-KEYWORDS="-* -amd64 ~hppa ~mips ~sparc"
-IUSE="nls bootstrap build multitarget uclibc"
-
-DEPEND="virtual/libc
- nls? ( sys-devel/gettext )
- !build? ( !bootstrap? ( dev-lang/perl ) )"
-
-src_unpack() {
- unpack ${A}
-
- cd ${S}
-
- # The prescott patch is not ready yet.
- mkdir ${WORKDIR}/patch/skip
- mv ${WORKDIR}/patch/05* ${WORKDIR}/patch/skip/
- mv ${WORKDIR}/patch/51* ${WORKDIR}/patch/skip/
- mv ${WORKDIR}/patch/52* ${WORKDIR}/patch/skip/
-
- # remove unused patches first (should not be in tarball at all)
- mv ${WORKDIR}/patch/{90,utils}* ${WORKDIR}/patch/skip/
-
- # uclibc uses non-relro version
- use uclibc \
- && mv ${WORKDIR}/patch/*relro* ${WORKDIR}/patch/skip/ \
- || mv ${WORKDIR}/patch/*no_rel_ro* ${WORKDIR}/patch/20_* ${WORKDIR}/patch/skip/
-
- epatch ${WORKDIR}/patch
-
- # Libtool is broken (Redhat).
- for x in ${S}/opcodes/Makefile.{am,in}
- do
- cp ${x} ${x}.orig
- gawk '
- {
- if ($0 ~ /LIBADD/)
- gsub("../bfd/libbfd.la", "-L../bfd/.libs ../bfd/libbfd.la")
- print
- }' ${x}.orig > ${x}
- rm -rf ${x}.orig
- done
-
- gnuconfig_update
-}
-
-src_compile() {
- strip-linguas -i */po #42033
-
- # Generate borked binaries. Bug #6730
- filter-flags -fomit-frame-pointer -fssa
- # Filter CFLAGS=".. -O2 .." on arm
- use arm && replace-flags -O? -O
- # GCC 3.4 miscompiles binutils unless CFLAGS are conservative #47581
- has_version "=sys-devel/gcc-3.4*" && strip-flags && replace-flags -O3 -O2
-
- local myconf=
- [ ! -z "${CBUILD}" ] && myconf="--build=${CBUILD}"
- use nls \
- && myconf="${myconf} --without-included-gettext" \
- || myconf="${myconf} --disable-nls"
- use multitarget && myconf="${myconf} --enable-targets=all"
-
- # Fix /usr/lib/libbfd.la
- elibtoolize --portage
-
- ./configure \
- --enable-shared \
- --enable-64-bit-bfd \
- --prefix=/usr \
- --mandir=/usr/share/man \
- --infodir=/usr/share/info \
- --host=${CHOST} \
- ${myconf} \
- || die
-
- make configure-bfd || die
- make headers -C bfd || die
- emake tooldir="${ROOT}/usr/bin" all || die
-
- if ! use build
- then
- if ! use bootstrap
- then
- # Nuke the manpages to recreate them (only use this if we have perl)
- find . -name '*.1' -exec rm -f {} \; || :
- fi
- # Make the info pages (makeinfo included with gcc is used)
- make info || die
- fi
-}
-
-src_test() {
- emake check
-}
-
-src_install() {
- make DESTDIR=${D} \
- install || die
-
- insinto /usr/include
- doins include/libiberty.h
-
- # c++filt is included with gcc -- what are these GNU people thinking?
- # but not the manpage, so leave that!
-# We install it now, as gcc-3.3 do not have it any longer ...
-# rm -f ${D}/usr/bin/c++filt #${D}/usr/share/man/man1/c++filt*
-
- # By default strip has a symlink going from /usr/${CHOST}/bin/strip to
- # /usr/bin/strip we should reverse it:
-
- rm ${D}/usr/${CHOST}/bin/strip; mv ${D}/usr/bin/strip ${D}/usr/${CHOST}/bin/strip
- # The strip symlink gets created in the loop below
-
- # By default ar, as, ld, nm, ranlib and strip are in two places; create
- # symlinks. This will reduce the size of the tbz2 significantly. We also
- # move all the stuff in /usr/bin to /usr/${CHOST}/bin and create the
- # appropriate symlinks. Things are cleaner that way.
- cd ${D}/usr/bin
- local x=
- for x in * strip
- do
- if [ ! -e ../${CHOST}/bin/${x} ]
- then
- mv ${x} ../${CHOST}/bin/${x}
- else
- rm -f ${x}
- fi
- ln -s ../${CHOST}/bin/${x} ${x}
- done
-
- if [ -n "${PROFILE_ARCH}" ] && \
- [ "${PROFILE_ARCH/64}" != "${PROFILE_ARCH}" ]
- then
- dosym ${CHOST} /usr/${CHOST/-/64-}
-
- for x in `ls ${D}/usr/${CHOST}/bin/`
- do
- [ ! -e "${D}/usr/bin/${CHOST}-${x}" ] && \
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST}-${x}
- dosym ../${CHOST}/bin/${x} /usr/bin/${CHOST/-/64-}-${x}
- done
- fi
-
- cd ${S}
- if ! use build
- then
- make DESTDIR=${D} install-info || die
-
- dodoc COPYING* README
- docinto bfd
- dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
- docinto binutils
- dodoc binutils/ChangeLog binutils/NEWS binutils/README
- docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
- docinto gprof
- dodoc gprof/ChangeLog* gprof/TEST gprof/TODO gprof/bbconv.pl
- docinto ld
- dodoc ld/ChangeLog* ld/README ld/NEWS ld/TODO
- docinto libiberty
- dodoc libiberty/ChangeLog* libiberty/COPYING.LIB libiberty/README
- docinto opcodes
- dodoc opcodes/ChangeLog*
- # Install pre-generated manpages .. currently we do not ...
- else
- rm -rf ${D}/usr/share/man
- fi
-
- use uclibc && rm -rf ${D}/usr/lib/ldscripts
-
- # remove shared libs' links (.so) to build all apps against the static versions
- use uclibc && rm -f ${D}/usr/lib/lib{bfd,opcodes}.so ${D}/usr/lib/lib*.la
-}
diff --git a/sys-devel/binutils/files/digest-binutils-2.15.90.0.1.1-r3 b/sys-devel/binutils/files/digest-binutils-2.15.90.0.1.1-r3
deleted file mode 100644
index 2501031143ee..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.15.90.0.1.1-r3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 d0427772ccbe68eefd40995d26ca4a78 binutils-2.15.90.0.1.1.tar.bz2 11068225
-MD5 fd3479e0455c80e6d17a2a7390df790f binutils-2.15.90.0.1-patches-1.3.tar.bz2 67142
diff --git a/sys-devel/binutils/files/digest-binutils-2.15.90.0.3-r3 b/sys-devel/binutils/files/digest-binutils-2.15.90.0.3-r3
deleted file mode 100644
index 286dd1e89eb0..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.15.90.0.3-r3
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 1c1af0064ebd3d7bd99905874656a21e binutils-2.15.90.0.3.tar.bz2 10703625
-MD5 90f635fd673fa93e0f64dad9670aac41 binutils-2.15.90.0.3-patches-1.3.tar.bz2 76625
diff --git a/sys-devel/binutils/files/digest-binutils-2.15.91.0.1 b/sys-devel/binutils/files/digest-binutils-2.15.91.0.1
deleted file mode 100644
index 66be933053e8..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.15.91.0.1
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 0d64d65d33a7f305e5ef8351086b9a3a binutils-2.15.91.0.1.tar.bz2 10775632
-MD5 2a58c1697c8f6a9e084299df4b481984 binutils-2.15.91.0.1-patches-1.0.tar.bz2 14370
diff --git a/sys-devel/binutils/files/digest-binutils-2.15.91.0.2 b/sys-devel/binutils/files/digest-binutils-2.15.91.0.2
deleted file mode 100644
index 493f77ed8a9f..000000000000
--- a/sys-devel/binutils/files/digest-binutils-2.15.91.0.2
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 41983069bef07af4f1350c6d30666b2d binutils-2.15.91.0.2.tar.bz2 10920145
-MD5 5cddb424d94ef2e290383b43aca17201 binutils-2.15.91.0.1-patches-1.3.tar.bz2 66603