summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-12-24 05:46:24 +0000
committerMike Frysinger <vapier@gentoo.org>2004-12-24 05:46:24 +0000
commit41a7859fe26b19043ffc7e69bf9c0c3316e5c3f1 (patch)
treeac854ffc60848b5ffbab634cdde5dd6cc6031ba4 /sys-devel
parentChange "app-sci" for the new categories "sci-astronomy" and "sci-biology" (diff)
downloadgentoo-2-41a7859fe26b19043ffc7e69bf9c0c3316e5c3f1.tar.gz
gentoo-2-41a7859fe26b19043ffc7e69bf9c0c3316e5c3f1.tar.bz2
gentoo-2-41a7859fe26b19043ffc7e69bf9c0c3316e5c3f1.zip
Seems people still have outdated gcc versions installed which break with GCC_SPECS="". Add a warning if their gcc is broken so they know they have to re-emerge gcc.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc-config/ChangeLog10
-rw-r--r--sys-devel/gcc-config/files/digest-gcc-config-1.3.8-r1 (renamed from sys-devel/gcc-config/files/digest-gcc-config-1.3.8)0
-rwxr-xr-xsys-devel/gcc-config/files/gcc-config-1.3.823
-rw-r--r--sys-devel/gcc-config/gcc-config-1.3.8-r1.ebuild (renamed from sys-devel/gcc-config/gcc-config-1.3.8.ebuild)2
4 files changed, 28 insertions, 7 deletions
diff --git a/sys-devel/gcc-config/ChangeLog b/sys-devel/gcc-config/ChangeLog
index 05a14b0c4c9e..e1bf6ccbb17b 100644
--- a/sys-devel/gcc-config/ChangeLog
+++ b/sys-devel/gcc-config/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/gcc-config
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.70 2004/12/23 18:04:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/ChangeLog,v 1.71 2004/12/24 05:46:23 vapier Exp $
+
+*gcc-config-1.3.8-r1 (24 Dec 2004)
+
+ 24 Dec 2004; Mike Frysinger <vapier@gentoo.org> files/gcc-config-1.3.8,
+ +gcc-config-1.3.8-r1.ebuild, -gcc-config-1.3.8.ebuild:
+ Seems people still have outdated gcc versions installed which break with
+ GCC_SPECS="". Add a warning if their gcc is broken so they know they have to
+ re-emerge gcc.
*gcc-config-1.3.8 (23 Dec 2004)
diff --git a/sys-devel/gcc-config/files/digest-gcc-config-1.3.8 b/sys-devel/gcc-config/files/digest-gcc-config-1.3.8-r1
index e69de29bb2d1..e69de29bb2d1 100644
--- a/sys-devel/gcc-config/files/digest-gcc-config-1.3.8
+++ b/sys-devel/gcc-config/files/digest-gcc-config-1.3.8-r1
diff --git a/sys-devel/gcc-config/files/gcc-config-1.3.8 b/sys-devel/gcc-config/files/gcc-config-1.3.8
index 309f49694423..ee8c1176252f 100755
--- a/sys-devel/gcc-config/files/gcc-config-1.3.8
+++ b/sys-devel/gcc-config/files/gcc-config-1.3.8
@@ -1,7 +1,7 @@
#!/bin/bash
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.8,v 1.1 2004/12/23 18:04:06 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/files/gcc-config-1.3.8,v 1.2 2004/12/24 05:46:24 vapier Exp $
# Author: Martin Schlemmer <azarah@gentoo.org>
trap ":" INT QUIT TSTP
@@ -89,7 +89,7 @@ get_real_chost() {
is_cross_compiler() {
get_real_chost
- [ "${CC_COMP/${REAL_CHOST}}" = "${CC_COMP}" ]
+ [[ ${CC_COMP/${REAL_CHOST}} = ${CC_COMP} ]]
}
switch_profile() {
@@ -160,11 +160,24 @@ switch_profile() {
${AWK} '!/^(STDCXX_INCDIR|LDPATH|CC|CXX|CTARGET|GCCBITS|GCC_SPECS)=/ {print $0}' \
"${GCC_ENV_D}/${CC_COMP}" > "${ENV_D}/05gcc"
echo "LDPATH=\"${MY_LDPATH}\"" >> "${ENV_D}/05gcc"
- if [[ -n ${GCC_SPECS} ]] && [[ -e ${ROOT}/${GCC_SPECS} ]]
- then
+ if [[ -n ${GCC_SPECS} ]] && [[ -e ${ROOT}/${GCC_SPECS} ]] ; then
echo "GCC_SPECS=\"${GCC_SPECS}\"" >> "${ENV_D}/05gcc"
else
- echo "GCC_SPECS=\"\"" >> "${ENV_D}/05gcc"
+ # People need to rebuild their gcc or setting GCC_SPECS to
+ # "" will cause issues again :(
+ if [[ ${ROOT} != "/" ]] ; then
+ echo "GCC_SPECS=\"\"" >> "${ENV_D}/05gcc"
+ else
+ if ! GCC_SPECS="" /usr/bin/gcc -v &>/dev/null ; then
+ echo
+ ewarn "Your gcc has a bug with GCC_SPECS."
+ ewarn "Please re-emerge gcc."
+ ewarn "http://bugs.gentoo.org/show_bug.cgi?id=68395"
+ echo
+ else
+ echo "GCC_SPECS=\"\"" >> "${ENV_D}/05gcc"
+ fi
+ fi
fi
echo "CURRENT=${CC_COMP}" > "${GCC_ENV_D}/config"
diff --git a/sys-devel/gcc-config/gcc-config-1.3.8.ebuild b/sys-devel/gcc-config/gcc-config-1.3.8-r1.ebuild
index 182ff2847f37..f9f558c4ffcf 100644
--- a/sys-devel/gcc-config/gcc-config-1.3.8.ebuild
+++ b/sys-devel/gcc-config/gcc-config-1.3.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.8.ebuild,v 1.4 2004/12/24 02:23:52 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc-config/gcc-config-1.3.8-r1.ebuild,v 1.1 2004/12/24 05:46:23 vapier Exp $
inherit toolchain-funcs