summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2005-04-08 04:14:26 +0000
committerMike Frysinger <vapier@gentoo.org>2005-04-08 04:14:26 +0000
commit53f02595121e788881701032bffb1d801417cf22 (patch)
tree7a5c4375e7dd09647158bd43ae9778183e606b09 /sys-devel
parentFixed really broken Manifest. (diff)
downloadgentoo-2-53f02595121e788881701032bffb1d801417cf22.tar.gz
gentoo-2-53f02595121e788881701032bffb1d801417cf22.tar.bz2
gentoo-2-53f02595121e788881701032bffb1d801417cf22.zip
Add a patch from Debian and the patch to prevent gcc from unlinking /dev/null.
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/digest-gcc-3.3.5.20050130-r28
-rw-r--r--sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild99
3 files changed, 114 insertions, 1 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index 7c8d24692074..8712d57be942 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.396 2005/04/08 02:52:07 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.397 2005/04/08 04:14:25 vapier Exp $
+
+*gcc-3.3.5.20050130-r2 (08 Apr 2005)
+
+ 08 Apr 2005; Mike Frysinger <vapier@gentoo.org>
+ +gcc-3.3.5.20050130-r2.ebuild:
+ Add a patch from Debian and the patch to prevent gcc from unlinking /dev/null.
*gcc-3.4.3.20050110-r2 (08 Apr 2005)
diff --git a/sys-devel/gcc/files/digest-gcc-3.3.5.20050130-r2 b/sys-devel/gcc/files/digest-gcc-3.3.5.20050130-r2
new file mode 100644
index 000000000000..752d65225495
--- /dev/null
+++ b/sys-devel/gcc/files/digest-gcc-3.3.5.20050130-r2
@@ -0,0 +1,8 @@
+MD5 70ee088b498741bb08c779f9617df3a5 gcc-3.3.5.tar.bz2 23833856
+MD5 a158a57134253df324270f99e5b4a612 gcc-3.3.5-branch-update-20050130.patch.bz2 38618
+MD5 407883749eddbe6baae77f722c6e77d7 protector-3.3.5.20050130-1.tar.gz 24324
+MD5 3c9f7b2bd066afe2888289595ac07104 gcc-3.3.5-uclibc-patches-1.0.tar.bz2 27532
+MD5 aa0868ecce2185884c618de9a15eb40d gcc-3.3.5-manpages.tar.bz2 214965
+MD5 c6a1161361dc8edf36204239f4079dfe gcc-3.3.5-patches-1.5.tar.bz2 43755
+MD5 9ffa098b60ba4e6eadcbbe50900fa295 gcc-3.3.5-piepatches-v8.7.7.1.tar.bz2 25970
+MD5 f75ad40c0340ff23aba1dd4961285516 bounds-checking-gcc-3.3.5-1.00-r2.patch.bz2 827126
diff --git a/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild b/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild
new file mode 100644
index 000000000000..53774b905d7b
--- /dev/null
+++ b/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r2.ebuild,v 1.1 2005/04/08 04:14:26 vapier Exp $
+
+MAN_VER="3.3.5"
+PATCH_VER="1.5"
+UCLIBC_VER="1.0"
+PIE_VER="8.7.7.1"
+PIE_CORE="gcc-3.3.5-piepatches-v${PIE_VER}.tar.bz2"
+PP_VER="3_3_5_20050130"
+PP_FVER="${PP_VER//_/.}-1"
+HTB_VER="1.00-r2"
+#HTB_GCC_VER="3.3.5"
+
+ETYPE="gcc-compiler"
+
+# arch/libc configurations known to be stable with {PIE,SSP}-by-default
+SSP_STABLE="x86 sparc amd64"
+SSP_UCLIBC_STABLE="arm mips ppc x86"
+PIE_GLIBC_STABLE="x86 sparc amd64"
+PIE_UCLIBC_STABLE="x86 mips ppc"
+
+# arch/libc configurations known to be broken with {PIE,SSP}-by-default
+SSP_UNSUPPORTED="hppa"
+SSP_UCLIBC_UNSUPPORTED="${SSP_UNSUPPORTED}"
+PIE_UCLIBC_UNSUPPORTED="alpha amd64 arm hppa ia64 m68k ppc64 s390 sh sparc"
+PIE_GLIBC_UNSUPPORTED="hppa"
+
+# whether we should split out specs files for multiple {PIE,SSP}-by-default
+# and vanilla configurations.
+SPLIT_SPECS=${SPLIT_SPECS-true}
+
+#GENTOO_PATCH_EXCLUDE=""
+#PIEPATCH_EXCLUDE=""
+
+inherit toolchain eutils
+
+DESCRIPTION="The GNU Compiler Collection. Includes C/C++, java compilers, pie+ssp extensions, Haj Ten Brugge runtime bounds checking"
+
+KEYWORDS="~alpha ~amd64 ~arm ~hppa -ia64 ~mips ~sh ~sparc ~x86"
+
+# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
+# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
+# well tested in gentoo on any arch other than amd64!!
+RDEPEND="virtual/libc
+ >=sys-devel/gcc-config-1.3.10
+ >=sys-libs/zlib-1.1.4
+ !sys-devel/hardened-gcc
+ !uclibc? ( >=sys-libs/glibc-2.3.2-r9 )
+ >=sys-devel/binutils-2.14.90.0.6-r1
+ >=sys-devel/bison-1.875
+ amd64? ( multilib? ( >=app-emulation/emul-linux-x86-glibc-1.1 ) )
+ sparc? ( hardened? ( >=sys-libs/glibc-2.3.3.20040420 ) )
+ !build? (
+ gcj? (
+ gtk? ( >=x11-libs/gtk+-2.2 )
+ >=media-libs/libart_lgpl-2.1
+ )
+ >=sys-libs/ncurses-5.2-r2
+ nls? ( sys-devel/gettext )
+ )"
+
+if [[ ${CATEGORY/cross-} != ${CATEGORY} ]]; then
+ RDEPEND="${RDEPEND} ${CATEGORY}/binutils"
+fi
+
+DEPEND="${RDEPEND}
+ >=sys-apps/texinfo-4.2-r4
+ amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
+PDEPEND="sys-devel/gcc-config"
+
+src_unpack() {
+ gcc_src_unpack
+
+ # bah
+ sed -e 's/3\.3\.6/3.3.5/' -i "${S}"/gcc/version.c
+
+ if [[ -n ${PATCH_VER} ]] && is_uclibc ; then
+ mv ${S}/gcc-3.3.2/libstdc++-v3/config/os/uclibc ${S}/libstdc++-v3/config/os/ || die
+ mv ${S}/gcc-3.3.2/libstdc++-v3/config/locale/uclibc ${S}/libstdc++-v3/config/locale/ || die
+ fi
+
+ # misc patches that havent made it into a patch tarball yet
+ epatch ${FILESDIR}/gcc-spec-env.patch
+
+ # Anything useful and objc will require libffi. Seriously. Lets just force
+ # libffi to install with USE="objc", even though it normally only installs
+ # if you attempt to build gcj.
+ if use !build && use objc && ! use gcj ; then
+ epatch ${FILESDIR}/3.3.4/libffi-without-libgcj.patch
+ #epatch ${FILESDIR}/3.4.3/libffi-nogcj-lib-path-fix.patch
+ fi
+
+ if [[ $(tc-arch) == "amd64" ]] ; then
+ replace-cpu-flags k8 i686
+ replace-cpu-flags opteron i686
+ replace-cpu-flags athlon64 i686
+ fi
+}