summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2013-11-10 10:56:18 +0000
committerAgostino Sarubbo <ago@gentoo.org>2013-11-10 10:56:18 +0000
commit60d957a01701d1566339b6cf7df0386a303ac2e0 (patch)
treecb437e0d09e6b54407f0f6503a597522bc57d1a4 /sys-devel
parentVersion bum. Drop old version. (diff)
downloadgentoo-2-60d957a01701d1566339b6cf7df0386a303ac2e0.tar.gz
gentoo-2-60d957a01701d1566339b6cf7df0386a303ac2e0.tar.bz2
gentoo-2-60d957a01701d1566339b6cf7df0386a303ac2e0.zip
Version bump to 0.16.20
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 7194459F)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/dev86/ChangeLog7
-rw-r--r--sys-devel/dev86/dev86-0.16.20.ebuild77
2 files changed, 83 insertions, 1 deletions
diff --git a/sys-devel/dev86/ChangeLog b/sys-devel/dev86/ChangeLog
index 2cfc1287c27e..04078be15bf2 100644
--- a/sys-devel/dev86/ChangeLog
+++ b/sys-devel/dev86/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/dev86
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/ChangeLog,v 1.27 2013/02/25 11:39:32 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/ChangeLog,v 1.28 2013/11/10 10:56:18 ago Exp $
+
+*dev86-0.16.20 (10 Nov 2013)
+
+ 10 Nov 2013; Agostino Sarubbo <ago@gentoo.org> +dev86-0.16.20.ebuild:
+ Version bump to 0.16.20
25 Feb 2013; Agostino Sarubbo <ago@gentoo.org> dev86-0.16.19.ebuild:
Stable for x86, wrt bug #457478
diff --git a/sys-devel/dev86/dev86-0.16.20.ebuild b/sys-devel/dev86/dev86-0.16.20.ebuild
new file mode 100644
index 000000000000..181681b04f5b
--- /dev/null
+++ b/sys-devel/dev86/dev86-0.16.20.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/dev86/dev86-0.16.20.ebuild,v 1.1 2013/11/10 10:56:18 ago Exp $
+
+EAPI="5"
+
+inherit eutils multilib
+
+DESCRIPTION="Bruce's C compiler - Simple C compiler to generate 8086 code"
+HOMEPAGE="http://v3.sk/~lkundrak/dev86/"
+SRC_URI="http://v3.sk/~lkundrak/dev86/archive/Dev86src-${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="sys-devel/bin86"
+DEPEND="${RDEPEND}
+ dev-util/gperf"
+
+STRIP_MASK="/usr/*/bcc/lib*.a /usr/*/i386/libc.a"
+
+src_prepare() {
+ # elksemu doesn't compile under amd64
+ if use amd64; then
+ einfo "Not compiling elksemu on amd64"
+ sed -i \
+ -e 's,alt-libs elksemu,alt-libs,' \
+ -e 's,install-lib install-emu,install-lib,' \
+ makefile.in || die
+ fi
+
+ epatch "${FILESDIR}"/dev86-pic.patch
+ epatch "${FILESDIR}"/${PN}-0.16.19-fortify.patch
+ sed -i \
+ -e "s:-O2 -g:${CFLAGS}:" \
+ -e '/INEXE=/s:-s::' \
+ makefile.in || die
+ sed -i \
+ -e "s:/lib/:/$(get_libdir)/:" \
+ bcc/bcc.c || die
+ sed -i -e '/INSTALL_OPTS=/s:-s::' bin86/Makefile || die
+ sed -i -e '/install -m 755 -s/s:-s::' dis88/Makefile || die
+}
+
+src_compile() {
+ # Don't mess with CPPFLAGS as they tend to break compilation
+ # (bug #343655).
+ CPPFLAGS=""
+
+ # First `make` is also a config, so set all the path vars here
+ emake -j1 \
+ DIST="${D}" \
+ CC="$(tc-getCC)" \
+ LIBDIR="/usr/$(get_libdir)/bcc" \
+ INCLDIR="/usr/$(get_libdir)/bcc"
+
+ export PATH=${S}/bin:${PATH}
+ cd bin
+ ln -s ncc bcc
+ cd ..
+ cd bootblocks
+ ln -s ../bcc/version.h .
+ emake DIST="${D}"
+}
+
+src_install() {
+ emake -j1 install-all DIST="${D}"
+ dobin bootblocks/makeboot
+ # remove all the stuff supplied by bin86
+ cd "${D}"
+ rm usr/bin/{as,ld,nm,objdump,size}86 || die
+ rm usr/man/man1/{as,ld}86.1 || die
+ dodir /usr/share/man
+ mv usr/man usr/share/
+}