summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2015-05-26 22:25:10 +0000
committerAnthony G. Basile <blueness@gentoo.org>2015-05-26 22:25:10 +0000
commit73d617178a9bec9f663044b95f9dbf001be8f599 (patch)
tree07d453763f49ad8b1e84eb80cc881dcd5480b15f /sys-devel
parentversion bump (diff)
downloadgentoo-2-73d617178a9bec9f663044b95f9dbf001be8f599.tar.gz
gentoo-2-73d617178a9bec9f663044b95f9dbf001be8f599.tar.bz2
gentoo-2-73d617178a9bec9f663044b95f9dbf001be8f599.zip
Version bump.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ct-ng/ChangeLog9
-rw-r--r--sys-devel/ct-ng/ct-ng-1.21.0.ebuild44
2 files changed, 51 insertions, 2 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
index 3ad2c3d9c7a8..85336dc725fa 100644
--- a/sys-devel/ct-ng/ChangeLog
+++ b/sys-devel/ct-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/ct-ng
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.50 2014/10/28 11:29:22 blueness Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.51 2015/05/26 22:25:10 blueness Exp $
+
+*ct-ng-1.21.0 (26 May 2015)
+
+ 26 May 2015; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.21.0.ebuild:
+ Version bump.
*ct-ng-1.19.0-r1 (28 Oct 2014)
*ct-ng-1.20.0-r1 (28 Oct 2014)
diff --git a/sys-devel/ct-ng/ct-ng-1.21.0.ebuild b/sys-devel/ct-ng/ct-ng-1.21.0.ebuild
new file mode 100644
index 000000000000..ef2f631a12d7
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.21.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.21.0.ebuild,v 1.1 2015/05/26 22:25:10 blueness Exp $
+
+EAPI="5"
+
+inherit autotools bash-completion-r1 eutils
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://crosstool-ng.org"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-kconfig-respect-flags.patch
+
+ #Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
+ #We'll use eautoconf to be portage friendly
+ eautoconf -Wall --force
+}
+
+src_configure () {
+ econf --with-install="/usr/bin/install"
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ newbashcomp ${PN}.comp ${PN}
+ dodoc README TODO
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/"${PN}.${PVR}"/* \
+ "${D}"/usr/share/doc/"${PF}"
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}