summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2009-11-27 08:40:03 +0000
committerFabian Groffen <grobian@gentoo.org>2009-11-27 08:40:03 +0000
commit793bae7edd3bfc265043a3b0afdf3087462bd9f1 (patch)
treeb034867b6c69f3a1f14757570db765d428dbb0f2 /sys-devel
parentCleanup and fix charm-6.1.2-r2-charmc-gentoo.patch (diff)
downloadgentoo-2-793bae7edd3bfc265043a3b0afdf3087462bd9f1.tar.gz
gentoo-2-793bae7edd3bfc265043a3b0afdf3087462bd9f1.tar.bz2
gentoo-2-793bae7edd3bfc265043a3b0afdf3087462bd9f1.zip
Turn ewarn into elog for instructions on how to get gdb usable on 10.5+, as it turns out many people don't see these instructions.
(Portage version: 2.2.00.14896-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gdb-apple/ChangeLog7
-rw-r--r--sys-devel/gdb-apple/gdb-apple-962.ebuild14
-rw-r--r--sys-devel/gdb-apple/gdb-apple-966.ebuild14
3 files changed, 20 insertions, 15 deletions
diff --git a/sys-devel/gdb-apple/ChangeLog b/sys-devel/gdb-apple/ChangeLog
index a519e1a34117..266c8bdca72c 100644
--- a/sys-devel/gdb-apple/ChangeLog
+++ b/sys-devel/gdb-apple/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/gdb-apple
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.4 2009/09/25 11:52:08 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/ChangeLog,v 1.5 2009/11/27 08:40:03 grobian Exp $
+
+ 27 Nov 2009; Fabian Groffen <grobian@gentoo.org> gdb-apple-962.ebuild,
+ gdb-apple-966.ebuild:
+ Turn ewarn into elog for instructions on how to get gdb usable on 10.5+,
+ as it turns out many people don't see these instructions.
25 Sep 2009; Fabian Groffen <grobian@gentoo.org> gdb-apple-1344.ebuild,
+files/gdb-apple-1344-darwin8.patch:
diff --git a/sys-devel/gdb-apple/gdb-apple-962.ebuild b/sys-devel/gdb-apple/gdb-apple-962.ebuild
index d3cd80a6531e..ff452845373a 100644
--- a/sys-devel/gdb-apple/gdb-apple-962.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-962.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-962.ebuild,v 1.2 2009/09/26 18:18:01 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-962.ebuild,v 1.3 2009/11/27 08:40:03 grobian Exp $
inherit eutils flag-o-matic
@@ -58,11 +58,11 @@ src_install() {
pkg_postinst() {
if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -ge 9 ]] ; then
- ewarn "Due to increased security measures in 10.5 and up, gdb is"
- ewarn "not able to get a mach task port when installed by Prefix"
- ewarn "Portage, unprivileged. To make gdb fully functional you'll"
- ewarn "have to perform the following steps:"
- ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
- ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ elog "Due to increased security measures in 10.5 and up, gdb is"
+ elog "not able to get a mach task port when installed by Prefix"
+ elog "Portage, unprivileged. To make gdb fully functional you'll"
+ elog "have to perform the following steps:"
+ elog " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ elog " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
fi
}
diff --git a/sys-devel/gdb-apple/gdb-apple-966.ebuild b/sys-devel/gdb-apple/gdb-apple-966.ebuild
index df38945f1705..043a83f7a3bd 100644
--- a/sys-devel/gdb-apple/gdb-apple-966.ebuild
+++ b/sys-devel/gdb-apple/gdb-apple-966.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-966.ebuild,v 1.2 2009/06/24 09:40:20 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb-apple/gdb-apple-966.ebuild,v 1.3 2009/11/27 08:40:03 grobian Exp $
inherit eutils flag-o-matic
@@ -58,11 +58,11 @@ src_install() {
pkg_postinst() {
if [[ ${CHOST} == *-darwin* && ${CHOST#*-darwin} -ge 9 ]] ; then
- ewarn "Due to increased security measures in 10.5 and up, gdb is"
- ewarn "not able to get a mach task port when installed by Prefix"
- ewarn "Portage, unprivileged. To make gdb fully functional you'll"
- ewarn "have to perform the following steps:"
- ewarn " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
- ewarn " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
+ elog "Due to increased security measures in 10.5 and up, gdb is"
+ elog "not able to get a mach task port when installed by Prefix"
+ elog "Portage, unprivileged. To make gdb fully functional you'll"
+ elog "have to perform the following steps:"
+ elog " % sudo chgrp procmod ${EPREFIX}/usr/bin/gdb"
+ elog " % sudo chmod g+s ${EPREFIX}/usr/bin/gdb"
fi
}