summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-05-01 12:26:19 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-05-01 12:26:19 +0000
commit858a068262c0b2b2f04101d1fd1c0187a2461967 (patch)
treeb55047fb078eec63fccf87b01d3c24cc091c167c /sys-devel
parentRemove older alpha (diff)
downloadgentoo-2-858a068262c0b2b2f04101d1fd1c0187a2461967.tar.gz
gentoo-2-858a068262c0b2b2f04101d1fd1c0187a2461967.tar.bz2
gentoo-2-858a068262c0b2b2f04101d1fd1c0187a2461967.zip
Version bump
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ct-ng/ChangeLog7
-rw-r--r--sys-devel/ct-ng/ct-ng-1.15.0.ebuild35
2 files changed, 41 insertions, 1 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
index f48486f868e9..4c68ba42aa7c 100644
--- a/sys-devel/ct-ng/ChangeLog
+++ b/sys-devel/ct-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/ct-ng
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.32 2012/02/15 01:51:56 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.33 2012/05/01 12:26:19 blueness Exp $
+
+*ct-ng-1.15.0 (01 May 2012)
+
+ 01 May 2012; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.15.0.ebuild:
+ Version bump
15 Feb 2012; Anthony G. Basile <blueness@gentoo.org> -ct-ng-1.8.2.ebuild,
-ct-ng-1.9.2.ebuild, -ct-ng-1.10.1.ebuild, -ct-ng-1.11.3.ebuild:
diff --git a/sys-devel/ct-ng/ct-ng-1.15.0.ebuild b/sys-devel/ct-ng/ct-ng-1.15.0.ebuild
new file mode 100644
index 000000000000..196d6deabfd7
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.15.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.15.0.ebuild,v 1.1 2012/05/01 12:26:19 blueness Exp $
+
+EAPI="4"
+
+inherit bash-completion-r1 autotools
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://ymorin.is-a-geek.org/projects/crosstool"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_prepare() {
+ #Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
+ #We'll use eautoconf to be portage friendly
+ eautoconf -Wall --force
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install || die "install failed"
+ dobashcomp ${PN}.comp
+ dodoc README TODO
+}