summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-07-29 15:44:56 +0000
committerMike Frysinger <vapier@gentoo.org>2012-07-29 15:44:56 +0000
commit8c699d5efba0b76757c86d433906476b0f255bdf (patch)
tree34fdacfeb95d0f7a63eb34e95a848be823e85be1 /sys-devel
parentWhitespace. (diff)
downloadgentoo-2-8c699d5efba0b76757c86d433906476b0f255bdf.tar.gz
gentoo-2-8c699d5efba0b76757c86d433906476b0f255bdf.tar.bz2
gentoo-2-8c699d5efba0b76757c86d433906476b0f255bdf.zip
Always apply amd64 build patch, and convert ebuild to EAPI=4 #428228 by Richard Yao.
(Portage version: 2.2.0_alpha116/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bin86/ChangeLog9
-rw-r--r--sys-devel/bin86/bin86-0.16.18.ebuild20
-rw-r--r--sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch4
3 files changed, 18 insertions, 15 deletions
diff --git a/sys-devel/bin86/ChangeLog b/sys-devel/bin86/ChangeLog
index aa63ee3199ba..82a946caa992 100644
--- a/sys-devel/bin86/ChangeLog
+++ b/sys-devel/bin86/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/bin86
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.20 2010/12/07 05:04:10 vapier Exp $
+# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.21 2012/07/29 15:44:56 vapier Exp $
+
+ 29 Jul 2012; Mike Frysinger <vapier@gentoo.org> bin86-0.16.18.ebuild,
+ files/bin86-0.16.17-amd64-build.patch:
+ Always apply amd64 build patch, and convert ebuild to EAPI=4 #428228 by
+ Richard Yao.
*bin86-0.16.18 (07 Dec 2010)
diff --git a/sys-devel/bin86/bin86-0.16.18.ebuild b/sys-devel/bin86/bin86-0.16.18.ebuild
index 9ded497423b3..60fc2d131fda 100644
--- a/sys-devel/bin86/bin86-0.16.18.ebuild
+++ b/sys-devel/bin86/bin86-0.16.18.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.16.18.ebuild,v 1.1 2010/12/07 05:04:08 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.16.18.ebuild,v 1.2 2012/07/29 15:44:56 vapier Exp $
+
+EAPI="4"
inherit toolchain-funcs eutils
@@ -13,9 +15,7 @@ SLOT="0"
KEYWORDS="-* ~amd64 ~x86"
IUSE=""
-src_unpack() {
- unpack ${A}
- cd "${S}"
+src_prepare() {
sed -i \
-e '/^PREFIX/s:=.*:=$(DESTDIR)/usr:' \
-e '/^MANDIR/s:)/man/man1:)/share/man/man1:' \
@@ -24,15 +24,11 @@ src_unpack() {
-e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
Makefile || die
epatch "${FILESDIR}"/${P}-headers.patch #347817
- use amd64 && epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
-}
-
-src_compile() {
- emake CC="$(tc-getCC)" || die
+ epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
+ tc-export CC
}
src_install() {
dodir /usr/bin /usr/share/man/man1
- emake install DESTDIR="${D}" || die
- dodoc README* ChangeLog
+ default
}
diff --git a/sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch b/sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch
index 496d79020383..b494a8b724de 100644
--- a/sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch
+++ b/sys-devel/bin86/files/bin86-0.16.17-amd64-build.patch
@@ -1,5 +1,7 @@
This should make it built on other archictectures as well
+https://bugs.gentoo.org/428228
+
--- ld/x86_aout.h
+++ ld/x86_aout.h
@@ -13,7 +13,9 @@
@@ -8,7 +10,7 @@ This should make it built on other archictectures as well
#else
-typedef char Long[4];
+#define __OUT_OK 1
-+#include <sys/types.h>
++#include <inttypes.h>
+typedef int32_t Long;
#endif