summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2001-08-29 05:57:29 +0000
committerDaniel Robbins <drobbins@gentoo.org>2001-08-29 05:57:29 +0000
commit99fb2b1c06b37f48d9ab2c2caf369e5b11e25c06 (patch)
treef168a897151fd271910a585f2d86f6d018ef948a /sys-devel
parentremoved dep change (diff)
downloadgentoo-2-99fb2b1c06b37f48d9ab2c2caf369e5b11e25c06.tar.gz
gentoo-2-99fb2b1c06b37f48d9ab2c2caf369e5b11e25c06.tar.bz2
gentoo-2-99fb2b1c06b37f48d9ab2c2caf369e5b11e25c06.zip
fixums
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/binutils/binutils-2.11.90.0.7.ebuild38
1 files changed, 11 insertions, 27 deletions
diff --git a/sys-devel/binutils/binutils-2.11.90.0.7.ebuild b/sys-devel/binutils/binutils-2.11.90.0.7.ebuild
index dd8c018e5820..5687dea446cf 100644
--- a/sys-devel/binutils/binutils-2.11.90.0.7.ebuild
+++ b/sys-devel/binutils/binutils-2.11.90.0.7.ebuild
@@ -1,41 +1,27 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2001 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.90.0.7.ebuild,v 1.1 2001/05/10 15:11:41 achim Exp $
+# Maintainer: System Team <system@gentoo.org>
+# Author: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.11.90.0.7.ebuild,v 1.2 2001/08/29 05:57:29 drobbins Exp $
-A=${P}.tar.gz
S=${WORKDIR}/${P}
DESCRIPTION="Tools necessary to build programs"
-SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${A}"
+SRC_URI="http://ftp.kernel.org/pub/linux/devel/binutils/${P}.tar.gz"
-if [ -z "`use build`" ] ; then
- DEPEND="nls? ( sys-devel/gettext )"
-fi
+DEPEND="virtual/glibc"
src_compile() {
-
- local myconf
- if [ "`use nls`" ]
- then
- if [ "`use build`" ] ; then
- myconf="--with-included-gettext"
- fi
- else
- myconf="--disable-nls"
- fi
- try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf}
+ ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} --without-included-gettext || die
if [ "`use static`" ]
then
- try make -e LDFLAGS=-all-static ${MAKEOPTS}
+ emake -e LDFLAGS=-all-static || die
else
- try make ${MAKEOPTS}
+ emake || die
fi
}
src_install() {
-
- try make prefix=${D}/usr mandir=${D}/usr/share/man install
-
+ make prefix=${D}/usr mandir=${D}/usr/share/man install || die
if [ -z "`use build`" ]
then
dodoc COPYING* README
@@ -44,8 +30,7 @@ src_install() {
docinto binutils
dodoc binutils/ChangeLog binutils/NEWS binutils/README
docinto gas
- dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING \
- gas/NEWS gas/README*
+ dodoc gas/ChangeLog* gas/CONTRIBUTORS gas/COPYING gas/NEWS gas/README*
docinto gprof
dodoc gprof/ChangeLog* gprof/NOTES gprof/TEST gprof/TODO
docinto ld
@@ -57,7 +42,6 @@ src_install() {
else
rm -rf ${D}/usr/share/man
fi
-
}