summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-02-01 23:16:57 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-02-01 23:16:57 +0000
commita10eb3b67aa8abe8c789e57eee018519893ca07d (patch)
treecf24aa2b5f24ec4beeef9091d43977e8b8662ba5 /sys-devel
parentRemove obsolete/unused patches. (diff)
downloadgentoo-2-a10eb3b67aa8abe8c789e57eee018519893ca07d.tar.gz
gentoo-2-a10eb3b67aa8abe8c789e57eee018519893ca07d.tar.bz2
gentoo-2-a10eb3b67aa8abe8c789e57eee018519893ca07d.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/ct-ng/ChangeLog9
-rw-r--r--sys-devel/ct-ng/ct-ng-1.18.0.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/sys-devel/ct-ng/ChangeLog b/sys-devel/ct-ng/ChangeLog
index 06da8e24f43f..9c458f6162b5 100644
--- a/sys-devel/ct-ng/ChangeLog
+++ b/sys-devel/ct-ng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/ct-ng
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.42 2012/11/14 23:02:32 blueness Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ChangeLog,v 1.43 2013/02/01 23:16:57 blueness Exp $
+
+*ct-ng-1.18.0 (01 Feb 2013)
+
+ 01 Feb 2013; Anthony G. Basile <blueness@gentoo.org> +ct-ng-1.18.0.ebuild:
+ Version bump
14 Nov 2012; Anthony G. Basile <blueness@gentoo.org> ct-ng-1.12.4.ebuild,
ct-ng-1.13.4.ebuild, ct-ng-1.14.1.ebuild, ct-ng-1.15.3.ebuild,
diff --git a/sys-devel/ct-ng/ct-ng-1.18.0.ebuild b/sys-devel/ct-ng/ct-ng-1.18.0.ebuild
new file mode 100644
index 000000000000..170bb26d6266
--- /dev/null
+++ b/sys-devel/ct-ng/ct-ng-1.18.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ct-ng/ct-ng-1.18.0.ebuild,v 1.1 2013/02/01 23:16:57 blueness Exp $
+
+EAPI="4"
+
+inherit autotools bash-completion-r1 eutils
+
+DESCRIPTION="crosstool-ng is a tool to build cross-compiling toolchains"
+HOMEPAGE="http://crosstool-ng.org"
+MY_P=${P/ct/crosstool}
+S=${WORKDIR}/${MY_P}
+SRC_URI="http://ymorin.is-a-geek.org/download/crosstool-ng/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bash-completion doc"
+
+RDEPEND="net-misc/curl
+ dev-util/gperf
+ dev-vcs/cvs
+ dev-vcs/subversion"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-kconfig-respect-flags.patch
+
+ #Upstream provides ${S}/bootstrap which runs autoconf -Wall --force
+ #We'll use eautoconf to be portage friendly
+ eautoconf -Wall --force
+}
+
+src_install() {
+ emake DESTDIR="${D%/}" install
+ dobashcomp ${PN}.comp
+ dodoc README TODO
+ use doc && mv "${D}"/usr/share/doc/crosstool-ng/"${PN}.${PVR}"/* \
+ "${D}"/usr/share/doc/"${PF}"
+ rm -rf "${D}"/usr/share/doc/crosstool-ng
+}