summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-10-07 22:02:39 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-10-07 22:02:39 +0000
commita4cceeb87efd291c46b9ff0cc51608b61eacfc58 (patch)
treefa2c10f5271b7cd39faa1e837022cf375706d5ff /sys-devel
parentFix a bug in AC_HELP_STRING definition, bug #29961, thanks to TGL (diff)
downloadgentoo-2-a4cceeb87efd291c46b9ff0cc51608b61eacfc58.tar.gz
gentoo-2-a4cceeb87efd291c46b9ff0cc51608b61eacfc58.tar.bz2
gentoo-2-a4cceeb87efd291c46b9ff0cc51608b61eacfc58.zip
Fix a bug in AC_HELP_STRING definition, bug #29961, thanks to TGL
<degrenier@easyconnect.fr> for tracking the problem.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog12
-rw-r--r--sys-devel/autoconf/Manifest4
-rw-r--r--sys-devel/autoconf/autoconf-2.57a-r1.ebuild143
-rw-r--r--sys-devel/autoconf/files/autoconf-2.57a-AC_HELP_STRING.patch14
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.57a-r12
5 files changed, 172 insertions, 3 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 3b5255ab36b5..04910603f20f 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.27 2003/09/28 14:45:44 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.28 2003/10/07 22:02:28 azarah Exp $
+
+*autoconf-2.57a-r1 (08 Oct 2003)
+
+ 08 Oct 2003; Martin Schlemmer <azarah@gentoo.org> autoconf-2.57a-r1.ebuild,
+ files/autoconf-2.57a-AC_HELP_STRING.patch:
+ Fix a bug in AC_HELP_STRING definition, bug #29961, thanks to TGL
+ <degrenier@easyconnect.fr> for tracking the problem.
+
+ 07 Oct 2003; Martin Schlemmer <azarah@gentoo.org> autoconf-2.57a.ebuild:
+ This breaks a few things, including ntp, etc.
*autoconf-2.57a (28 Sep 2003)
diff --git a/sys-devel/autoconf/Manifest b/sys-devel/autoconf/Manifest
index 65f139a80f22..e371b318edf6 100644
--- a/sys-devel/autoconf/Manifest
+++ b/sys-devel/autoconf/Manifest
@@ -4,9 +4,9 @@ MD5 512a24f6969c9f497f2d94c77a7b549c autoconf-2.53a.ebuild 2782
MD5 0e3dddf05f2b4efa229843d9a1201410 autoconf-2.54.ebuild 3205
MD5 f73eea253e36a72484edff7fe1ca1086 autoconf-2.13-r2.ebuild 989
MD5 154a8e475e893a398434d0b77f6bc9fc autoconf-2.57a.ebuild 3269
-MD5 37550cf54bd5506bf8d333561070ac03 ChangeLog 4437
+MD5 3935cfd6a39ecb4fec96590af0838937 ChangeLog 4718
MD5 98662b30b8641482848514c4b26efede autoconf-2.57-r1.ebuild 3216
-MD5 6bbf4d4a1302d418df66b29306303f09 autoconf-2.57a-r1.ebuild 3371
+MD5 3ccbd266e1fd59b19de72b2a96bce6c6 autoconf-2.57a-r1.ebuild 3374
MD5 28795f22763ef0683a8a1e72e8dd4646 files/ac-wrapper.pl 2133
MD5 f2802f3155defa9299baf6e5d0d79571 files/digest-autoconf-2.57a 132
MD5 c98042870fa4228b40ce57442d91ca47 files/autoconf-2.57a-infopage-namechange.patch 5119
diff --git a/sys-devel/autoconf/autoconf-2.57a-r1.ebuild b/sys-devel/autoconf/autoconf-2.57a-r1.ebuild
new file mode 100644
index 000000000000..93ca0a079ef3
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.57a-r1.ebuild
@@ -0,0 +1,143 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.57a-r1.ebuild,v 1.1 2003/10/07 22:02:28 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+OLD_PV="2.13"
+OLD_P="${PN}-${OLD_PV}"
+S="${WORKDIR}/${P}"
+OLD_S="${WORKDIR}/${OLD_P}"
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://alpha.gnu.org/gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${P}.tar.bz2
+ mirror://gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="~amd64 ~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm ~ia64"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ ~sys-devel/m4-1.4
+ dev-lang/perl"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${OLD_S}
+ epatch ${FILESDIR}/${OLD_P}-configure-gentoo.diff
+ epatch ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff
+
+ cd ${S}
+ # Enable both autoconf-2.1 and autoconf-2.5 info pages
+ epatch ${FILESDIR}/${PN}-2.57a-infopage-namechange.patch
+ ln -snf ${S}/doc/autoconf.texi ${S}/doc/autoconf25.texi
+
+ # Fix a bug in AC_HELP_STRING definition, bug #29961.
+ epatch ${FILESDIR}/${P}-AC_HELP_STRING.patch
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+
+ perl -pi -e 's|\* Autoconf:|\* Autoconf v2.1:|' autoconf.texi
+ cp autoconf.texi autoconf.texi.orig
+ sed -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
+ autoconf.texi.orig > autoconf.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ doexe ${FILESDIR}/ac-wrapper.pl
+ dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+# mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/autoconf/files/autoconf-2.57a-AC_HELP_STRING.patch b/sys-devel/autoconf/files/autoconf-2.57a-AC_HELP_STRING.patch
new file mode 100644
index 000000000000..c0a2cdff18ea
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.57a-AC_HELP_STRING.patch
@@ -0,0 +1,14 @@
+diff -u -r1.817 -r1.818
+--- autoconf/lib/autoconf/general.m4 2003/08/21 17:25:31 1.817
++++ autoconf/lib/autoconf/general.m4 2003/09/26 09:11:23 1.818
+@@ -215,11 +215,8 @@
+
+
+ # AU::AC_HELP_STRING(LHS, RHS, [COLUMN])
+-# ----------------------------------
+-AU_DEFUN([AC_HELP_STRING],
+-[AS_HELP_STRING([$@])dnl
+-])
+-
++# --------------------------------------
++AU_ALIAS([AC_HELP_STRING], [AS_HELP_STRING])
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.57a-r1 b/sys-devel/autoconf/files/digest-autoconf-2.57a-r1
new file mode 100644
index 000000000000..469bd54bbd78
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.57a-r1
@@ -0,0 +1,2 @@
+MD5 61297397b9c5740132c34e32d7967ac1 autoconf-2.57a.tar.bz2 839100
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844