summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAchim Gottinger <achim@gentoo.org>2001-03-06 05:27:28 +0000
committerAchim Gottinger <achim@gentoo.org>2001-03-06 05:27:28 +0000
commitb0796da85f5fcf2897347016bd70674912db3061 (patch)
tree4e03661facbcc345c6444e4f17373d67398055c1 /sys-devel
parentNew packages for gnome-1.4_beta2 used in rc4 (diff)
downloadgentoo-2-b0796da85f5fcf2897347016bd70674912db3061.tar.gz
gentoo-2-b0796da85f5fcf2897347016bd70674912db3061.tar.bz2
gentoo-2-b0796da85f5fcf2897347016bd70674912db3061.zip
*** empty log message ***
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/autoconf-2.13-r2.ebuild14
-rw-r--r--sys-devel/bc/bc-1.06-r1.ebuild4
-rw-r--r--sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild7
-rw-r--r--sys-devel/gdb/gdb-5.0-r2.ebuild12
-rw-r--r--sys-devel/gettext/gettext-0.10.35-r2.ebuild14
-rw-r--r--sys-devel/ld.so/ld.so-1.9.11-r2.ebuild8
-rw-r--r--sys-devel/m4/m4-1.4o-r2.ebuild12
-rw-r--r--sys-devel/perl/perl-5.6.0-r6.ebuild19
-rw-r--r--sys-devel/spython/spython-2.0-r4.ebuild4
9 files changed, 61 insertions, 33 deletions
diff --git a/sys-devel/autoconf/autoconf-2.13-r2.ebuild b/sys-devel/autoconf/autoconf-2.13-r2.ebuild
index b41ad300847e..56cb9280c03d 100644
--- a/sys-devel/autoconf/autoconf-2.13-r2.ebuild
+++ b/sys-devel/autoconf/autoconf-2.13-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.13-r2.ebuild,v 1.1 2001/02/07 16:05:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.13-r2.ebuild,v 1.2 2001/03/06 05:27:28 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,8 +10,16 @@ SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/autoconf/${A}
ftp://prep.ai.mit.edu/gnu/autoconf/${A}"
HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
-DEPEND="sys-devel/perl
- >=sys-devel/m4-1.4o-r2"
+DEPEND=">=sys-devel/m4-1.4o-r2"
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+ patch -p0 < ${FILESDIR}/${P}-configure-gentoo.diff
+ patch -p0 < ${FILESDIR}/${P}-configure.in-gentoo.diff
+
+}
src_compile() {
diff --git a/sys-devel/bc/bc-1.06-r1.ebuild b/sys-devel/bc/bc-1.06-r1.ebuild
index ae06e7dfc47c..98fdaf9678b5 100644
--- a/sys-devel/bc/bc-1.06-r1.ebuild
+++ b/sys-devel/bc/bc-1.06-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r1.ebuild,v 1.1 2001/02/07 16:05:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bc/bc-1.06-r1.ebuild,v 1.2 2001/03/06 05:27:28 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -11,7 +11,7 @@ SRC_URI="ftp://gatekeeper.dec.com/pub/GNU/bc/${A}
HOMEPAGE="http://www.gnu.org/software/bc/bc.html"
DEPEND="virtual/glibc
- readline? ( >=sys-libs/readline-4.1 )"
+ readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
src_compile() {
diff --git a/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild b/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild
index 11db3f296993..95694bb5b955 100644
--- a/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild
+++ b/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild,v 1.1 2001/02/27 17:21:15 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/binutils/binutils-2.10.91.0.2-r1.ebuild,v 1.2 2001/03/06 05:27:28 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -17,7 +17,7 @@ src_compile() {
then
myconf="--disable-nls"
fi
- try ./configure --prefix=/usr --host=${CHOST} ${myconf}
+ try ./configure --prefix=/usr --mandir=/usr/share/man --host=${CHOST} ${myconf}
if [ "`use static`" ]
then
try make -e LDFLAGS=-all-static ${MAKEOPTS}
@@ -28,11 +28,10 @@ src_compile() {
src_install() {
- try make prefix=${D}/usr install
+ try make prefix=${D}/usr mandir=${D}/usr/share/man install
if [ -z "`use build`" ]
then
- rm -rf ${D}/usr/share
dodoc COPYING* README
docinto bfd
dodoc bfd/ChangeLog* bfd/COPYING bfd/README bfd/PORTING bfd/TODO
diff --git a/sys-devel/gdb/gdb-5.0-r2.ebuild b/sys-devel/gdb/gdb-5.0-r2.ebuild
index 87afa4fcd25d..c1b966e5102b 100644
--- a/sys-devel/gdb/gdb-5.0-r2.ebuild
+++ b/sys-devel/gdb/gdb-5.0-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.0-r2.ebuild,v 1.4 2001/02/07 21:04:43 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gdb/gdb-5.0-r2.ebuild,v 1.5 2001/03/06 05:27:28 achim Exp $
A=${P}.tar.bz2
S=${WORKDIR}/${P}
@@ -10,15 +10,21 @@ SRC_URI="ftp://sourceware.cygnus.com/pub/gdb/releases/${A}
ftp://ftp.freesoftware.com/pub/sourceware/gdb/releases/${A}"
DEPEND=">=sys-libs/ncurses-5.2-r2
- sys-devel/gettext"
+ nls? ( sys-devel/gettext )"
RDEPEND=">=sys-libs/ncurses-5.2-r2"
HOMEPAGE="http://www.gnu.org/software/gdb/gdb.html"
src_compile() {
+
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
try ./configure --prefix=/usr --mandir=/usr/share/man --infodir=/usr/share/info \
- --without-included-regex --without-included-gettext --host=${CHOST}
+ --without-included-regex --without-included-gettext --host=${CHOST} ${myconf}
try make ${MAKEOPTS}
}
diff --git a/sys-devel/gettext/gettext-0.10.35-r2.ebuild b/sys-devel/gettext/gettext-0.10.35-r2.ebuild
index 22383c70ffe8..7898a49c2102 100644
--- a/sys-devel/gettext/gettext-0.10.35-r2.ebuild
+++ b/sys-devel/gettext/gettext-0.10.35-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.10.35-r2.ebuild,v 1.2 2001/02/15 18:17:32 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gettext/gettext-0.10.35-r2.ebuild,v 1.3 2001/03/06 05:27:28 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -13,10 +13,14 @@ HOMEPAGE="http://www.gnu.org/software/gettext/gettext.html"
DEPEND="virtual/glibc"
src_compile() {
-
- try ./configure --prefix=/usr --infodir=/usr/share/info \
- --with-included-gettext --enable-shared --host=${CHOST}
- try make ${MAKEOPTS}
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
+ try ./configure --prefix=/usr --infodir=/usr/share/info \
+ --with-included-gettext --enable-shared --host=${CHOST} ${myconf}
+ try make ${MAKEOPTS}
}
src_install() {
diff --git a/sys-devel/ld.so/ld.so-1.9.11-r2.ebuild b/sys-devel/ld.so/ld.so-1.9.11-r2.ebuild
index 5b54eff17640..7a06646e6e97 100644
--- a/sys-devel/ld.so/ld.so-1.9.11-r2.ebuild
+++ b/sys-devel/ld.so/ld.so-1.9.11-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/ld.so/ld.so-1.9.11-r2.ebuild,v 1.1 2001/02/07 16:05:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/ld.so/ld.so-1.9.11-r2.ebuild,v 1.2 2001/03/06 05:27:28 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -23,9 +23,9 @@ src_install() {
PREFIX=${D} ./instldso.sh --force
- # Remove stuff that comes with glibc
- rm -rf ${D}/sbin
- rm ${D}/usr/share/man/man8/ldconfig*
+ # Remove stuff that comes with glibc
+ rm -rf ${D}/sbin ${D}/usr/bin
+ rm ${D}/usr/share/man/man8/ldconfig*
preplib /
diff --git a/sys-devel/m4/m4-1.4o-r2.ebuild b/sys-devel/m4/m4-1.4o-r2.ebuild
index f079477bcfe7..9e23751f0f69 100644
--- a/sys-devel/m4/m4-1.4o-r2.ebuild
+++ b/sys-devel/m4/m4-1.4o-r2.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4o-r2.ebuild,v 1.3 2001/02/07 16:05:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4o-r2.ebuild,v 1.4 2001/03/06 05:27:28 achim Exp $
A=${P}.tar.gz
S=${WORKDIR}/${P}
@@ -10,16 +10,20 @@ SRC_URI="ftp://ftp.seindal.dk/gnu/${A}"
HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
DEPEND="virtual/glibc
- sys-devel/gettext
+ nls? ( sys-devel/gettext )
>=sys-devel/libtool-1.3.5-r2"
RDEPEND="virtual/glibc"
src_compile() {
-
+ local myconf
+ if [ -z "`use nls`" ]
+ then
+ myconf="--disable-nls"
+ fi
try ./configure --prefix=/usr --libexecdir=/usr/lib \
--mandir=/usr/share/man --infodir=/usr/share/info \
- --with-modules --host=${CHOST}
+ --with-modules --host=${CHOST} ${myconf}
try make ${MAKEOPTS}
}
diff --git a/sys-devel/perl/perl-5.6.0-r6.ebuild b/sys-devel/perl/perl-5.6.0-r6.ebuild
index 2060b4b91fcf..cd6aaf8ceab2 100644
--- a/sys-devel/perl/perl-5.6.0-r6.ebuild
+++ b/sys-devel/perl/perl-5.6.0-r6.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.0-r6.ebuild,v 1.1 2001/02/07 16:05:19 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.0-r6.ebuild,v 1.2 2001/03/06 05:27:28 achim Exp $
A=${P}.tar.gz
@@ -23,8 +23,10 @@ test -d \$installprefix || mkdir \$installprefix
test -d \$installprefix/bin || mkdir \$installprefix/bin
installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
-installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
-installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
+installman1dir=\$installprefix/share/man/man1
+installman3dir=\$installprefix/share/man/man3
+installman1ext=1
+installman3ext=3pl
installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
@@ -38,7 +40,9 @@ EOF
fi
if [ "`use berkdb`" ]
then
- myconf="${myconf} -Di_db"
+ myconf="${myconf} -Di_db -Di_ndbm"
+ else
+ myconf="${myconf} -Ui_db -Ui_ndbm"
fi
sh Configure -des -Dprefix=/usr -Dd_dosuid \
-Dd_semctl_semun ${myconf} -Duselargefiles \
@@ -56,7 +60,10 @@ EOF
}
src_install() {
- try make install
+
+ export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+
+ try make man1ext=1 man3ext=3pl install
install -m 755 utils/pl2pm ${D}/usr/bin/pl2pm
# Generate *.ph files with a trick. Is this sick or what?
@@ -88,7 +95,7 @@ EOF
#man pages
- ./perl installman --man1dir=${D}/usr/share/man/man1 --man1ext=1 --man3dir=${D}/usr/share/man/man3 --man3ext=3
+# ./perl installman --man1dir=${D}/usr/share/man/man1 --man1ext=1 --man3dir=${D}/usr/share/man/man3 --man3ext=3
# This removes ${D} from Config.pm
diff --git a/sys-devel/spython/spython-2.0-r4.ebuild b/sys-devel/spython/spython-2.0-r4.ebuild
index 1790d0e5f750..8fcd9d61a73f 100644
--- a/sys-devel/spython/spython-2.0-r4.ebuild
+++ b/sys-devel/spython/spython-2.0-r4.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2000 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
# Author Daniel Robbins <drobbins@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r4.ebuild,v 1.2 2001/02/27 18:26:17 achim Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/spython/spython-2.0-r4.ebuild,v 1.3 2001/03/06 05:27:28 achim Exp $
S=${WORKDIR}/Python-2.0
S2=${WORKDIR}/python-fchksum-1.1
@@ -11,7 +11,7 @@ SRC_URI="http://www.python.org/ftp/python/src/BeOpen-Python-2.0.tar.bz2
HOMEPAGE="http://www.python.org http://www.azstarnet.com/~donut/programs/fchksum/"
-DEPEND=">=sys-libs/zlib-1.1.3-r2 readline? ( >=sys-libs/readline-4.1-r2 )"
+DEPEND=">=sys-libs/zlib-1.1.3 readline? ( >=sys-libs/readline-4.1 >=sys-libs/ncurses-5.2 )"
RDEPEND="virtual/glibc"
PROVIDE="virtual/python-2.0"