summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2006-03-06 23:26:38 +0000
committerMike Frysinger <vapier@gentoo.org>2006-03-06 23:26:38 +0000
commitb324ffa34a7557ec552182941a76ad8b7d9311be (patch)
treea36bc7306a38ee266f5de660ccb479888361cdf9 /sys-devel
parentupdate avr patches (diff)
downloadgentoo-2-b324ffa34a7557ec552182941a76ad8b7d9311be.tar.gz
gentoo-2-b324ffa34a7557ec552182941a76ad8b7d9311be.tar.bz2
gentoo-2-b324ffa34a7557ec552182941a76ad8b7d9311be.zip
some cross-compile fixes
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-4.1.0.ebuild10
1 files changed, 9 insertions, 1 deletions
diff --git a/sys-devel/gcc/gcc-4.1.0.ebuild b/sys-devel/gcc/gcc-4.1.0.ebuild
index 77235879efcb..4febc250dabf 100644
--- a/sys-devel/gcc/gcc-4.1.0.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0.ebuild,v 1.4 2006/03/05 08:18:46 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0.ebuild,v 1.5 2006/03/06 23:26:38 vapier Exp $
PATCH_VER="1.0"
UCLIBC_VER="1.0"
@@ -49,3 +49,11 @@ DEPEND="${RDEPEND}
PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( =virtual/libstdc++-3.3 ) ) ) )"
+src_unpack() {
+ gcc_src_unpack
+
+ # Fix cross-compiling
+ epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-cross-compile.patch
+
+ [[ ${CTARGET} == *-softfloat-* ]] && epatch "${FILESDIR}"/4.0.2/gcc-4.0.2-softfloat.patch
+}