summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2003-08-13 22:14:09 +0000
committerLisa M. Seelye <lisa@gentoo.org>2003-08-13 22:14:09 +0000
commitb38109609f0af87d709e48b2935af84776b0eab7 (patch)
tree4c428f42fbc81d0cc1f6c556fae0abb0e6cb1578 /sys-devel
parentFix the ebuild. should be doing distcc-config --install, too (diff)
downloadgentoo-2-b38109609f0af87d709e48b2935af84776b0eab7.tar.gz
gentoo-2-b38109609f0af87d709e48b2935af84776b0eab7.tar.bz2
gentoo-2-b38109609f0af87d709e48b2935af84776b0eab7.zip
Fix the ebuild. should be doing distcc-config --install, too
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/distcc/ChangeLog7
-rw-r--r--sys-devel/distcc/Manifest4
-rw-r--r--sys-devel/distcc/distcc-2.10-r1.ebuild111
-rw-r--r--sys-devel/distcc/files/digest-distcc-2.10-r11
4 files changed, 120 insertions, 3 deletions
diff --git a/sys-devel/distcc/ChangeLog b/sys-devel/distcc/ChangeLog
index c4e2361559a8..8a616077116d 100644
--- a/sys-devel/distcc/ChangeLog
+++ b/sys-devel/distcc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/distcc
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.69 2003/08/12 16:39:13 lisa Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/ChangeLog,v 1.70 2003/08/13 22:13:59 lisa Exp $
+
+*distcc-2.10-r1 (13 Aug 2003)
+
+ 13 Aug 2003; Lisa Seelye <lisa@gentoo.org> distcc-2.10-r1.ebuild:
+ Fix the ebuild. should be doing distcc-config --install, too
12 Aug 2003; Lisa Seelye <lisa@gentoo.org> distcc-2.9.ebuild:
Mark distcc 2.9 stable on x86.
diff --git a/sys-devel/distcc/Manifest b/sys-devel/distcc/Manifest
index 509908ca4e6b..7ad59c227a04 100644
--- a/sys-devel/distcc/Manifest
+++ b/sys-devel/distcc/Manifest
@@ -1,9 +1,9 @@
MD5 c68dd76338384f0a996204db7364f8f7 distcc-2.8-r2.ebuild 3357
-MD5 f9a2a43461dff0f4153caddf2dc09522 distcc-2.10-r1.ebuild 3486
+MD5 ff26d9e0a5f8d639aa1f2810187d9012 distcc-2.10-r1.ebuild 3489
MD5 564b09fcdf279623746f23731af6cdef distcc-2.5-r1.ebuild 3209
MD5 8cfcda064781a10ddcddbc85f43b032a distcc-2.10.ebuild 3451
MD5 03093b58cdb18091e8d8abf43119fe04 distcc-2.9.ebuild 3445
-MD5 67075f14f26a326469f73490b0ee66f8 ChangeLog 11969
+MD5 77e4db77f32b05a32e2d2ea7e1d2d0d1 ChangeLog 12132
MD5 70619e7eb5fa4fd0aa4f3588579cd50d metadata.xml 443
MD5 ade4e8cda892045944e204fc2c3df8bd files/digest-distcc-2.9 63
MD5 996b45704fdf266745dfc2e6038a1f76 files/digest-distcc-2.10-r1 64
diff --git a/sys-devel/distcc/distcc-2.10-r1.ebuild b/sys-devel/distcc/distcc-2.10-r1.ebuild
new file mode 100644
index 000000000000..92a2fdccbd44
--- /dev/null
+++ b/sys-devel/distcc/distcc-2.10-r1.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/distcc/distcc-2.10-r1.ebuild,v 1.1 2003/08/13 22:13:59 lisa Exp $
+
+inherit eutils gcc flag-o-matic
+[ `gcc-major-version` -eq 2 ] && filter-flags -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE
+
+HOMEPAGE="http://distcc.samba.org/"
+SRC_URI="http://distcc.samba.org/ftp/distcc/distcc-${PV}.tar.bz2"
+DESCRIPTION="a program to distribute compilation of C code across several machines on a network"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~hppa ~mips ~arm"
+IUSE="gtk"
+
+DEPEND=">=sys-apps/portage-2.0.46-r11
+ >=sys-devel/gcc-config-1.3.1
+ sys-apps/shadow"
+
+RDEPEND="gtk? ( >=x11-libs/gtk+-2.2.1 )
+ selinux? ( sec-policy/selinux-distcc )"
+
+
+src_compile() {
+ local myconf="--with-included-popt "
+ #Here we use the built in parse-options package. It saves a dependancy
+
+ use gtk && myconf="--enable-gnome"
+
+ econf ${myconf} || die "econf ${myconf} failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D%/}" install
+
+ insinto /usr/share/doc/${PN}
+ doins "${S}/survey.txt"
+
+ exeinto /usr/bin
+ doexe "${FILESDIR}/${PV}/distcc-config"
+
+ insinto /etc/conf.d
+ newins "${FILESDIR}/${PV}/conf" distccd
+
+ exeinto /etc/init.d
+ newexe "${FILESDIR}/${PV}/init" distccd
+
+ # create and keep the symlink dir
+ dodir /usr/lib/distcc/bin
+ keepdir /usr/lib/distcc/bin
+
+ # create the distccd pid directory
+ dodir /var/run/distccd
+ keepdir /var/run/distccd
+}
+
+pkg_preinst() {
+ # non-/ installs don't require us to do anything here
+ [ "${ROOT}" != "/" ] && return 0
+
+ # stop daemon since script is being updated
+ [ -n "$(pidof distccd)" -a -x /etc/init.d/distccd ] && \
+ /etc/init.d/distccd stop
+
+ # moved user creation and permissions to distcc-config script
+ # because of ROOT install requirements
+}
+
+pkg_postinst() {
+ # handle DISTCC_HOSTS upgrade better
+ local ENVFILE
+ ENVFILE="${ROOT}etc/env.d/02distcc"
+ [ ! -f "${ENVFILE}" ] && \
+ ENVFILE="${ROOT}etc/env.d/04distcc"
+ if [ -f "${ENVFILE}" ]
+ then
+ # save hosts to new file
+ ROOT="${ROOT}" ${ROOT}usr/bin/distcc-config --set-hosts \
+ $(egrep '^DISTCC_HOSTS' "${ENVFILE}" | sed 's,[^=]*=,,')
+ # now remove from the file
+ grep -v 'DISTCC_HOSTS' "${ENVFILE}" > "${ENVFILE}.new"
+ mv "${ENVFILE}.new" "${ENVFILE}"
+ fi
+
+ if [ "${ROOT}" = "/" ]; then
+ einfo "Installing links to native compilers..."
+ /usr/bin/distcc-config --install-user
+ /usr/bin/distcc-config --install-links
+ /usr/bin/distcc-config --install-links "${CHOST}"
+ /usr/bin/distcc-config --install
+ else
+ # distcc-config can *almost* handle ROOT installs itself
+ # but for now, but user must finsh things off
+ ewarn "*** Installation is not complete ***"
+ ewarn "You must run the following as root:"
+ ewarn " /usr/bin/distcc-config --install"
+ ewarn "after booting or chrooting into ${ROOT}"
+ fi
+ einfo "Tips on using distcc with Gentoo can be found at"
+ einfo "http://www.gentoo.org/doc/en/distcc.xml"
+ echo ""
+ einfo "As of this release (2.10), you can specify where you want state"
+ einfo "files to go (these are for monitoring). You can specify this setting"
+ einfo "in /etc/make.conf by setting DISTCC_DIR to somewhere portage can write to"
+ einfo "such as /tmp, also, change it in /etc/conf.d/distccd."
+ echo ""
+ einfo "To use the distccmon programs with Gentoo you should use this command:"
+ einfo " sudo -H -u portage distccmon-text OR sudo -H -u portage distccmon-gnome"
+}
diff --git a/sys-devel/distcc/files/digest-distcc-2.10-r1 b/sys-devel/distcc/files/digest-distcc-2.10-r1
new file mode 100644
index 000000000000..0dbf80357d04
--- /dev/null
+++ b/sys-devel/distcc/files/digest-distcc-2.10-r1
@@ -0,0 +1 @@
+MD5 044474020e864123b01aaa1c06fc831a distcc-2.10.tar.bz2 239769