summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Zacarias <gustavoz@gentoo.org>2005-06-23 18:24:20 +0000
committerGustavo Zacarias <gustavoz@gentoo.org>2005-06-23 18:24:20 +0000
commitb45022d78e3799f10c3ce012793daf156ee04bfc (patch)
tree45b1c912ab1b39ec484195c9a14795b6b6ff6f87 /sys-devel
parentinitial import (diff)
downloadgentoo-2-b45022d78e3799f10c3ce012793daf156ee04bfc.tar.gz
gentoo-2-b45022d78e3799f10c3ce012793daf156ee04bfc.tar.bz2
gentoo-2-b45022d78e3799f10c3ce012793daf156ee04bfc.zip
Added new avr target device support with blessing from spanky
(Portage version: 2.0.51.19)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog6
-rw-r--r--sys-devel/gcc/files/3.4.4/gcc-3.4_x-avr-news-devs2.patch124
-rw-r--r--sys-devel/gcc/gcc-3.4.4.ebuild5
3 files changed, 133 insertions, 2 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index d8b8d1763e76..8d8f301343d2 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.422 2005/06/18 22:42:25 halcy0n Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.423 2005/06/23 18:24:20 gustavoz Exp $
+
+ 23 Jun 2005; Gustavo Zacarias <gustavoz@gentoo.org>
+ +files/3.4.4/gcc-3.4_x-avr-news-devs2.patch, gcc-3.4.4.ebuild:
+ Added new avr target device support with blessing from spanky
*gcc-4.1.0_beta20050618 (18 Jun 2005)
diff --git a/sys-devel/gcc/files/3.4.4/gcc-3.4_x-avr-news-devs2.patch b/sys-devel/gcc/files/3.4.4/gcc-3.4_x-avr-news-devs2.patch
new file mode 100644
index 000000000000..9719ccb90695
--- /dev/null
+++ b/sys-devel/gcc/files/3.4.4/gcc-3.4_x-avr-news-devs2.patch
@@ -0,0 +1,124 @@
+--- gcc/config/avr/avr.c.orig 2004-09-27 19:13:55.000000000 -0600
++++ gcc/config/avr/avr.c 2005-02-01 14:58:40.465250000 -0700
+@@ -175,6 +175,9 @@
+ { "at90c8534", 2, "__AVR_AT90C8534__" },
+ { "at90s8535", 2, "__AVR_AT90S8535__" },
+ { "at86rf401", 2, "__AVR_AT86RF401__" },
++ /* Classic + MOVW, <= 8K. */
++ { "attiny13", 2, "__AVR_ATtiny13__" },
++ { "attiny2313", 2, "__AVR_ATtiny2313__" },
+ /* Classic, > 8K. */
+ { "avr3", 3, NULL },
+ { "atmega103", 3, "__AVR_ATmega103__" },
+@@ -185,6 +188,8 @@
+ /* Enhanced, <= 8K. */
+ { "avr4", 4, NULL },
+ { "atmega8", 4, "__AVR_ATmega8__" },
++ { "atmega48", 4, "__AVR_ATmega48__" },
++ { "atmega88", 4, "__AVR_ATmega88__" },
+ { "atmega8515", 4, "__AVR_ATmega8515__" },
+ { "atmega8535", 4, "__AVR_ATmega8535__" },
+ /* Enhanced, > 8K. */
+@@ -193,11 +198,13 @@
+ { "atmega161", 5, "__AVR_ATmega161__" },
+ { "atmega162", 5, "__AVR_ATmega162__" },
+ { "atmega163", 5, "__AVR_ATmega163__" },
++ { "atmega168", 5, "__AVR_ATmega168__" },
+ { "atmega169", 5, "__AVR_ATmega169__" },
+ { "atmega32", 5, "__AVR_ATmega32__" },
+ { "atmega323", 5, "__AVR_ATmega323__" },
+ { "atmega64", 5, "__AVR_ATmega64__" },
+ { "atmega128", 5, "__AVR_ATmega128__" },
++ { "at90can128", 5, "__AVR_AT90CAN128__" },
+ { "at94k", 5, "__AVR_AT94K__" },
+ /* Assembler only. */
+ { "avr1", 1, NULL },
+
+--- gcc/config/avr/avr.h.orig 2004-03-08 19:59:55.000000000 -0700
++++ gcc/config/avr/avr.h 2005-02-01 14:58:40.480875000 -0700
+@@ -2351,12 +2351,12 @@
+ Do not define this macro if it does not need to do anything. */
+
+ #define LINK_SPEC " %{!mmcu*:-m avr2}\
+-%{mmcu=at90s1200|mmcu=attiny1*|mmcu=attiny28:-m avr1} \
+-%{mmcu=attiny22|mmcu=attiny26|mmcu=at90s2*|mmcu=at90s4*|mmcu=at90s8*|mmcu=at90c8*|mmcu=at86rf401:-m avr2}\
++%{mmcu=at90s1200|mmcu=attiny11|mmcu=attiny12|mmcu=attiny15|mmcu=attiny28:-m avr1} \
++%{mmcu=attiny22|mmcu=attiny26|mmcu=at90s2*|mmcu=at90s4*|mmcu=at90s8*|mmcu=at90c8*|mmcu=at86rf401|mmcu=attiny13|mmcu=attiny2313:-m avr2}\
+ %{mmcu=atmega103|mmcu=atmega603|mmcu=at43*|mmcu=at76*:-m avr3}\
+-%{mmcu=atmega8*:-m avr4}\
+-%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega64|mmcu=atmega128|mmcu=at94k:-m avr5}\
+-%{mmcu=atmega64|mmcu=atmega128|mmcu=atmega162|mmcu=atmega169: -Tdata 0x800100} "
++%{mmcu=atmega8*|mmcu=atmega48:-m avr4}\
++%{mmcu=atmega16*|mmcu=atmega32*|mmcu=atmega64|mmcu=atmega128|mmcu=at90can128|mmcu=at94k:-m avr5}\
++%{mmcu=atmega48|mmcu=atmega88|mmcu=atmega64|mmcu=atmega128|mmcu=at90can128|mmcu=at90can128|mmcu=atmega162|mmcu=atmega168|mmcu=atmega169: -Tdata 0x800100} "
+
+ /* A C string constant that tells the GCC driver program options to
+ pass to the linker. It can also specify how to translate options
+@@ -2365,7 +2365,7 @@
+ Do not define this macro if it does not need to do anything. */
+
+ #define LIB_SPEC \
+- "%{!mmcu=at90s1*:%{!mmcu=attiny1*:%{!mmcu=attiny28: -lc }}}"
++ "%{!mmcu=at90s1*:%{!mmcu=attiny11:%{!mmcu=attiny12:%{!mmcu=attiny15:%{!mmcu=attiny28: -lc }}}}}"
+ /* Another C string constant used much like `LINK_SPEC'. The
+ difference between the two is that `LIB_SPEC' is used at the end
+ of the command given to the linker.
+@@ -2377,7 +2377,7 @@
+ /* No libstdc++ for now. Empty string doesn't work. */
+
+ #define LIBGCC_SPEC \
+- "%{!mmcu=at90s1*:%{!mmcu=attiny1*:%{!mmcu=attiny28: -lgcc }}}"
++ "%{!mmcu=at90s1*:%{!mmcu=attiny11:%{!mmcu=attiny12:%{!mmcu=attiny15:%{!mmcu=attiny28: -lgcc }}}}}"
+ /* Another C string constant that tells the GCC driver program how
+ and when to place a reference to `libgcc.a' into the linker
+ command line. This constant is placed both before and after the
+@@ -2421,23 +2421,29 @@
+ %{mmcu=at90c8534:crtc8534.o%s} \
+ %{mmcu=at90s8535:crts8535.o%s} \
+ %{mmcu=at86rf401:crt86401.o%s} \
++%{mmcu=attiny13:crttn13.o%s} \
++%{mmcu=attiny2313:crttn2313.o%s} \
+ %{mmcu=atmega103|mmcu=avr3:crtm103.o%s} \
+ %{mmcu=atmega603:crtm603.o%s} \
+ %{mmcu=at43usb320:crt43320.o%s} \
+ %{mmcu=at43usb355:crt43355.o%s} \
+ %{mmcu=at76c711:crt76711.o%s} \
+ %{mmcu=atmega8|mmcu=avr4:crtm8.o%s} \
++%{mmcu=atmega48:crtm48.o%s} \
++%{mmcu=atmega88:crtm88.o%s} \
+ %{mmcu=atmega8515:crtm8515.o%s} \
+ %{mmcu=atmega8535:crtm8535.o%s} \
+ %{mmcu=atmega16:crtm16.o%s} \
+ %{mmcu=atmega161|mmcu=avr5:crtm161.o%s} \
+ %{mmcu=atmega162:crtm162.o%s} \
+ %{mmcu=atmega163:crtm163.o%s} \
++%{mmcu=atmega168:crtm168.o%s} \
+ %{mmcu=atmega169:crtm169.o%s} \
+ %{mmcu=atmega32:crtm32.o%s} \
+ %{mmcu=atmega323:crtm323.o%s} \
+ %{mmcu=atmega64:crtm64.o%s} \
+ %{mmcu=atmega128:crtm128.o%s} \
++%{mmcu=at90can128:crtcan128.o%s} \
+ %{mmcu=at94k:crtat94k.o%s}"
+
+ #define EXTRA_SPECS {"crt_binutils", CRT_BINUTILS_SPECS},
+--- gcc/config/avr/t-avr.orig 2003-02-27 14:45:33.000000000 -0700
++++ gcc/config/avr/t-avr 2005-02-01 14:58:40.480875000 -0700
+@@ -50,13 +50,14 @@
+ mmcu?avr3=mmcu?at43usb320 mmcu?avr3=mmcu?at43usb355 \
+ mmcu?avr3=mmcu?at76c711 \
+ mmcu?avr4=mmcu?atmega8515 mmcu?avr4=mmcu?atmega8535 \
+- mmcu?avr4=mmcu?atmega8 \
++ mmcu?avr4=mmcu?atmega8 mmcu?avr4=mmcu?atmega48 \
++ mmcu?avr4=mmcu?atmega88 \
+ mmcu?avr5=mmcu?atmega161 mmcu?avr5=mmcu?atmega162 \
+ mmcu?avr5=mmcu?atmega163 mmcu?avr5=mmcu?atmega169 \
+- mmcu?avr5=mmcu?atmega16 \
++ mmcu?avr5=mmcu?atmega16 mmcu?avr5=mmcu?atmega168 \
+ mmcu?avr5=mmcu?atmega323 mmcu?avr5=mmcu?atmega32 \
+ mmcu?avr5=mmcu?atmega64 mmcu?avr5=mmcu?atmega128 \
+- mmcu?avr5=mmcu?at94k
++ mmcu?avr5=mmcu?at94k mmcu?avr5=mmcu?at90can128
+
+ MULTILIB_EXCEPTIONS =
+
diff --git a/sys-devel/gcc/gcc-3.4.4.ebuild b/sys-devel/gcc/gcc-3.4.4.ebuild
index 2d0ac913b9a2..5318f02b066a 100644
--- a/sys-devel/gcc/gcc-3.4.4.ebuild
+++ b/sys-devel/gcc/gcc-3.4.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4.ebuild,v 1.12 2005/06/20 02:36:46 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4.ebuild,v 1.13 2005/06/23 18:24:20 gustavoz Exp $
MAN_VER=""
PATCH_VER="1.2"
@@ -94,6 +94,9 @@ src_unpack() {
# Fix cross-compiling
epatch "${FILESDIR}"/3.4.4/gcc-3.4.4-cross-compile.patch
+ # Newer AVR target processors
+ epatch "${FILESDIR}"/3.4.4/gcc-3.4_x-avr-news-devs2.patch
+
# Arch stuff
case $(tc-arch) in
mips)