summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-09-07 13:08:03 +0000
committerMichał Górny <mgorny@gentoo.org>2013-09-07 13:08:03 +0000
commitba1a8b4e97e0486f15258ae01532ccab77af1399 (patch)
tree1b5a051a4ebca64850f49c9b508142aeb4e47f73 /sys-devel
parentRaise version requirement for bcprov to 1.49, fixes bug 483322 (diff)
downloadgentoo-2-ba1a8b4e97e0486f15258ae01532ccab77af1399.tar.gz
gentoo-2-ba1a8b4e97e0486f15258ae01532ccab77af1399.tar.bz2
gentoo-2-ba1a8b4e97e0486f15258ae01532ccab77af1399.zip
Use official git mirror for the live ebuild since git-r3 is more space- and bandwidth-efficient than subversion.
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild27
2 files changed, 18 insertions, 15 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index b0005871d65d..bed1a878a367 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.134 2013/09/05 19:08:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.135 2013/09/07 13:08:03 mgorny Exp $
+
+ 07 Sep 2013; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
+ Use official git mirror for the live ebuild since git-r3 is more space- and
+ bandwidth-efficient than subversion.
05 Sep 2013; Michał Górny <mgorny@gentoo.org> llvm-3.2.ebuild,
llvm-3.3-r1.ebuild, llvm-3.3.ebuild, llvm-9999.ebuild:
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index b46198716d77..bdd8aef0a7c9 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,18 +1,17 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.51 2013/09/05 19:08:49 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.52 2013/09/07 13:08:03 mgorny Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} pypy2_0 )
+PYTHON_COMPAT=( python{2_5,2_6,2_7} pypy{1_9,2_0} )
-inherit subversion eutils flag-o-matic multilib multilib-minimal \
+inherit eutils flag-o-matic git-r3 multilib multilib-minimal \
python-r1 toolchain-funcs pax-utils check-reqs
DESCRIPTION="Low Level Virtual Machine"
HOMEPAGE="http://llvm.org/"
SRC_URI=""
-ESVN_REPO_URI="http://llvm.org/svn/llvm-project/llvm/trunk"
LICENSE="UoI-NCSA"
SLOT="0/${PV}"
@@ -130,18 +129,18 @@ pkg_setup() {
src_unpack() {
if use clang; then
- ESVN_PROJECT=compiler-rt S="${S}"/projects/compiler-rt subversion_fetch "http://llvm.org/svn/llvm-project/compiler-rt/trunk"
-
- # Force version match between LLVM, compiler-rt & clang
- # but first work-around subversion.eclass smartness, bug #282486.
- ESVN_PROJECT=compiler-rt subversion_wc_info "http://llvm.org/svn/llvm-project/compiler-rt/trunk"
- local ESVN_REVISION=${ESVN_WC_REVISION}
-
- ESVN_PROJECT=clang S="${S}"/tools/clang subversion_fetch "http://llvm.org/svn/llvm-project/cfe/trunk"
+ git-r3_fetch http://llvm.org/git/compiler-rt.git
+ git-r3_fetch http://llvm.org/git/clang.git
fi
+ git-r3_fetch http://llvm.org/git/llvm.git
- # Do llvm last so that ESVN_WC_* is top-level.
- subversion_src_unpack
+ if use clang; then
+ git-r3_checkout http://llvm.org/git/compiler-rt.git \
+ "${S}"/projects/compiler-rt
+ git-r3_checkout http://llvm.org/git/clang.git \
+ "${S}"/tools/clang
+ fi
+ git-r3_checkout http://llvm.org/git/llvm.git
}
src_prepare() {