summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2004-04-24 00:38:49 +0000
committerMike Frysinger <vapier@gentoo.org>2004-04-24 00:38:49 +0000
commitc0e231a0c0003b01873220444435a58fe6297a5a (patch)
tree675a1dc0490935cbf76acce1a01449e8131b83b5 /sys-devel
parentCleaned old ebuilds. Added a few DEPENDS (Manifest recommit) (diff)
downloadgentoo-2-c0e231a0c0003b01873220444435a58fe6297a5a.tar.gz
gentoo-2-c0e231a0c0003b01873220444435a58fe6297a5a.tar.bz2
gentoo-2-c0e231a0c0003b01873220444435a58fe6297a5a.zip
nogcj -> gcj
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/gcc-3.3-r1.ebuild36
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r5.ebuild10
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r7.ebuild10
-rw-r--r--sys-devel/gcc/gcc-3.3.3.ebuild10
-rw-r--r--sys-devel/gcc/gcc-3.4.0_pre20040416.ebuild10
5 files changed, 36 insertions, 40 deletions
diff --git a/sys-devel/gcc/gcc-3.3-r1.ebuild b/sys-devel/gcc/gcc-3.3-r1.ebuild
index 99acebe0749a..14a8bd26e99a 100644
--- a/sys-devel/gcc/gcc-3.3-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3-r1.ebuild
@@ -1,14 +1,9 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3-r1.ebuild,v 1.8 2004/02/26 20:36:49 pappy Exp $
-
-IUSE="static nls bootstrap java build X"
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3-r1.ebuild,v 1.9 2004/04/24 00:38:49 vapier Exp $
inherit eutils flag-o-matic libtool
-# Compile problems with these (bug #6641 among others)...
-#filter-flags "-fno-exceptions -fomit-frame-pointer -fforce-addr"
-
# Recently there has been a lot of stability problem in Gentoo-land. Many
# things can be the cause to this, but I believe that it is due to gcc3
# still having issues with optimizations, or with it not filtering bad
@@ -29,7 +24,16 @@ inherit eutils flag-o-matic libtool
# problems.
#
# <azarah@gentoo.org> (13 Oct 2002)
-strip-flags
+do_filter_flags() {
+ strip-flags
+
+ # In general gcc does not like optimization, and add -O2 where
+ # it is safe.
+ filter-flags -O?
+
+ # Compile problems with these (bug #6641 among others)...
+ filter-flags -fno-exceptions -fomit-frame-pointer -ggdb
+}
# Theoretical cross compiler support
[ ! -n "${CCHOST}" ] && export CCHOST="${CHOST}"
@@ -95,7 +99,8 @@ DESCRIPTION="The GNU Compiler Collection. Includes C/C++ and java compilers"
HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
LICENSE="GPL-2 LGPL-2.1"
-KEYWORDS="-*"
+KEYWORDS="-* arm"
+IUSE="static nls bootstrap java build X"
# Ok, this is a hairy one again, but lets assume that we
# are not cross compiling, than we want SLOT to only contain
@@ -118,13 +123,11 @@ DEPEND="virtual/glibc
>=sys-devel/gcc-config-1.3.1
!build? ( >=sys-libs/ncurses-5.2-r2
nls? ( sys-devel/gettext ) )"
-
RDEPEND="virtual/glibc
>=sys-devel/gcc-config-1.3.1
>=sys-libs/zlib-1.1.4
>=sys-apps/texinfo-4.2-r4
!build? ( >=sys-libs/ncurses-5.2-r2 )"
-
PDEPEND="sys-devel/gcc-config"
@@ -256,20 +259,20 @@ src_compile() {
local myconf=
local gcc_lang=
- if [ -z "`use build`" ]
+ if ! use build
then
myconf="${myconf} --enable-shared"
gcc_lang="c,c++,f77,objc"
else
gcc_lang="c"
fi
- if [ -z "`use nls`" -o "`use build`" ]
+ if ! use nls || use build
then
myconf="${myconf} --disable-nls"
else
myconf="${myconf} --enable-nls --without-included-gettext"
fi
- if [ -n "`use java`" -a -z "`use build`" ]
+ if use java && ! use build
then
gcc_lang="${gcc_lang},java"
fi
@@ -289,12 +292,6 @@ src_compile() {
# Multilib not yet supported
myconf="${myconf} --disable-multilib"
- # In general gcc does not like optimization, and add -O2 where
- # it is safe. This is especially true for gcc-3.3 ...
- export CFLAGS="${CFLAGS/-O?/-O2}"
- export CXXFLAGS="${CXXFLAGS/-O?/-O2}"
- export GCJFLAGS="${CFLAGS/-O?/-O2}"
-
# Build in a separate build tree
mkdir -p ${WORKDIR}/build
cd ${WORKDIR}/build
@@ -594,4 +591,3 @@ pkg_postinst() {
[ "${ROOT}" = "/" ] && hardened-gcc -A
fi
}
-
diff --git a/sys-devel/gcc/gcc-3.3.2-r5.ebuild b/sys-devel/gcc/gcc-3.3.2-r5.ebuild
index 007dc854db22..92c0cdc56a8b 100644
--- a/sys-devel/gcc/gcc-3.3.2-r5.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r5.ebuild,v 1.14 2004/03/15 09:23:16 kumba Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r5.ebuild,v 1.15 2004/04/24 00:38:49 vapier Exp $
-IUSE="static nls bootstrap java build X multilib nogcj"
+IUSE="static nls bootstrap java build X multilib gcj"
inherit eutils flag-o-matic libtool
@@ -333,7 +333,7 @@ src_compile() {
else
myconf="${myconf} --enable-nls --without-included-gettext"
fi
- if [ -n "`use java`" -a -z "`use nogcj`" -a -z "`use build`" ]
+ if [ -n "`use java`" -a "`use gcj`" -a -z "`use build`" ]
then
gcc_lang="${gcc_lang},java"
fi
@@ -343,7 +343,7 @@ src_compile() {
# X11 support is still very experimental but enabling it is
# quite innocuous... [No, gcc is *not* linked to X11...]
# <dragon@gentoo.org> (15 May 2003)
- if [ -n "`use java`" -a -z "`use nogcj`" -a \
+ if [ -n "`use java`" -a "`use gcj`" -a \
-n "`use X`" -a -z "`use build`" -a \
-f /usr/X11R6/include/X11/Xlib.h ]
then
@@ -615,7 +615,7 @@ src_install() {
cp -f docs/html/17_intro/[A-Z]* \
${D}/usr/share/doc/${PF}/${DOCDESTTREE}/17_intro/
- if [ -n "`use java`" -a -z "`use nogcj`" ]
+ if [ -n "`use java`" -a "`use gcj`" ]
then
cd ${S}/fastjar
docinto ${CCHOST}/fastjar
diff --git a/sys-devel/gcc/gcc-3.3.2-r7.ebuild b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
index e0361fe8ff4a..414664b1def8 100644
--- a/sys-devel/gcc/gcc-3.3.2-r7.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.6 2004/02/21 19:50:44 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.7 2004/04/24 00:38:49 vapier Exp $
-IUSE="static nls bootstrap java build X multilib nogcj"
+IUSE="static nls bootstrap java build X multilib gcj"
inherit eutils flag-o-matic libtool
@@ -360,7 +360,7 @@ src_compile() {
else
myconf="${myconf} --enable-nls --without-included-gettext"
fi
- if [ -n "`use java`" -a -z "`use nogcj`" -a -z "`use build`" ]
+ if [ -n "`use java`" -a "`use gcj`" -a -z "`use build`" ]
then
gcc_lang="${gcc_lang},java"
fi
@@ -370,7 +370,7 @@ src_compile() {
# X11 support is still very experimental but enabling it is
# quite innocuous... [No, gcc is *not* linked to X11...]
# <dragon@gentoo.org> (15 May 2003)
- if [ -n "`use java`" -a -z "`use nogcj`" -a \
+ if [ -n "`use java`" -a "`use gcj`" -a \
-n "`use X`" -a -z "`use build`" -a \
-f /usr/X11R6/include/X11/Xlib.h ]
then
@@ -642,7 +642,7 @@ src_install() {
cp -f docs/html/17_intro/[A-Z]* \
${D}/usr/share/doc/${PF}/${DOCDESTTREE}/17_intro/
- if [ -n "`use java`" -a -z "`use nogcj`" ]
+ if [ -n "`use java`" -a "`use gcj`" ]
then
cd ${S}/fastjar
docinto ${CCHOST}/fastjar
diff --git a/sys-devel/gcc/gcc-3.3.3.ebuild b/sys-devel/gcc/gcc-3.3.3.ebuild
index 7fa86cb1ddf1..571f9a6c5c1a 100644
--- a/sys-devel/gcc/gcc-3.3.3.ebuild
+++ b/sys-devel/gcc/gcc-3.3.3.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3.ebuild,v 1.6 2004/04/05 20:31:01 iggy Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.3.ebuild,v 1.7 2004/04/24 00:38:49 vapier Exp $
-IUSE="static nls bootstrap java build X multilib nogcj"
+IUSE="static nls bootstrap java build X multilib gcj"
inherit eutils flag-o-matic libtool
@@ -363,7 +363,7 @@ src_compile() {
else
myconf="${myconf} --enable-nls --without-included-gettext"
fi
- if [ -n "`use java`" -a -z "`use nogcj`" -a -z "`use build`" ]
+ if [ -n "`use java`" -a "`use gcj`" -a -z "`use build`" ]
then
gcc_lang="${gcc_lang},java"
fi
@@ -373,7 +373,7 @@ src_compile() {
# X11 support is still very experimental but enabling it is
# quite innocuous... [No, gcc is *not* linked to X11...]
# <dragon@gentoo.org> (15 May 2003)
- if [ -n "`use java`" -a -z "`use nogcj`" -a \
+ if [ -n "`use java`" -a "`use gcj`" -a \
-n "`use X`" -a -z "`use build`" -a \
-f /usr/X11R6/include/X11/Xlib.h ]
then
@@ -645,7 +645,7 @@ src_install() {
cp -f docs/html/17_intro/[A-Z]* \
${D}/usr/share/doc/${PF}/${DOCDESTTREE}/17_intro/
- if [ -n "`use java`" -a -z "`use nogcj`" ]
+ if [ -n "`use java`" -a "`use gcj`" ]
then
cd ${S}/fastjar
docinto ${CCHOST}/fastjar
diff --git a/sys-devel/gcc/gcc-3.4.0_pre20040416.ebuild b/sys-devel/gcc/gcc-3.4.0_pre20040416.ebuild
index b625ae1aa667..f6af30bee09b 100644
--- a/sys-devel/gcc/gcc-3.4.0_pre20040416.ebuild
+++ b/sys-devel/gcc/gcc-3.4.0_pre20040416.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0_pre20040416.ebuild,v 1.4 2004/04/21 14:35:03 aliz Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.0_pre20040416.ebuild,v 1.5 2004/04/24 00:38:49 vapier Exp $
-IUSE="static nls bootstrap java build X multilib nogcj hardened"
+IUSE="static nls bootstrap java build X multilib gcj hardened"
DESCRIPTION="The GNU Compiler Collection. Includes C/C++ and java compilers, as well as support for pax PIE"
HOMEPAGE="http://www.gnu.org/software/gcc/gcc.html"
@@ -201,7 +201,7 @@ src_compile() {
else
myconf="${myconf} --enable-nls --without-included-gettext"
fi
- if [ -n "`use java`" -a -z "`use nogcj`" -a -z "`use build`" ]
+ if [ -n "`use java`" -a "`use gcj`" -a -z "`use build`" ]
then
gcc_lang="${gcc_lang},java"
fi
@@ -211,7 +211,7 @@ src_compile() {
# X11 support is still very experimental but enabling it is
# quite innocuous... [No, gcc is *not* linked to X11...]
# <dragon@gentoo.org> (15 May 2003)
- if [ -n "`use java`" -a -z "`use nogcj`" -a \
+ if [ -n "`use java`" -a "`use gcj`" -a \
-n "`use X`" -a -z "`use build`" -a \
-f /usr/X11R6/include/X11/Xlib.h ]
then
@@ -471,7 +471,7 @@ src_install() {
cp -f docs/html/17_intro/[A-Z]* \
${D}/usr/share/doc/${PF}/${DOCDESTTREE}/17_intro/
- if [ -n "`use java`" -a -z "`use nogcj`" ]
+ if [ -n "`use java`" -a "`use gcj`" ]
then
cd ${S}/fastjar
docinto ${CCHOST}/fastjar