summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-04-04 22:59:16 +0000
committerMike Frysinger <vapier@gentoo.org>2013-04-04 22:59:16 +0000
commitd6973fbe5284d87e5a708fe6b35855119af1d5c1 (patch)
treef79f33a8979f3cf6d6eeea3e8e46462c1b33e203 /sys-devel
parentDrop automake-1.9 requirement #454750 by Alphat-PC. (diff)
downloadgentoo-2-d6973fbe5284d87e5a708fe6b35855119af1d5c1.tar.gz
gentoo-2-d6973fbe5284d87e5a708fe6b35855119af1d5c1.tar.bz2
gentoo-2-d6973fbe5284d87e5a708fe6b35855119af1d5c1.zip
Initial USE=multislot support. Also drop -j1 workaround for newer versions as bug only affected 2.61.
(Portage version: 2.2.0_alpha170/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog10
-rw-r--r--sys-devel/autoconf/autoconf-2.59-r7.ebuild28
-rw-r--r--sys-devel/autoconf/autoconf-2.61-r2.ebuild14
-rw-r--r--sys-devel/autoconf/autoconf-2.62-r1.ebuild18
-rw-r--r--sys-devel/autoconf/autoconf-2.63-r1.ebuild18
-rw-r--r--sys-devel/autoconf/autoconf-2.64.ebuild25
-rw-r--r--sys-devel/autoconf/autoconf-2.65-r1.ebuild18
-rw-r--r--sys-devel/autoconf/autoconf-2.65.ebuild37
-rw-r--r--sys-devel/autoconf/autoconf-2.67.ebuild18
-rw-r--r--sys-devel/autoconf/autoconf-2.68.ebuild18
-rw-r--r--sys-devel/autoconf/autoconf-2.69.ebuild16
-rw-r--r--sys-devel/autoconf/autoconf-9999.ebuild18
-rw-r--r--sys-devel/autoconf/metadata.xml3
13 files changed, 147 insertions, 94 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index e3897aa3c9dd..064e47af57ec 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for sys-devel/autoconf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.184 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.185 2013/04/04 22:59:16 vapier Exp $
+
+ 04 Apr 2013; Mike Frysinger <vapier@gentoo.org> -autoconf-2.65.ebuild,
+ autoconf-2.59-r7.ebuild, autoconf-2.61-r2.ebuild, autoconf-2.62-r1.ebuild,
+ autoconf-2.63-r1.ebuild, autoconf-2.64.ebuild, autoconf-2.65-r1.ebuild,
+ autoconf-2.67.ebuild, autoconf-2.68.ebuild, autoconf-2.69.ebuild,
+ autoconf-9999.ebuild, metadata.xml:
+ Initial USE=multislot support. Also drop -j1 workaround for newer versions as
+ bug only affected 2.61.
04 Apr 2013; Mike Frysinger <vapier@gentoo.org> autoconf-2.59-r7.ebuild,
autoconf-2.61-r2.ebuild, autoconf-2.62-r1.ebuild, autoconf-2.63-r1.ebuild,
diff --git a/sys-devel/autoconf/autoconf-2.59-r7.ebuild b/sys-devel/autoconf/autoconf-2.59-r7.ebuild
index 9b05024afbd7..6e1e6fb4db72 100644
--- a/sys-devel/autoconf/autoconf-2.59-r7.ebuild
+++ b/sys-devel/autoconf/autoconf-2.59-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.59-r7.ebuild,v 1.17 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.59-r7.ebuild,v 1.18 2013/04/04 22:59:16 vapier Exp $
inherit eutils
@@ -9,42 +9,42 @@ HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
-SLOT="${PV:0:3}"
+SLOT=$(usex multislot "${PV}" "2.5")
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="emacs"
+IUSE="emacs multislot"
DEPEND="=sys-devel/m4-1.4*
dev-lang/perl"
RDEPEND="${DEPEND}
sys-devel/autoconf-wrapper"
+PDEPEND="emacs? ( app-emacs/autoconf-mode )"
src_unpack() {
unpack ${A}
cd "${S}"
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
epatch "${FILESDIR}"/${P}-more-quotes.patch
}
src_compile() {
- (use emacs && type -p emacs) \
- && export EMACS=emacs \
- || export EMACS=no
+ # Disable Emacs in the build system since it is in a separate package.
+ export EMACS=no
econf --program-suffix="-${PV}" || die
# econf updates config.{sub,guess} which forces the manpages
# to be regenerated which we dont want to do #146621
touch man/*.1
- # We want to transform the binaries, not the manpages
- sed -i "/^program_transform_name/s:-${PV}::" man/Makefile
emake || die
}
src_install() {
- make DESTDIR="${D}" install || die
-
+ emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
-}
-pkg_postinst() {
- einfo "Please note that the 'WANT_AUTOCONF_2_5=1' syntax is now:"
- einfo " WANT_AUTOCONF=2.5"
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/autoconf-2.61-r2.ebuild b/sys-devel/autoconf/autoconf-2.61-r2.ebuild
index 53ead6120a51..658cb5c982c0 100644
--- a/sys-devel/autoconf/autoconf-2.61-r2.ebuild
+++ b/sys-devel/autoconf/autoconf-2.61-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.61-r2.ebuild,v 1.9 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.61-r2.ebuild,v 1.10 2013/04/04 22:59:16 vapier Exp $
inherit eutils
@@ -9,9 +9,9 @@ HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT="2.5"
+SLOT=$(usex multislot "${PV}" "2.5")
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="emacs"
+IUSE="emacs multislot"
DEPEND=">=sys-devel/m4-1.4.6
dev-lang/perl"
@@ -22,6 +22,7 @@ PDEPEND="emacs? ( app-emacs/autoconf-mode )"
src_unpack() {
unpack ${A}
cd "${S}"
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
epatch "${FILESDIR}"/${P}-GETMNTENT.patch
}
@@ -41,4 +42,11 @@ src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/autoconf-2.62-r1.ebuild b/sys-devel/autoconf/autoconf-2.62-r1.ebuild
index 54f2e9dc6d0b..49c4c1fc1b7a 100644
--- a/sys-devel/autoconf/autoconf-2.62-r1.ebuild
+++ b/sys-devel/autoconf/autoconf-2.62-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.62-r1.ebuild,v 1.2 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.62-r1.ebuild,v 1.3 2013/04/04 22:59:16 vapier Exp $
inherit eutils
@@ -9,9 +9,9 @@ HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT="2.5"
+SLOT=$(usex multislot "${PV}" "2.5")
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="emacs"
+IUSE="emacs multislot"
DEPEND=">=sys-devel/m4-1.4.6
dev-lang/perl"
@@ -22,6 +22,7 @@ PDEPEND="emacs? ( app-emacs/autoconf-mode )"
src_unpack() {
unpack ${A}
cd "${S}"
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
epatch "${FILESDIR}"/${P}-revert-AC_C_BIGENDIAN.patch #228825
epatch "${FILESDIR}"/${P}-at-keywords.patch
epatch "${FILESDIR}"/${P}-fix-multiline-string.patch #217976
@@ -34,13 +35,18 @@ src_compile() {
# econf updates config.{sub,guess} which forces the manpages
# to be regenerated which we dont want to do #146621
touch man/*.1
- # From configure output:
- # Parallel builds via `make -jN' do not work.
- emake -j1 || die
+ emake || die
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/autoconf-2.63-r1.ebuild b/sys-devel/autoconf/autoconf-2.63-r1.ebuild
index fbc087353ce3..e1a0aca3d152 100644
--- a/sys-devel/autoconf/autoconf-2.63-r1.ebuild
+++ b/sys-devel/autoconf/autoconf-2.63-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.63-r1.ebuild,v 1.3 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.63-r1.ebuild,v 1.4 2013/04/04 22:59:16 vapier Exp $
inherit eutils
@@ -9,9 +9,9 @@ HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
-SLOT="2.5"
+SLOT=$(usex multislot "${PV}" "2.5")
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc ~sparc-fbsd x86 ~x86-fbsd"
-IUSE="emacs"
+IUSE="emacs multislot"
DEPEND=">=sys-devel/m4-1.4.6
dev-lang/perl"
@@ -22,6 +22,7 @@ PDEPEND="emacs? ( app-emacs/autoconf-mode )"
src_unpack() {
unpack ${A}
cd "${S}"
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
epatch "${FILESDIR}"/${P}-sh.patch #264303
}
@@ -32,13 +33,18 @@ src_compile() {
# econf updates config.{sub,guess} which forces the manpages
# to be regenerated which we dont want to do #146621
touch man/*.1
- # From configure output:
- # Parallel builds via `make -jN' do not work.
- emake -j1 || die
+ emake || die
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/autoconf-2.64.ebuild b/sys-devel/autoconf/autoconf-2.64.ebuild
index 0b998e3ed4ea..0c99bc74b422 100644
--- a/sys-devel/autoconf/autoconf-2.64.ebuild
+++ b/sys-devel/autoconf/autoconf-2.64.ebuild
@@ -1,6 +1,8 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.64.ebuild,v 1.3 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.64.ebuild,v 1.4 2013/04/04 22:59:16 vapier Exp $
+
+inherit eutils
DESCRIPTION="Used to create autoconfiguration files"
HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
@@ -8,9 +10,9 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-2"
-SLOT="2.5"
+SLOT=$(usex multislot "${PV}" "2.5")
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
-IUSE="emacs"
+IUSE="emacs multislot"
DEPEND=">=sys-devel/m4-1.4.6
dev-lang/perl"
@@ -18,6 +20,12 @@ RDEPEND="${DEPEND}
>=sys-devel/autoconf-wrapper-7"
PDEPEND="emacs? ( app-emacs/autoconf-mode )"
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
+}
+
src_compile() {
# Disable Emacs in the build system since it is in a separate package.
export EMACS=no
@@ -25,13 +33,18 @@ src_compile() {
# econf updates config.{sub,guess} which forces the manpages
# to be regenerated which we dont want to do #146621
touch man/*.1
- # From configure output:
- # Parallel builds via `make -jN' do not work.
- emake -j1 || die
+ emake || die
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/autoconf-2.65-r1.ebuild b/sys-devel/autoconf/autoconf-2.65-r1.ebuild
index df221fabef9c..d97f7b0823a9 100644
--- a/sys-devel/autoconf/autoconf-2.65-r1.ebuild
+++ b/sys-devel/autoconf/autoconf-2.65-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.65-r1.ebuild,v 1.8 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.65-r1.ebuild,v 1.9 2013/04/04 22:59:16 vapier Exp $
inherit eutils
@@ -10,9 +10,9 @@ SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
LICENSE="GPL-3"
-SLOT="2.5"
+SLOT=$(usex multislot "${PV}" "2.5")
KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="emacs"
+IUSE="emacs multislot"
DEPEND=">=sys-devel/m4-1.4.6
dev-lang/perl"
@@ -23,6 +23,7 @@ PDEPEND="emacs? ( app-emacs/autoconf-mode )"
src_unpack() {
unpack ${A}
cd "${S}"
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
epatch "${FILESDIR}"/${P}-AC_TYPE_INT_T.patch #324649
}
@@ -33,13 +34,18 @@ src_compile() {
# econf updates config.{sub,guess} which forces the manpages
# to be regenerated which we dont want to do #146621
touch man/*.1
- # From configure output:
- # Parallel builds via `make -jN' do not work.
- emake -j1 || die
+ emake || die
}
src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/autoconf-2.65.ebuild b/sys-devel/autoconf/autoconf-2.65.ebuild
deleted file mode 100644
index cfa3b9d6591c..000000000000
--- a/sys-devel/autoconf/autoconf-2.65.ebuild
+++ /dev/null
@@ -1,37 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.65.ebuild,v 1.10 2013/04/04 18:44:03 vapier Exp $
-
-DESCRIPTION="Used to create autoconfiguration files"
-HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
-SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
- ftp://alpha.gnu.org/pub/gnu/${PN}/${P}.tar.bz2"
-
-LICENSE="GPL-3"
-SLOT="2.5"
-KEYWORDS="alpha amd64 arm hppa ia64 m68k ~mips ppc ppc64 s390 sh sparc x86 ~sparc-fbsd ~x86-fbsd"
-IUSE="emacs"
-
-DEPEND=">=sys-devel/m4-1.4.6
- dev-lang/perl"
-RDEPEND="${DEPEND}
- >=sys-devel/autoconf-wrapper-8"
-PDEPEND="emacs? ( app-emacs/autoconf-mode )"
-
-src_compile() {
- # Disable Emacs in the build system since it is in a separate package.
- export EMACS=no
- econf --program-suffix="-${PV}" || die
- # econf updates config.{sub,guess} which forces the manpages
- # to be regenerated which we dont want to do #146621
- touch man/*.1
- # From configure output:
- # Parallel builds via `make -jN' do not work.
- emake -j1 || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die
- dodoc AUTHORS BUGS NEWS README TODO THANKS \
- ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
-}
diff --git a/sys-devel/autoconf/autoconf-2.67.ebuild b/sys-devel/autoconf/autoconf-2.67.ebuild
index 3891ced3df7f..495fcc88e59d 100644
--- a/sys-devel/autoconf/autoconf-2.67.ebuild
+++ b/sys-devel/autoconf/autoconf-2.67.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.67.ebuild,v 1.12 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.67.ebuild,v 1.13 2013/04/04 22:59:16 vapier Exp $
EAPI="2"
+inherit eutils
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/autoconf.git"
- inherit git
+ inherit git-2
SRC_URI=""
#KEYWORDS=""
else
@@ -19,8 +21,8 @@ DESCRIPTION="Used to create autoconfiguration files"
HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
LICENSE="GPL-3"
-SLOT="2.5"
-IUSE="emacs"
+SLOT=$(usex multislot "${PV}" "2.5")
+IUSE="emacs multislot"
DEPEND=">=sys-devel/m4-1.4.6
dev-lang/perl"
@@ -32,6 +34,7 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
autoreconf -f -i || die
fi
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
}
src_configure() {
@@ -47,4 +50,11 @@ src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/autoconf-2.68.ebuild b/sys-devel/autoconf/autoconf-2.68.ebuild
index 242d2ca4af2d..0cf73fd020f9 100644
--- a/sys-devel/autoconf/autoconf-2.68.ebuild
+++ b/sys-devel/autoconf/autoconf-2.68.ebuild
@@ -1,12 +1,14 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.68.ebuild,v 1.10 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.68.ebuild,v 1.11 2013/04/04 22:59:16 vapier Exp $
EAPI="2"
+inherit eutils
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/autoconf.git"
- inherit git
+ inherit git-2
SRC_URI=""
#KEYWORDS=""
else
@@ -19,8 +21,8 @@ DESCRIPTION="Used to create autoconfiguration files"
HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
LICENSE="GPL-3"
-SLOT="2.5"
-IUSE="emacs"
+SLOT=$(usex multislot "${PV}" "2.5")
+IUSE="emacs multislot"
DEPEND=">=sys-devel/m4-1.4.6
dev-lang/perl"
@@ -32,6 +34,7 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
autoreconf -f -i || die
fi
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
}
src_configure() {
@@ -47,4 +50,11 @@ src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/autoconf-2.69.ebuild b/sys-devel/autoconf/autoconf-2.69.ebuild
index d237fcabcd3e..2edf542340bf 100644
--- a/sys-devel/autoconf/autoconf-2.69.ebuild
+++ b/sys-devel/autoconf/autoconf-2.69.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.69.ebuild,v 1.15 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.69.ebuild,v 1.16 2013/04/04 22:59:16 vapier Exp $
EAPI="3"
+inherit eutils
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
http://git.savannah.gnu.org/r/${PN}.git"
@@ -21,8 +23,8 @@ DESCRIPTION="Used to create autoconfiguration files"
HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
LICENSE="GPL-3"
-SLOT="2.5"
-IUSE="emacs"
+SLOT=$(usex multislot "${PV}" "2.5")
+IUSE="emacs multislot"
DEPEND=">=sys-devel/m4-1.4.16
>=dev-lang/perl-5.6"
@@ -34,6 +36,7 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
autoreconf -f -i || die
fi
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
}
src_configure() {
@@ -49,4 +52,11 @@ src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/autoconf-9999.ebuild b/sys-devel/autoconf/autoconf-9999.ebuild
index 1895fdb452e1..6bbbd6de9a56 100644
--- a/sys-devel/autoconf/autoconf-9999.ebuild
+++ b/sys-devel/autoconf/autoconf-9999.ebuild
@@ -1,9 +1,11 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-9999.ebuild,v 1.8 2013/04/04 18:44:03 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-9999.ebuild,v 1.9 2013/04/04 22:59:16 vapier Exp $
EAPI="3"
+inherit eutils
+
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="git://git.savannah.gnu.org/${PN}.git
http://git.savannah.gnu.org/r/${PN}.git"
@@ -21,10 +23,10 @@ DESCRIPTION="Used to create autoconfiguration files"
HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
LICENSE="GPL-3"
-SLOT="2.5"
-IUSE="emacs"
+SLOT=$(usex multislot "${PV}" "2.5")
+IUSE="emacs multislot"
-DEPEND=">=sys-devel/m4-1.4.6
+DEPEND=">=sys-devel/m4-1.4.16
>=dev-lang/perl-5.6"
RDEPEND="${DEPEND}
>=sys-devel/autoconf-wrapper-10"
@@ -35,6 +37,7 @@ src_prepare() {
if [[ ${PV} == "9999" ]] ; then
autoreconf -f -i || die
fi
+ use multislot && find -name Makefile.in -exec sed -i '/^pkgdatadir/s:$:-@VERSION@:' {} +
}
src_configure() {
@@ -50,4 +53,11 @@ src_install() {
emake DESTDIR="${D}" install || die
dodoc AUTHORS BUGS NEWS README TODO THANKS \
ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ if use multislot ; then
+ local f
+ for f in "${D}"/usr/share/info/*.info* ; do
+ mv "${f}" "${f/.info/-${SLOT}.info}" || die
+ done
+ fi
}
diff --git a/sys-devel/autoconf/metadata.xml b/sys-devel/autoconf/metadata.xml
index 96a2d586367d..f9d3cbfa27c9 100644
--- a/sys-devel/autoconf/metadata.xml
+++ b/sys-devel/autoconf/metadata.xml
@@ -2,4 +2,7 @@
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
<herd>base-system</herd>
+<use>
+<flag name='multislot'>Allow for multiple versions to be installed at once</flag>
+</use>
</pkgmetadata>