summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2009-03-09 21:32:35 +0000
committerMike Frysinger <vapier@gentoo.org>2009-03-09 21:32:35 +0000
commitdad3dbf16ce6b97419b3bacb42cf5fe34f3a32b7 (patch)
treeaace30b87edd21f8c0cc2d4b1fbd8eaa304f87d3 /sys-devel
parentSync live-git/normal ebuilds and dropped merged sh patch. (diff)
downloadgentoo-2-dad3dbf16ce6b97419b3bacb42cf5fe34f3a32b7.tar.gz
gentoo-2-dad3dbf16ce6b97419b3bacb42cf5fe34f3a32b7.tar.bz2
gentoo-2-dad3dbf16ce6b97419b3bacb42cf5fe34f3a32b7.zip
Update snapshot.
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gnuconfig/ChangeLog8
-rw-r--r--sys-devel/gnuconfig/gnuconfig-20090203.ebuild56
2 files changed, 63 insertions, 1 deletions
diff --git a/sys-devel/gnuconfig/ChangeLog b/sys-devel/gnuconfig/ChangeLog
index 12e707486733..5fb66ea3e5d0 100644
--- a/sys-devel/gnuconfig/ChangeLog
+++ b/sys-devel/gnuconfig/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/gnuconfig
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.37 2009/03/09 21:32:02 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/ChangeLog,v 1.38 2009/03/09 21:32:35 vapier Exp $
+
+*gnuconfig-20090203 (09 Mar 2009)
+
+ 09 Mar 2009; Mike Frysinger <vapier@gentoo.org>
+ +gnuconfig-20090203.ebuild:
+ Update snapshot.
09 Mar 2009; Mike Frysinger <vapier@gentoo.org>
-files/99999999/0003-add-more-superh-targets-to-config.sub.patch,
diff --git a/sys-devel/gnuconfig/gnuconfig-20090203.ebuild b/sys-devel/gnuconfig/gnuconfig-20090203.ebuild
new file mode 100644
index 000000000000..f0228c20aa8d
--- /dev/null
+++ b/sys-devel/gnuconfig/gnuconfig-20090203.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gnuconfig/gnuconfig-20090203.ebuild,v 1.1 2009/03/09 21:32:35 vapier Exp $
+
+inherit eutils
+if [[ ${PV} == "99999999" ]] ; then
+ EGIT_REPO_URI="git://git.savannah.gnu.org/config.git"
+ inherit git
+else
+ SRC_URI="mirror://gentoo/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="Updated config.sub and config.guess file from GNU"
+HOMEPAGE="http://savannah.gnu.org/projects/config"
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE=""
+
+S=${WORKDIR}
+
+maint_pkg_create() {
+ cd "${S}"
+
+ local ver=$(head -n 1 ChangeLog | awk '{print $1}' | sed -e 's:-::g')
+ [[ ${#ver} != 8 ]] && die "invalid version '${ver}'"
+
+ cp "${FILESDIR}"/${PV}/*.patch . || die
+
+ local tar="${T}/gnuconfig-${ver}.tar.bz2"
+ tar -jcf ${tar} . || die "creating tar failed"
+ einfo "Packaged tar now available:"
+ einfo "$(du -b ${tar})"
+}
+
+src_unpack() {
+ if [[ ${PV} == "99999999" ]] ; then
+ git_src_unpack
+ maint_pkg_create
+ else
+ unpack ${A}
+ fi
+ epatch "${WORKDIR}"/*.patch
+ sed -i '/i386-pc-solaris2.6/d' testsuite/config-guess.data
+ use elibc_uclibc && sed -i 's:linux-gnu:linux-uclibc:' testsuite/config-guess.data #180637
+}
+
+src_compile() { :;}
+
+src_install() {
+ insinto /usr/share/${PN}
+ doins config.{sub,guess} || die
+ fperms +x /usr/share/${PN}/config.{sub,guess}
+ dodoc ChangeLog
+}