summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-10-24 14:50:09 +0000
committerFabian Groffen <grobian@gentoo.org>2010-10-24 14:50:09 +0000
commitdebab3460b062b08b83589a244c03f6ff7d9e035 (patch)
treef4e264c562a792394553e9ceafafa001e4f9da81 /sys-devel
parentppc64 stable wrt #337510 (diff)
downloadgentoo-2-debab3460b062b08b83589a244c03f6ff7d9e035.tar.gz
gentoo-2-debab3460b062b08b83589a244c03f6ff7d9e035.tar.bz2
gentoo-2-debab3460b062b08b83589a244c03f6ff7d9e035.zip
Update reference fixing for Darwin for newer more strict versions of Portage
(Portage version: 2.2.01.17063-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog7
-rw-r--r--sys-devel/llvm/llvm-2.8-r1.ebuild18
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild18
3 files changed, 28 insertions, 15 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index a3524a6a1ecd..4c89a005b2ab 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.26 2010/10/23 15:12:26 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.27 2010/10/24 14:50:09 grobian Exp $
+
+ 24 Oct 2010; Fabian Groffen <grobian@gentoo.org> llvm-2.8-r1.ebuild,
+ llvm-9999.ebuild:
+ Update reference fixing for Darwin for newer more strict versions of
+ Portage
23 Oct 2010; Fabian Groffen <grobian@gentoo.org> llvm-2.8-r1.ebuild,
+files/llvm-2.8-darwin8.patch, llvm-9999.ebuild:
diff --git a/sys-devel/llvm/llvm-2.8-r1.ebuild b/sys-devel/llvm/llvm-2.8-r1.ebuild
index 8b085b83e554..7c724ba0e41b 100644
--- a/sys-devel/llvm/llvm-2.8-r1.ebuild
+++ b/sys-devel/llvm/llvm-2.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.8-r1.ebuild,v 1.2 2010/10/23 15:12:26 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-2.8-r1.ebuild,v 1.3 2010/10/24 14:50:09 grobian Exp $
EAPI="3"
inherit eutils multilib toolchain-funcs
@@ -160,17 +160,21 @@ src_install() {
# to just fix this, so we correct it post-install
if [[ ${CHOST} == *-darwin* ]] ; then
for lib in lib{EnhancedDisassembly,LLVM-${PV},BugpointPasses,LLVMHello,LTO,profile_rt}.dylib ; do
+ # libEnhancedDisassembly is Darwin10 only, so non-fatal
+ [[ -f ${ED}/usr/lib/${PN}/${lib} ]] || continue
ebegin "fixing install_name of $lib"
- if [[ ! -f ${ED}/usr/lib/${PN}/${lib} ]] ; then
- # libEnhancedDisassembly is Darwin10 only, so non-fatal
- ewarn "$lib not found"
- eend 1
- continue
- fi
install_name_tool \
-id "${EPREFIX}"/usr/lib/${PN}/${lib} \
"${ED}"/usr/lib/${PN}/${lib}
eend $?
done
+ for f in "${ED}"/usr/bin/* "${ED}"/usr/lib/${PN}/libLTO.dylib ; do
+ ebegin "fixing install_name reference to libLLVM-${PV}.dylib of ${f##*/}"
+ install_name_tool \
+ -change "${S}"/Release/lib/libLLVM-${PV}.dylib \
+ "${EPREFIX}"/usr/lib/${PN}/libLLVM-${PV}.dylib \
+ "${f}"
+ eend $?
+ done
fi
}
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 74c4314684ea..0dd80b5ad826 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.8 2010/10/23 15:12:26 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.9 2010/10/24 14:50:09 grobian Exp $
EAPI="3"
inherit subversion eutils multilib toolchain-funcs
@@ -157,17 +157,21 @@ src_install() {
# to just fix this, so we correct it post-install
if [[ ${CHOST} == *-darwin* ]] ; then
for lib in lib{EnhancedDisassembly,LLVM-${PV},BugpointPasses,LLVMHello,LTO,profile_rt}.dylib ; do
+ # libEnhancedDisassembly is Darwin10 only, so non-fatal
+ [[ -f ${ED}/usr/lib/${PN}/${lib} ]] || continue
ebegin "fixing install_name of $lib"
- if [[ ! -f ${ED}/usr/lib/${PN}/${lib} ]] ; then
- # libEnhancedDisassembly is Darwin10 only, so non-fatal
- ewarn "$lib not found"
- eend 1
- continue
- fi
install_name_tool \
-id "${EPREFIX}"/usr/lib/${PN}/${lib} \
"${ED}"/usr/lib/${PN}/${lib}
eend $?
done
+ for f in "${ED}"/usr/bin/* "${ED}"/usr/lib/${PN}/libLTO.dylib ; do
+ ebegin "fixing install_name reference to libLLVM-${PV}.dylib of ${f##*/}"
+ install_name_tool \
+ -change "${S}"/Release/lib/libLLVM-${PV}.dylib \
+ "${EPREFIX}"/usr/lib/${PN}/libLLVM-${PV}.dylib \
+ "${f}"
+ eend $?
+ done
fi
}