summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2002-09-09 20:35:01 +0000
committerMartin Schlemmer <azarah@gentoo.org>2002-09-09 20:35:01 +0000
commite0d62ae73aebd387e70b9e4929739b2b2a6a1b69 (patch)
treeb1101456445b868d17b74244b0faeb7be2fb258c /sys-devel
parentRemoved unneeded configure option (diff)
downloadgentoo-2-e0d62ae73aebd387e70b9e4929739b2b2a6a1b69.tar.gz
gentoo-2-e0d62ae73aebd387e70b9e4929739b2b2a6a1b69.tar.bz2
gentoo-2-e0d62ae73aebd387e70b9e4929739b2b2a6a1b69.zip
fix possible build breaker
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog7
-rw-r--r--sys-devel/gcc/gcc-3.2-r1.ebuild12
2 files changed, 17 insertions, 2 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index a9f004e49d8d..dcf6c56d16f5 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,9 +1,14 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.33 2002/08/27 20:55:39 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.34 2002/09/09 20:35:01 azarah Exp $
*gcc-3.2-r1 (27 Aug 2002)
+ 9 Sep 2002; Martin Schlemmer <azarah@gentoo.org> gcc-3.2-r1.ebuild :
+
+ Remove symlinks that are installed to /usr/lib/gcc-lib/$CHOST/$PV/include,
+ as it may cause the build to fail.
+
27 Aug 2002; Martin Schlemmer <azarah@gentoo.org> gcc-3.2-r1.ebuild :
Update the "misconstruct function call frame" bug patches. This resolves
diff --git a/sys-devel/gcc/gcc-3.2-r1.ebuild b/sys-devel/gcc/gcc-3.2-r1.ebuild
index 6f4e4f7a49ea..3bf51d2b5eea 100644
--- a/sys-devel/gcc/gcc-3.2-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2-r1.ebuild,v 1.1 2002/08/27 20:55:39 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2-r1.ebuild,v 1.2 2002/09/09 20:35:01 azarah Exp $
# NOTE TO MAINTAINER: Info pages get nuked for multiple version installs.
# Ill fix it later if i get a chance.
@@ -196,6 +196,16 @@ src_compile() {
}
src_install() {
+ # Do allow symlinks in ${LOC}/lib/gcc-lib/${CHOST}/${PV}/include as
+ # this can break the build.
+ for x in cd ${WORKDIR}/build/gcc/include/*
+ do
+ if [ -L ${x} ]
+ then
+ rm -f ${x}
+ fi
+ done
+
# Do the 'make install' from the build directory
cd ${WORKDIR}/build
S="${WORKDIR}/build" \