summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Volynets <iluxa@gentoo.org>2004-08-15 07:31:35 +0000
committerIlya Volynets <iluxa@gentoo.org>2004-08-15 07:31:35 +0000
commite19581930641905b4c7abff055c330ce5d9b0545 (patch)
tree87d0b3effeaab22dfe5332387a34e742070b9575 /sys-devel
parentver bump #57933 (diff)
downloadgentoo-2-e19581930641905b4c7abff055c330ce5d9b0545.tar.gz
gentoo-2-e19581930641905b4c7abff055c330ce5d9b0545.tar.bz2
gentoo-2-e19581930641905b4c7abff055c330ce5d9b0545.zip
Make sure all gcc libraries go into version-specific dir on n32-only and n64-only systems
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog8
-rw-r--r--sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n32only.patch4
-rw-r--r--sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n64only.patch4
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r2.ebuild4
4 files changed, 13 insertions, 7 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index cd2aa2cfa9ff..7d6f14904b90 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,11 +1,17 @@
# ChangeLog for sys-devel/gcc
# Copyright 2002-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.305 2004/08/15 02:25:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.306 2004/08/15 07:31:35 iluxa Exp $
14 Aug 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.0-r6.ebuild,
gcc-3.4.1-r2.ebuild, gcc-3.4.1.ebuild:
-mcpu is deprecated on amd64 and x86
+ 14 Aug 2004; Ilya A. Volynets-Evenbach <iluxa@gentoo.org>
+ files/3.4.1/gcc-3.4.1-mips-n32only.patch,
+ files/3.4.1/gcc-3.4.1-mips-n64only.patch, gcc-3.4.1-r2.ebuild:
+ Make sure all gcc libraries go into version-specific dir on n32-only and
+ n64-only systems
+
13 Aug 2004; Travis Tilley <lv@gentoo.org> gcc-3.4.1-r2.ebuild:
stable on amd64 :)
diff --git a/sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n32only.patch b/sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n32only.patch
index 4e459afd5f55..6fba12b78a44 100644
--- a/sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n32only.patch
+++ b/sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n32only.patch
@@ -10,8 +10,8 @@ diff -u -r1.3 t-linux64
-MULTILIB_DIRNAMES = o32 32 64
-MULTILIB_OSDIRNAMES = ../lib ../lib32 ../lib64
+MULTILIB_OPTIONS = mabi=n32
-+MULTILIB_DIRNAMES = 32
-+MULTILIB_OSDIRNAMES = ../lib
++MULTILIB_DIRNAMES =
++MULTILIB_OSDIRNAMES =
EXTRA_MULTILIB_PARTS=crtbegin.o crtend.o crtbeginS.o crtendS.o crtbeginT.o
diff --git a/sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n64only.patch b/sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n64only.patch
index bd6bf8b2d092..81baf62ec62a 100644
--- a/sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n64only.patch
+++ b/sys-devel/gcc/files/3.4.1/gcc-3.4.1-mips-n64only.patch
@@ -10,8 +10,8 @@ diff -u -r1.3 t-linux64
-MULTILIB_DIRNAMES = o32 32 64
-MULTILIB_OSDIRNAMES = ../lib ../lib32 ../lib64
+MULTILIB_OPTIONS = mabi=n64
-+MULTILIB_DIRNAMES = 64
-+MULTILIB_OSDIRNAMES = ../lib
++MULTILIB_DIRNAMES =
++MULTILIB_OSDIRNAMES =
EXTRA_MULTILIB_PARTS=crtbegin.o crtend.o crtbeginS.o crtendS.o crtbeginT.o
diff --git a/sys-devel/gcc/gcc-3.4.1-r2.ebuild b/sys-devel/gcc/gcc-3.4.1-r2.ebuild
index ea12c2140ce2..f9c8a15c2089 100644
--- a/sys-devel/gcc/gcc-3.4.1-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r2.ebuild,v 1.8 2004/08/15 02:25:56 lv Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r2.ebuild,v 1.9 2004/08/15 07:31:35 iluxa Exp $
IUSE="static nls bootstrap build multilib gcj gtk f77 objc hardened uclibc n32 n64"
@@ -613,8 +613,8 @@ src_compile() {
case "${CCHOST}" in
mips*)
use multilib && myconf="${myconf} --with-abi=32"
- [ "${ABI}" = n32 ] && myconf="${myconf} --with-abi=n32"
[ "${ABI}" = n64 ] && myconf="${myconf} --with-abi=n64"
+ [ "${ABI}" = n32 ] && myconf="${myconf} --with-abi=n32"
;;
esac