summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNed Ludd <solar@gentoo.org>2006-08-14 16:32:23 +0000
committerNed Ludd <solar@gentoo.org>2006-08-14 16:32:23 +0000
commite27cf2e449b2611f70e7f35089beb2a747aa592e (patch)
tree36fe840409d5c6fadd306c1eaeb492a505932747 /sys-devel
parent- switch default ordering of gcc-config and eselect-compiler to work around p... (diff)
downloadgentoo-2-e27cf2e449b2611f70e7f35089beb2a747aa592e.tar.gz
gentoo-2-e27cf2e449b2611f70e7f35089beb2a747aa592e.tar.bz2
gentoo-2-e27cf2e449b2611f70e7f35089beb2a747aa592e.zip
- switch default ordering of gcc-config and eselect-compiler to work around portage bug
(Portage version: 2.1.1_pre2-r7)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/gcc/ChangeLog12
-rw-r--r--sys-devel/gcc/gcc-3.2.3-r4.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.2-r7.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.5-r1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.3.6-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-3.3.6.ebuild6
-rw-r--r--sys-devel/gcc/gcc-3.4.1-r3.ebuild4
-rw-r--r--sys-devel/gcc/gcc-3.4.4-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-3.4.5-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-3.4.5.ebuild6
-rw-r--r--sys-devel/gcc/gcc-3.4.6-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-3.4.6-r2.ebuild6
-rw-r--r--sys-devel/gcc/gcc-3.4.6.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.0.2-r3.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.0.3.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.1.0-r1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.1.1.ebuild6
-rw-r--r--sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild6
19 files changed, 60 insertions, 50 deletions
diff --git a/sys-devel/gcc/ChangeLog b/sys-devel/gcc/ChangeLog
index adb68df7e04f..7a8bc3bd5741 100644
--- a/sys-devel/gcc/ChangeLog
+++ b/sys-devel/gcc/ChangeLog
@@ -1,6 +1,16 @@
# ChangeLog for sys-devel/gcc
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.564 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/ChangeLog,v 1.565 2006/08/14 16:32:23 solar Exp $
+
+ 14 Aug 2006; <solar@gentoo.org> gcc-3.2.3-r4.ebuild, gcc-3.3.2-r7.ebuild,
+ gcc-3.3.5-r1.ebuild, gcc-3.3.5.20050130-r1.ebuild, gcc-3.3.6.ebuild,
+ gcc-3.3.6-r1.ebuild, gcc-3.4.1-r3.ebuild, gcc-3.4.4-r1.ebuild,
+ gcc-3.4.5.ebuild, gcc-3.4.5-r1.ebuild, gcc-3.4.6.ebuild,
+ gcc-3.4.6-r1.ebuild, gcc-3.4.6-r2.ebuild, gcc-4.0.2-r3.ebuild,
+ gcc-4.0.3.ebuild, gcc-4.1.0-r1.ebuild, gcc-4.1.1.ebuild,
+ gcc-4.2.0_alpha20060715.ebuild:
+ - switch default ordering of gcc-config and eselect-compiler to work around
+ portage bug
28 Jul 2006; Kevin F. Quinn <kevquinn@gentoo.org> gcc-3.3.5-r1.ebuild,
gcc-3.3.5.20050130-r1.ebuild, gcc-3.3.6.ebuild, gcc-3.3.6-r1.ebuild,
diff --git a/sys-devel/gcc/gcc-3.2.3-r4.ebuild b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
index 1d035c9e0b96..ad8273f72f28 100644
--- a/sys-devel/gcc/gcc-3.2.3-r4.ebuild
+++ b/sys-devel/gcc/gcc-3.2.3-r4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.21 2006/06/22 05:38:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.2.3-r4.ebuild,v 1.22 2006/08/14 16:32:23 solar Exp $
inherit eutils flag-o-matic libtool versionator
@@ -123,7 +123,7 @@ RDEPEND=">=sys-libs/glibc-2.3.2-r3
>=sys-apps/texinfo-4.2-r4
!build? ( >=sys-libs/ncurses-5.2-r2 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
# Hack used to patch Makefiles to install into the build dir
diff --git a/sys-devel/gcc/gcc-3.3.2-r7.ebuild b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
index 7e0033a444f6..e5c609b99137 100644
--- a/sys-devel/gcc/gcc-3.3.2-r7.ebuild
+++ b/sys-devel/gcc/gcc-3.3.2-r7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.28 2006/06/22 05:38:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.2-r7.ebuild,v 1.29 2006/08/14 16:32:23 solar Exp $
IUSE="static nls bootstrap java build X multilib gcj emul-linux-x86"
@@ -132,7 +132,7 @@ RDEPEND="virtual/libc
>=sys-apps/texinfo-4.2-r4
!build? ( >=sys-libs/ncurses-5.2-r2 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
chk_gcc_version() {
diff --git a/sys-devel/gcc/gcc-3.3.5-r1.ebuild b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
index 09f17507a8df..46391331f574 100644
--- a/sys-devel/gcc/gcc-3.3.5-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.31 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5-r1.ebuild,v 1.32 2006/08/14 16:32:23 solar Exp $
MAN_VER="3.3.5"
#BRANCH_UPDATE="20041025"
@@ -70,7 +70,7 @@ fi
DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
src_unpack() {
gcc_src_unpack
diff --git a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
index a8d82cec7a7c..db21d6978e9c 100644
--- a/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.17 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.5.20050130-r1.ebuild,v 1.18 2006/08/14 16:32:23 solar Exp $
MAN_VER="3.3.5"
PATCH_VER="1.4"
@@ -66,7 +66,7 @@ fi
DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
src_unpack() {
gcc_src_unpack
diff --git a/sys-devel/gcc/gcc-3.3.6-r1.ebuild b/sys-devel/gcc/gcc-3.3.6-r1.ebuild
index 20baba348e18..88bd8d71cc6d 100644
--- a/sys-devel/gcc/gcc-3.3.6-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.3.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6-r1.ebuild,v 1.3 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6-r1.ebuild,v 1.4 2006/08/14 16:32:23 solar Exp $
MAN_VER=""
PATCH_VER="1.4"
@@ -40,7 +40,7 @@ KEYWORDS="-* ~alpha ~amd64 ~arm ~hppa -ia64 ~m68k ~sh ~sparc ~x86"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
# well tested in gentoo on any arch other than amd64!!
-RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+RDEPEND="|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
>=sys-libs/zlib-1.1.4
elibc_glibc? ( >=sys-libs/glibc-2.3.2-r9 )
>=sys-devel/binutils-2.14.90.0.6-r1
@@ -65,7 +65,7 @@ fi
DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
src_unpack() {
gcc_src_unpack
diff --git a/sys-devel/gcc/gcc-3.3.6.ebuild b/sys-devel/gcc/gcc-3.3.6.ebuild
index 7f74c2ae9a53..d77d2d07c6e4 100644
--- a/sys-devel/gcc/gcc-3.3.6.ebuild
+++ b/sys-devel/gcc/gcc-3.3.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.24 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.3.6.ebuild,v 1.25 2006/08/14 16:32:23 solar Exp $
MAN_VER=""
PATCH_VER="1.3"
@@ -40,7 +40,7 @@ KEYWORDS="-* ~alpha ~amd64 arm hppa -ia64 m68k sh ~sparc x86"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
# well tested in gentoo on any arch other than amd64!!
-RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+RDEPEND="|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
>=sys-libs/zlib-1.1.4
elibc_glibc? ( >=sys-libs/glibc-2.3.2-r9 )
>=sys-devel/binutils-2.14.90.0.6-r1
@@ -65,7 +65,7 @@ fi
DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
src_unpack() {
gcc_src_unpack
diff --git a/sys-devel/gcc/gcc-3.4.1-r3.ebuild b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
index 017fa5240f0a..8c3d36ae8de2 100644
--- a/sys-devel/gcc/gcc-3.4.1-r3.ebuild
+++ b/sys-devel/gcc/gcc-3.4.1-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.24 2006/06/22 05:38:55 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.1-r3.ebuild,v 1.25 2006/08/14 16:32:23 solar Exp $
IUSE="static nls bootstrap build multilib gcj gtk fortran objc hardened n32 n64 emul-linux-x86"
@@ -40,7 +40,7 @@ RDEPEND="virtual/libc
>=sys-apps/texinfo-4.2-r4
!build? ( >=sys-libs/ncurses-5.2-r2 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
[ "${ABI}" != "n32" ] && [ "${ABI}" != "n64" ] && PDEPEND="${PDEPEND}
!n32? ( !n64? ( !s390? ( !elibc_uclibc? ( sys-libs/libstdc++-v3 ) ) ) )"
diff --git a/sys-devel/gcc/gcc-3.4.4-r1.ebuild b/sys-devel/gcc/gcc-3.4.4-r1.ebuild
index 0353fc8bed00..23d116a08962 100644
--- a/sys-devel/gcc/gcc-3.4.4-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4-r1.ebuild,v 1.16 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.4-r1.ebuild,v 1.17 2006/08/14 16:32:23 solar Exp $
MAN_VER=""
PATCH_VER="1.7"
@@ -46,7 +46,7 @@ KEYWORDS="-* alpha amd64 arm -hppa ~ia64 mips ppc ppc64 ~s390 sh ~sparc x86"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
# well tested in gentoo on any arch other than amd64!!
-RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+RDEPEND="|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
>=sys-libs/zlib-1.1.4
elibc_glibc? (
>=sys-libs/glibc-2.3.3_pre20040420-r1
@@ -73,7 +73,7 @@ DEPEND="${RDEPEND}
>=sys-devel/bison-1.875
>=sys-devel/binutils-2.14.90.0.8-r1
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( || ( sys-libs/libstdc++-v3 =sys-devel/gcc-3.3* ) ) ) ) )"
src_unpack() {
diff --git a/sys-devel/gcc/gcc-3.4.5-r1.ebuild b/sys-devel/gcc/gcc-3.4.5-r1.ebuild
index 40936ec5a51e..9fb8e0c7e55f 100644
--- a/sys-devel/gcc/gcc-3.4.5-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.5-r1.ebuild,v 1.14 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.5-r1.ebuild,v 1.15 2006/08/14 16:32:23 solar Exp $
MAN_VER=""
PATCH_VER="1.4"
@@ -43,7 +43,7 @@ KEYWORDS="-* ~amd64 arm -hppa ~ia64 ~mips ppc ~ppc64 ~s390 sh x86"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
# well tested in gentoo on any arch other than amd64!!
-RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+RDEPEND="|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
>=sys-libs/zlib-1.1.4
elibc_glibc? (
>=sys-libs/glibc-2.3.3_pre20040420-r1
@@ -70,7 +70,7 @@ DEPEND="${RDEPEND}
>=sys-devel/bison-1.875
>=sys-devel/binutils-2.14.90.0.8-r1
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( || ( sys-libs/libstdc++-v3 =sys-devel/gcc-3.3* ) ) ) ) )"
src_unpack() {
diff --git a/sys-devel/gcc/gcc-3.4.5.ebuild b/sys-devel/gcc/gcc-3.4.5.ebuild
index 8c13f0ae8145..a5c3804f8992 100644
--- a/sys-devel/gcc/gcc-3.4.5.ebuild
+++ b/sys-devel/gcc/gcc-3.4.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.5.ebuild,v 1.17 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.5.ebuild,v 1.18 2006/08/14 16:32:23 solar Exp $
MAN_VER=""
PATCH_VER="1.2"
@@ -43,7 +43,7 @@ KEYWORDS="-* amd64 ~arm -hppa ~ia64 mips ~ppc ~ppc64 ~s390 sh sparc x86"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
# well tested in gentoo on any arch other than amd64!!
-RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+RDEPEND="|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
>=sys-libs/zlib-1.1.4
elibc_glibc? (
>=sys-libs/glibc-2.3.3_pre20040420-r1
@@ -70,7 +70,7 @@ DEPEND="${RDEPEND}
>=sys-devel/bison-1.875
>=sys-devel/binutils-2.14.90.0.8-r1
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( || ( sys-libs/libstdc++-v3 =sys-devel/gcc-3.3* ) ) ) ) )"
src_unpack() {
diff --git a/sys-devel/gcc/gcc-3.4.6-r1.ebuild b/sys-devel/gcc/gcc-3.4.6-r1.ebuild
index fc9947555074..12f7fb2c3698 100644
--- a/sys-devel/gcc/gcc-3.4.6-r1.ebuild
+++ b/sys-devel/gcc/gcc-3.4.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r1.ebuild,v 1.13 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r1.ebuild,v 1.14 2006/08/14 16:32:23 solar Exp $
MAN_VER=""
PATCH_VER="1.2"
@@ -46,7 +46,7 @@ KEYWORDS="-* alpha amd64 arm mips ppc ppc64 sh sparc x86 ~x86-fbsd"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
# well tested in gentoo on any arch other than amd64!!
-RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+RDEPEND="|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
>=sys-libs/zlib-1.1.4
virtual/libiconv
elibc_glibc? (
@@ -74,7 +74,7 @@ DEPEND="${RDEPEND}
>=sys-devel/bison-1.875
>=sys-devel/binutils-2.14.90.0.8-r1
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( || ( sys-libs/libstdc++-v3 =sys-devel/gcc-3.3* ) ) ) ) )"
src_unpack() {
diff --git a/sys-devel/gcc/gcc-3.4.6-r2.ebuild b/sys-devel/gcc/gcc-3.4.6-r2.ebuild
index 986618c9f2e9..34ea81b50ddc 100644
--- a/sys-devel/gcc/gcc-3.4.6-r2.ebuild
+++ b/sys-devel/gcc/gcc-3.4.6-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.3 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6-r2.ebuild,v 1.4 2006/08/14 16:32:23 solar Exp $
MAN_VER=""
PATCH_VER="1.2"
@@ -46,7 +46,7 @@ KEYWORDS="-* ~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
# well tested in gentoo on any arch other than amd64!!
-RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+RDEPEND="|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
>=sys-libs/zlib-1.1.4
virtual/libiconv
elibc_glibc? (
@@ -74,7 +74,7 @@ DEPEND="${RDEPEND}
>=sys-devel/bison-1.875
>=sys-devel/binutils-2.14.90.0.8-r1
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( || ( sys-libs/libstdc++-v3 =sys-devel/gcc-3.3* ) ) ) ) )"
src_unpack() {
diff --git a/sys-devel/gcc/gcc-3.4.6.ebuild b/sys-devel/gcc/gcc-3.4.6.ebuild
index 30089691835c..c5ca14aef97c 100644
--- a/sys-devel/gcc/gcc-3.4.6.ebuild
+++ b/sys-devel/gcc/gcc-3.4.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6.ebuild,v 1.11 2006/07/28 06:39:21 kevquinn Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-3.4.6.ebuild,v 1.12 2006/08/14 16:32:23 solar Exp $
MAN_VER=""
PATCH_VER="1.0"
@@ -46,7 +46,7 @@ KEYWORDS="-* ~alpha ~amd64 ~arm ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
# NOTE: we SHOULD be using at least binutils 2.15.90.0.1 everywhere for proper
# .eh_frame ld optimisation and symbol visibility support, but it hasnt been
# well tested in gentoo on any arch other than amd64!!
-RDEPEND="|| ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+RDEPEND="|| ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
>=sys-libs/zlib-1.1.4
elibc_glibc? (
>=sys-libs/glibc-2.3.3_pre20040420-r1
@@ -73,7 +73,7 @@ DEPEND="${RDEPEND}
>=sys-devel/bison-1.875
>=sys-devel/binutils-2.14.90.0.8-r1
amd64? ( >=sys-devel/binutils-2.15.90.0.1.1-r1 )"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )
x86? ( !nocxx? ( !elibc_uclibc? ( !build? ( || ( sys-libs/libstdc++-v3 =sys-devel/gcc-3.3* ) ) ) ) )"
src_unpack() {
diff --git a/sys-devel/gcc/gcc-4.0.2-r3.ebuild b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
index 8e429fb19df8..86ef5ce1f76c 100644
--- a/sys-devel/gcc/gcc-4.0.2-r3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.2-r3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r3.ebuild,v 1.17 2006/07/18 05:08:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.2-r3.ebuild,v 1.18 2006/08/14 16:32:23 solar Exp $
PATCH_VER="1.6"
PATCH_GCC_VER="4.0.2"
@@ -30,7 +30,7 @@ LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-* ~ia64"
RDEPEND=">=sys-libs/zlib-1.1.4
- || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
fortran? (
dev-libs/gmp
dev-libs/mpfr
@@ -52,7 +52,7 @@ DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
>=${CATEGORY}/binutils-2.15.94"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
fi
diff --git a/sys-devel/gcc/gcc-4.0.3.ebuild b/sys-devel/gcc/gcc-4.0.3.ebuild
index fd1e6e7e2811..4b7b847d2e2a 100644
--- a/sys-devel/gcc/gcc-4.0.3.ebuild
+++ b/sys-devel/gcc/gcc-4.0.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.3.ebuild,v 1.10 2006/07/18 05:08:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.0.3.ebuild,v 1.11 2006/08/14 16:32:23 solar Exp $
PATCH_VER="1.3"
UCLIBC_VER="1.0"
@@ -25,7 +25,7 @@ LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-* ~ia64"
RDEPEND=">=sys-libs/zlib-1.1.4
- || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
fortran? (
dev-libs/gmp
dev-libs/mpfr
@@ -47,7 +47,7 @@ DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
>=${CATEGORY}/binutils-2.15.94"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
fi
diff --git a/sys-devel/gcc/gcc-4.1.0-r1.ebuild b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
index 29e11d849455..e73c9f338812 100644
--- a/sys-devel/gcc/gcc-4.1.0-r1.ebuild
+++ b/sys-devel/gcc/gcc-4.1.0-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0-r1.ebuild,v 1.10 2006/07/18 05:08:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.0-r1.ebuild,v 1.11 2006/08/14 16:32:23 solar Exp $
PATCH_VER="1.7"
UCLIBC_VER="1.1"
@@ -19,7 +19,7 @@ LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-* ~amd64 ~hppa ~ppc ~s390 ~x86"
RDEPEND=">=sys-libs/zlib-1.1.4
- || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
virtual/libiconv
fortran? (
>=dev-libs/gmp-4.2.1
@@ -42,7 +42,7 @@ DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
>=${CATEGORY}/binutils-2.15.94"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
fi
diff --git a/sys-devel/gcc/gcc-4.1.1.ebuild b/sys-devel/gcc/gcc-4.1.1.ebuild
index 82a25e21f08f..ec560b3ff867 100644
--- a/sys-devel/gcc/gcc-4.1.1.ebuild
+++ b/sys-devel/gcc/gcc-4.1.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.1.ebuild,v 1.15 2006/07/18 05:08:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.1.1.ebuild,v 1.16 2006/08/14 16:32:23 solar Exp $
PATCH_VER="1.6"
UCLIBC_VER="1.0"
@@ -19,7 +19,7 @@ LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-* ~amd64 hppa ~mips ppc ~ppc64 ~s390 ~x86 ~x86-fbsd"
RDEPEND=">=sys-libs/zlib-1.1.4
- || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
virtual/libiconv
fortran? (
>=dev-libs/gmp-4.2.1
@@ -42,7 +42,7 @@ DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
>=${CATEGORY}/binutils-2.15.94"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
fi
diff --git a/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild b/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild
index 9cfd73659bbb..f5996db358c5 100644
--- a/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild
+++ b/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild,v 1.2 2006/07/18 05:08:21 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/gcc/gcc-4.2.0_alpha20060715.ebuild,v 1.3 2006/08/14 16:32:23 solar Exp $
ETYPE="gcc-compiler"
@@ -12,7 +12,7 @@ LICENSE="GPL-2 LGPL-2.1"
KEYWORDS="-*"
RDEPEND=">=sys-libs/zlib-1.1.4
- || ( app-admin/eselect-compiler >=sys-devel/gcc-config-1.3.12-r4 )
+ || ( >=sys-devel/gcc-config-1.3.12-r4 app-admin/eselect-compiler )
virtual/libiconv
fortran? (
>=dev-libs/gmp-4.2.1
@@ -34,7 +34,7 @@ DEPEND="${RDEPEND}
>=sys-apps/texinfo-4.2-r4
>=sys-devel/bison-1.875
>=${CATEGORY}/binutils-2.16.1"
-PDEPEND="|| ( app-admin/eselect-compiler sys-devel/gcc-config )"
+PDEPEND="|| ( sys-devel/gcc-config app-admin/eselect-compiler )"
if [[ ${CATEGORY} != cross-* ]] ; then
PDEPEND="${PDEPEND} elibc_glibc? ( >=sys-libs/glibc-2.3.6 )"
fi