summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Cummings <mcummings@gentoo.org>2002-08-05 01:52:21 +0000
committerMichael Cummings <mcummings@gentoo.org>2002-08-05 01:52:21 +0000
commite9ede4b0b182d0f6d99f3ae014a87a743f19dc1b (patch)
treebafb5fb06649c3535aa770a6e203e0aeade2984b /sys-devel
parentadded mask for perl-5.6.1-r6; -r5 and below were hardcoded for i686 (diff)
downloadgentoo-2-e9ede4b0b182d0f6d99f3ae014a87a743f19dc1b.tar.gz
gentoo-2-e9ede4b0b182d0f6d99f3ae014a87a743f19dc1b.tar.bz2
gentoo-2-e9ede4b0b182d0f6d99f3ae014a87a743f19dc1b.zip
Ebuild contained hardcoded references for the i686 platform. Changed these to
use the $PARCH variable so that ebuilds would be specific to intended platform.
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/perl/files/digest-perl-5.6.1-r61
-rw-r--r--sys-devel/perl/perl-5.6.1-r6.ebuild188
2 files changed, 189 insertions, 0 deletions
diff --git a/sys-devel/perl/files/digest-perl-5.6.1-r6 b/sys-devel/perl/files/digest-perl-5.6.1-r6
new file mode 100644
index 000000000000..a1b30f92f979
--- /dev/null
+++ b/sys-devel/perl/files/digest-perl-5.6.1-r6
@@ -0,0 +1 @@
+MD5 ec1ff15464809b562aecfaa2e65edba6 perl-5.6.1.tar.gz 5983695
diff --git a/sys-devel/perl/perl-5.6.1-r6.ebuild b/sys-devel/perl/perl-5.6.1-r6.ebuild
new file mode 100644
index 000000000000..4c028f5ea3ac
--- /dev/null
+++ b/sys-devel/perl/perl-5.6.1-r6.ebuild
@@ -0,0 +1,188 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# /space/gentoo/cvsroot/gentoo-x86/sys-devel/perl/perl-5.6.1-r3.ebuild,v 1.3 2002/04/29 20:53:42 sandymac Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Larry Wall's Practical Extraction and Reporting Language"
+SRC_URI="ftp://ftp.perl.org/pub/CPAN/src/${P}.tar.gz"
+HOMEPAGE="http://www.perl.org"
+LICENSE="Artistic GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+
+DEPEND="sys-apps/groff berkdb? ( >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1 ) gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+RDEPEND="berkdb? ( >=sys-libs/db-3.2.3h-r3 =sys-libs/db-1.85-r1 ) gdbm? ( >=sys-libs/gdbm-1.8.0 )"
+
+src_compile() {
+
+ local myconf
+ if [ "`use gdbm`" ]
+ then
+ myconf="-Di_gdbm"
+ fi
+ if [ "`use berkdb`" ]
+ then
+ myconf="${myconf} -Di_db -Di_ndbm"
+ else
+ myconf="${myconf} -Ui_db -Ui_ndbm"
+ fi
+
+ # configure for libperl.so
+ sh Configure -des \
+ -Darchname=${CHOST%%-*}-linux \
+ -Dcccdlflags='-fPIC' \
+ -Dccdlflags='-rdynamic' \
+ -Dprefix=/usr \
+ -Dlocincpth=' ' \
+ -Doptimize="${CFLAGS}" \
+ -Duselargefiles \
+ -Duseshrplib \
+ -Dlibperl=libperl.so \
+ -Dd_dosuid \
+ -Dd_semctl_semun \
+ ${myconf} || die
+ # add optimization flags
+ cp config.sh config.sh.orig
+ sed -e "s/optimize='-O2'/optimize=\'${CFLAGS}\'/" config.sh.orig > config.sh
+ # create libperl.so and move it out of the way
+ mv -f Makefile Makefile_orig
+ sed -e 's#^CCDLFLAGS = -rdynamic -Wl,-rpath,/usr/lib/perl5/.*#CCDLFLAGS = -rdynamic#' \
+ -e 's#^all: $(FIRSTMAKEFILE) #all: README #' \
+ Makefile_orig > Makefile
+ export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+ make -f Makefile depend || die
+ mv makefile makefile_orig
+ mv x2p/makefile x2p/makefile_orig
+ egrep -v "(<built-in>|<command line>)" makefile_orig >makefile
+ egrep -v "(<built-in>|<command line>)" x2p/makefile_orig >x2p/makefile
+ make -f Makefile libperl.so || die
+ mv libperl.so ${WORKDIR}
+
+ # starting from scratch again
+ cd ${WORKDIR}
+ rm -rf ${S}
+ unpack ${A}
+ cd ${S}
+
+ # configure for libperl.a
+# this is gross -- from Christian Gafton, Red Hat
+ cat > config.over <<EOF
+installprefix=${D}/usr
+#test -d \$installprefix || mkdir \$installprefix
+#test -d \$installprefix/bin || mkdir \$installprefix/bin
+installarchlib=\`echo \$installarchlib | sed "s!\$prefix!\$installprefix!"\`
+installbin=\`echo \$installbin | sed "s!\$prefix!\$installprefix!"\`
+#installman1dir=\$installprefix/share/man/man1
+#installman3dir=\$installprefix/share/man/man3
+installman1dir=\`echo \$installman1dir | sed "s!\$prefix!\$installprefix!"\`
+installman3dir=\`echo \$installman3dir | sed "s!\$prefix!\$installprefix!"\`
+installman1dir=\`echo \$installman1dir | sed "s!/man/!/share/man/!"\`
+installman3dir=\`echo \$installman3dir | sed "s!/man/!/share/man/!"\`
+man1ext=1
+man3ext=3pm
+installprivlib=\`echo \$installprivlib | sed "s!\$prefix!\$installprefix!"\`
+installscript=\`echo \$installscript | sed "s!\$prefix!\$installprefix!"\`
+installsitelib=\`echo \$installsitelib | sed "s!\$prefix!\$installprefix!"\`
+installsitearch=\`echo \$installsitearch | sed "s!\$prefix!\$installprefix!"\`
+EOF
+
+ sh Configure -des \
+ -Dprefix=/usr \
+ -Darchname=${CHOST%%-*}-linux \
+ -Duselargefiles \
+ -Dd_dosuid \
+ -Dlocincpth=' ' \
+ -Dd_semctl_semun \
+ ${myconf} || die
+
+ #Optimize ;)
+ cp config.sh config.sh.orig
+ sed -e "s/optimize='-O2'/optimize=\'${CFLAGS}\'/" config.sh.orig > config.sh
+ #THIS IS USED LATER:
+ export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+
+# Umm, for some reason this doesn't want to work, so we'll just remove
+# the makefiles and let make rebuild them itself. (It seems to do it
+# right the second time... -- pete
+# cp makefile makefile.orig
+# sed -e "s:^0::" makefile.orig > makefile
+
+ mv Makefile Makefile_orig
+ sed -e 's#^all: $(FIRSTMAKEFILE) #all: README #' \
+ Makefile_orig > Makefile
+
+ #for some reason, this rm -f doesn't seem to actually do anything. So we explicitly use "Makefile"
+ #(rather than the default "makefile") in all make commands below.
+ rm -f makefile x2p/makefile
+ make -f Makefile depend || die
+ mv makefile makefile_orig
+ mv x2p/makefile x2p/makefile_orig
+ egrep -v "(<built-in>|<command line>)" makefile_orig >makefile
+ egrep -v "(<built-in>|<command line>)" x2p/makefile_orig >x2p/makefile
+ make -f Makefile || die
+ # Parallel make fails
+ # dont use the || die since some tests fail on bootstrap
+ if [ `expr "$PARCH" ":" "sparc"` -gt 4 ]; then
+ echo "Skipping tests on this platform"
+ else
+ make -f Makefile test
+ fi
+}
+
+src_install() {
+
+ export PARCH=`grep myarchname config.sh | cut -f2 -d"'"`
+
+ insinto /usr/lib/perl5/${PV}/${PARCH}/CORE/
+ doins ${WORKDIR}/libperl.so
+ dosym /usr/lib/perl5/${PV}/${PARCH}/CORE/libperl.so /usr/lib/libperl.so
+
+
+ make -f Makefile INSTALLMAN1DIR=${D}/usr/share/man/man1 INSTALLMAN3DIR=${D}/usr/share/man/man3 install || die
+ install -m 755 utils/pl2pm ${D}/usr/bin/pl2pm
+
+make all -f - <<EOF
+STDH =\$(wildcard /usr/include/linux/*.h) \$(wildcard /usr/include/asm/*.h) \
+ \$(wildcard /usr/include/scsi/*.h)
+GCCDIR = \$(shell gcc --print-file-name include)
+
+PERLLIB = \$(D)/usr/lib/perl5/%{perlver}%{perlrel}
+PERL = PERL5LIB=\$(PERLLIB) \$(D)/usr/bin/perl
+PHDIR = \$(PERLLIB)/\${PARCH}-linux
+H2PH = \$(PERL) \$(D)/usr/bin/h2ph -d \$(PHDIR)/
+
+all: std-headers gcc-headers fix-config
+
+std-headers: \$(STDH)
+ cd /usr/include && \$(H2PH) \$(STDH:/usr/include/%%=%%)
+
+gcc-headers: \$(GCCH)
+ cd \$(GCCDIR) && \$(H2PH) \$(GCCH:\$(GCCDIR)/%%=%%)
+
+fix-config: \$(PHDIR)/Config.pm
+ \$(PERL) -i -p -e "s|\$(D)||g;" \$<
+
+EOF
+
+#man pages
+
+# ./perl installman --man1dir=${D}/usr/share/man/man1 --man1ext=1 --man3dir=${D}/usr/share/man/man3 --man3ext=3
+
+
+# This removes ${D} from Config.pm
+
+ dosed /usr/lib/perl5/${PV}/${CHOST%%-*}-linux/Config.pm
+ dosed /usr/lib/perl5/${PV}/${CHOST%%-*}-linux/.packlist
+
+# DOCUMENTATION
+
+ dodoc Changes* Artistic Copying README Todo* AUTHORS
+ prepalldocs
+
+# HTML Documentation
+
+ dodir /usr/share/doc/${PF}/html
+ ./perl installhtml --recurse --htmldir=${D}/usr/share/doc/${PF}/html
+
+}