summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMartin Schlemmer <azarah@gentoo.org>2003-01-21 17:26:07 +0000
committerMartin Schlemmer <azarah@gentoo.org>2003-01-21 17:26:07 +0000
commitecd65c9b297517b01dc26d5064a653aed35bf874 (patch)
treeb7a62b22b85edef6c9d1312f7c7f7698af405cfe /sys-devel
parentRemoving all directfb support (diff)
downloadgentoo-2-ecd65c9b297517b01dc26d5064a653aed35bf874.tar.gz
gentoo-2-ecd65c9b297517b01dc26d5064a653aed35bf874.tar.bz2
gentoo-2-ecd65c9b297517b01dc26d5064a653aed35bf874.zip
new version
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/autoconf/ChangeLog7
-rw-r--r--sys-devel/autoconf/autoconf-2.57.ebuild139
-rw-r--r--sys-devel/autoconf/files/ac-wrapper.pl4
-rw-r--r--sys-devel/autoconf/files/autoconf-2.57-infopage-namechange.patch107
-rw-r--r--sys-devel/autoconf/files/digest-autoconf-2.572
-rw-r--r--sys-devel/automake/ChangeLog8
-rw-r--r--sys-devel/automake/automake-1.7.2.ebuild424
-rw-r--r--sys-devel/automake/files/am-wrapper.pl-1.7119
-rw-r--r--sys-devel/automake/files/automake-1.7.2-infopage-namechange.patch14
-rw-r--r--sys-devel/automake/files/digest-automake-1.7.24
10 files changed, 824 insertions, 4 deletions
diff --git a/sys-devel/autoconf/ChangeLog b/sys-devel/autoconf/ChangeLog
index 9345cecc7a53..0b7444412109 100644
--- a/sys-devel/autoconf/ChangeLog
+++ b/sys-devel/autoconf/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-devel/autoconf
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.14 2003/01/17 11:35:12 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/ChangeLog,v 1.15 2003/01/21 17:25:54 azarah Exp $
+
+autoconf-2.57 (21 Jan 2003)
+
+ 21 Jan 2003; Martin Schlemmer <azarah@gentoo.org> autoconf-2.57.ebuild :
+ New version.
17 Jan 2003; Martin Schlemmer <azarah@gentoo.org> autoconf-2.54.ebuild :
Depend on texinfo-4.3, else info pages breaks, bug #13041.
diff --git a/sys-devel/autoconf/autoconf-2.57.ebuild b/sys-devel/autoconf/autoconf-2.57.ebuild
new file mode 100644
index 000000000000..1a54ae1a3571
--- /dev/null
+++ b/sys-devel/autoconf/autoconf-2.57.ebuild
@@ -0,0 +1,139 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/autoconf/autoconf-2.57.ebuild,v 1.1 2003/01/21 17:25:54 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+OLD_PV="2.13"
+OLD_P="${PN}-${OLD_PV}"
+S="${WORKDIR}/${P}"
+OLD_S="${WORKDIR}/${OLD_P}"
+DESCRIPTION="Used to create autoconfiguration files"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.bz2
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/autoconf/autoconf.html"
+
+LICENSE="GPL-2"
+SLOT="2.5"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha"
+
+DEPEND=">=sys-apps/texinfo-4.3
+ >=sys-devel/m4-1.4p
+ sys-devel/perl"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${OLD_S}
+ epatch ${FILESDIR}/${OLD_P}-configure-gentoo.diff
+ epatch ${FILESDIR}/${OLD_P}-configure.in-gentoo.diff
+
+ cd ${S}
+ # Enable both autoconf-2.1 and autoconf-2.5 info pages
+ epatch ${FILESDIR}/${PN}-2.57-infopage-namechange.patch
+ ln -snf ${S}/doc/autoconf.texi ${S}/doc/autoconf25.texi
+}
+
+src_compile() {
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+ cd ${S}
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+ cd ${OLD_S}
+
+ perl -pi -e 's|\* Autoconf:|\* Autoconf v2.1:|' autoconf.texi
+ cp autoconf.texi autoconf.texi.orig
+ sed -e '/START-INFO-DIR-ENTRY/ i INFO-DIR-SECTION GNU programming tools' \
+ autoconf.texi.orig > autoconf.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ doexe ${FILESDIR}/ac-wrapper.pl
+ dosed "s:2\.5x:${PV}:g" /usr/lib/${PN}/ac-wrapper.pl
+
+ #
+ # ************ autoconf-2.5x ************
+ #
+
+ # need to use 'DESTDIR' here, else perl stuff puke
+ cd ${S}
+ make DESTDIR=${D} \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${PV}
+ done
+ # new in 2.5x
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/autom4te
+
+# mv ${D}/usr/share/info/autoconf.info ${D}/usr/share/info/autoconf-2.5.info
+
+ docinto ${PV}
+ dodoc COPYING AUTHORS BUGS NEWS README TODO THANKS
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1 ChangeLog.2
+
+ #
+ # ************ autoconf-2.13 ************
+ #
+
+ # need to use 'prefix' here, else we get sandbox problems
+ cd ${OLD_S}
+ make prefix=${D}/usr \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ install || die
+
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD_PV}
+ dosym ../lib/${PN}/ac-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD_PV}
+ dodoc COPYING AUTHORS NEWS README TODO
+ dodoc ChangeLog ChangeLog.0 ChangeLog.1
+
+ # from binutils
+ rm -f ${D}/usr/share/info/standards.info*
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in autoconf autoheader autoreconf autoscan autoupdate ifnames autom4te
+ do
+ if [ -e /usr/bin/${x} ]
+ then
+ rm -f /usr/bin/${x}
+ fi
+ done
+}
+
diff --git a/sys-devel/autoconf/files/ac-wrapper.pl b/sys-devel/autoconf/files/ac-wrapper.pl
index 29005d259501..7b9bcb71bb0f 100644
--- a/sys-devel/autoconf/files/ac-wrapper.pl
+++ b/sys-devel/autoconf/files/ac-wrapper.pl
@@ -42,10 +42,10 @@ if (!$ENV{WANT_AUTOCONF_2_1}) {
if (-x $binary_new # user may have only 2.13
&& ($ENV{WANT_AUTOCONF_2_5}
|| -r 'configure.ac'
- || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
|| (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
|| (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
- || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\)/m ? $1 : '') gt '2.1')) {
+ || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1')) {
$ENV{WANT_AUTOCONF_2_5} = 1; # to prevent further "cats" and to enhance consistency (possible cwd etc)
$binary = $binary_new;
} else {
diff --git a/sys-devel/autoconf/files/autoconf-2.57-infopage-namechange.patch b/sys-devel/autoconf/files/autoconf-2.57-infopage-namechange.patch
new file mode 100644
index 000000000000..f7f6cbc98042
--- /dev/null
+++ b/sys-devel/autoconf/files/autoconf-2.57-infopage-namechange.patch
@@ -0,0 +1,107 @@
+--- autoconf-2.57/doc/autoconf.texi.orig 2003-01-20 21:25:17.000000000 +0200
++++ autoconf-2.57/doc/autoconf.texi 2003-01-20 21:29:26.000000000 +0200
+@@ -1,9 +1,9 @@
+ \input texinfo @c -*-texinfo-*-
+ @comment ========================================================
+ @comment %**start of header
+-@setfilename autoconf.info
++@setfilename autoconf25.info
+ @include version.texi
+-@settitle Autoconf
++@settitle Autoconf v2.5
+ @setchapternewpage odd
+ @setcontentsaftertitlepage
+ @finalout
+@@ -97,35 +97,35 @@
+
+ @dircategory GNU programming tools
+ @direntry
+-* Autoconf: (autoconf). Create source code configuration scripts
++* Autoconf v2.5: (autoconf25). Create source code configuration scripts
+ @end direntry
+
+ @dircategory Individual utilities
+ @direntry
+-* autoscan: (autoconf)autoscan Invocation.
++* autoscan: (autoconf25)autoscan Invocation.
+ Semi-automatic @file{configure.ac} writing
+-* ifnames: (autoconf)ifnames Invocation.
++* ifnames: (autoconf25)ifnames Invocation.
+ Listing the conditionals in source code
+-* autoconf: (autoconf)autoconf Invocation.
++* autoconf: (autoconf25)autoconf Invocation.
+ How to create configuration scripts
+-* autoreconf: (autoconf)autoreconf Invocation.
++* autoreconf: (autoconf25)autoreconf Invocation.
+ Remaking multiple @command{configure} scripts
+-* autoheader: (autoconf)autoheader Invocation.
++* autoheader: (autoconf25)autoheader Invocation.
+ How to create configuration templates
+-* autom4te: (autoconf)autom4te Invocation.
++* autom4te: (autoconf25)autom4te Invocation.
+ The Autoconf executables backbone
+-* configure: (autoconf)configure Invocation.
++* configure: (autoconf25)configure Invocation.
+ Configuring a package
+-* autoupdate: (autoconf)autoupdate Invocation.
++* autoupdate: (autoconf25)autoupdate Invocation.
+ Automatic update of @file{configure.ac}
+-* config.status: (autoconf)config.status Invocation.
++* config.status: (autoconf25)config.status Invocation.
+ Recreating a configuration
+-* testsuite: (autoconf)testsuite Invocation.
++* testsuite: (autoconf25)testsuite Invocation.
+ Running an Autotest test suite
+ @end direntry
+
+ @titlepage
+-@title Autoconf
++@title Autoconf v2.5
+ @subtitle Creating Automatic Configuration Scripts
+ @subtitle for version @value{VERSION}, @value{UPDATED}
+ @author David MacKenzie
+--- autoconf-2.57/doc/Makefile.in.orig 2003-01-20 21:29:55.000000000 +0200
++++ autoconf-2.57/doc/Makefile.in 2003-01-20 21:31:12.000000000 +0200
+@@ -96,7 +96,7 @@
+ TEXI2HTML = texi2html
+ TEXI2HTML_FLAGS = -split_chapter
+
+-info_TEXINFOS = autoconf.texi standards.texi
++info_TEXINFOS = autoconf25.texi standards.texi
+ autoconf_TEXINFOS = fdl.texi install.texi
+ standards_TEXINFOS = make-stds.texi
+
+@@ -113,11 +113,11 @@
+ DIST_SOURCES =
+ TEXINFO_TEX = $(top_srcdir)/config/texinfo.tex
+ am__TEXINFO_TEX_DIR = $(top_srcdir)/config
+-INFO_DEPS = autoconf.info standards.info
++INFO_DEPS = autoconf25.info standards.info
+ DVIS = autoconf.dvi standards.dvi
+ PDFS = autoconf.pdf standards.pdf
+ PSS = autoconf.ps standards.ps
+-TEXINFOS = autoconf.texi standards.texi
++TEXINFOS = autoconf25.texi standards.texi
+ DIST_COMMON = $(autoconf_TEXINFOS) $(standards_TEXINFOS) Makefile.am \
+ Makefile.in stamp-vti version.texi
+ all: all-am
+@@ -144,13 +144,13 @@
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
+ MAKEINFO='$(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir)' \
+ $(TEXI2PDF) `test -f '$<' || echo '$(srcdir)/'`$<
+-autoconf.info: autoconf.texi version.texi $(autoconf_TEXINFOS)
+-autoconf.dvi: autoconf.texi version.texi $(autoconf_TEXINFOS)
+-autoconf.pdf: autoconf.texi version.texi $(autoconf_TEXINFOS)
++autoconf25.info: autoconf25.texi version.texi $(autoconf_TEXINFOS)
++autoconf.dvi: autoconf25.texi version.texi $(autoconf_TEXINFOS)
++autoconf.pdf: autoconf25.texi version.texi $(autoconf_TEXINFOS)
+ version.texi: stamp-vti
+-stamp-vti: autoconf.texi $(top_srcdir)/configure
+- @(dir=.; test -f ./autoconf.texi || dir=$(srcdir); \
+- set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf.texi`; \
++stamp-vti: autoconf25.texi $(top_srcdir)/configure
++ @(dir=.; test -f ./autoconf25.texi || dir=$(srcdir); \
++ set `$(SHELL) $(top_srcdir)/config/mdate-sh $$dir/autoconf25.texi`; \
+ echo "@set UPDATED $$1 $$2 $$3"; \
+ echo "@set UPDATED-MONTH $$2 $$3"; \
+ echo "@set EDITION $(VERSION)"; \
diff --git a/sys-devel/autoconf/files/digest-autoconf-2.57 b/sys-devel/autoconf/files/digest-autoconf-2.57
new file mode 100644
index 000000000000..8c1eeddbdd02
--- /dev/null
+++ b/sys-devel/autoconf/files/digest-autoconf-2.57
@@ -0,0 +1,2 @@
+MD5 407ea53787ce13f5ca427e9a51e05bc2 autoconf-2.57.tar.bz2 811439
+MD5 9de56d4a161a723228220b0f425dc711 autoconf-2.13.tar.gz 443844
diff --git a/sys-devel/automake/ChangeLog b/sys-devel/automake/ChangeLog
index 112ddd8cc4fa..9067f33ce854 100644
--- a/sys-devel/automake/ChangeLog
+++ b/sys-devel/automake/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/automake
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.20 2002/12/14 19:56:58 azarah Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/ChangeLog,v 1.21 2003/01/21 17:26:07 azarah Exp $
+
+*automake-1.7.2 (21 Jan 2003)
+
+ 21 Jan 2003; Martin Schlemmer <azarah@gentoo.org> automake-1.7.2.ebuild :
+ Update version. Change WANT_AUTOMAKE_1_?=1 selection scheme to
+ WANT_AUTOMAKE=<version>.
14 Dec 2002; Martin Schlemmer <azarah@gentoo.org> automake-1.6.3.ebuild :
Fix info pages to also get 1.5 and 1.6 in info DIR.
diff --git a/sys-devel/automake/automake-1.7.2.ebuild b/sys-devel/automake/automake-1.7.2.ebuild
new file mode 100644
index 000000000000..fea83103dabd
--- /dev/null
+++ b/sys-devel/automake/automake-1.7.2.ebuild
@@ -0,0 +1,424 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/automake/automake-1.7.2.ebuild,v 1.1 2003/01/21 17:26:07 azarah Exp $
+
+IUSE=""
+
+inherit eutils
+
+# OLD14 = 1.4
+# OLD15 = 1.5
+# OLD16 = 1.6
+# NEW = 1.7 (.2)
+
+# NOTE: For all of those brave souls out there that wants to fix
+# or update this, note that all three versions install
+# .m4 files to /usr/share/aclocal-${ver}/ and .am files
+# to /usr/share/automake-${ver}/. We then add the default
+# /usr/share/aclocal/ to aclocal's search path by adding
+# "push (@dirlist, \"/usr/share/aclocal\");" after @dirlist
+# is defined the first time (done in fix_bins() function).
+#
+# The theory thus is, all version specific data goes into
+# version specific directories, but programs like ogg/whatever
+# can still install thier .m4 macros into /usr/share/aclocal/.
+#
+# Martin Schlemmer <azarah@gentoo.org>
+# 19 May 2002
+
+
+# Currently this is 1.7, but it could change to 1.7.x as it
+# does with 1.5d ... to determine this, install latest version
+# of 1.7, and look at the generated files in the bin dir ..
+# it should be something like (for 1.7.1):
+#
+# nosferatu automake-1.7.1 # ls /myinstallroot/bin/
+# aclocal aclocal-1.7 automake automake-1.7
+# nosferatu automake-1.7.1 #
+#
+# You should then set NEW_PV to 1.7, as this is the suffix
+NEW_PV="1.7"
+
+OLD16_PV="1.6.3"
+OLD16_PV_S="1.6"
+OLD16_P="${PN}-${OLD16_PV}"
+OLD15_PV="1.5"
+OLD15_P="${PN}-${OLD15_PV}"
+OLD14_PV="1.4-p5"
+OLD14_P="${PN}-${OLD14_PV}"
+S="${WORKDIR}/${P}"
+OLD16_S="${WORKDIR}/${OLD16_P}"
+OLD15_S="${WORKDIR}/${OLD15_P}"
+OLD14_S="${WORKDIR}/${OLD14_P}"
+DESCRIPTION="Used to generate Makefile.in from Makefile.am"
+SRC_URI="ftp://ftp.gnu.org/gnu/${PN}/${P}.tar.gz
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD16_P}.tar.gz
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD15_P}.tar.gz
+ ftp://ftp.gnu.org/gnu/${PN}/${OLD14_P}.tar.gz"
+HOMEPAGE="http://www.gnu.org/software/automake/automake.html"
+
+LICENSE="GPL-2"
+SLOT="1.5"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips"
+
+DEPEND="sys-devel/perl
+ >=sys-devel/autoconf-2.57"
+
+
+src_unpack() {
+
+ unpack ${A}
+
+ cd ${OLD15_S}
+ epatch ${FILESDIR}/${PN}-${OLD15_PV}-target_hook.patch
+
+ cd ${S}
+ epatch ${FILESDIR}/${P}-infopage-namechange.patch
+}
+
+src_compile() {
+
+ #
+ # ************ automake-1.7x ************
+ #
+
+ # stupid configure script goes and run autoconf in a subdir,
+ # so 'ac-wrapper.pl' do not detect that it should use
+ # autoconf-2.5x
+ export WANT_AUTOCONF_2_5=1
+
+ cd ${S}
+
+ perl -pi -e 's:setfilename automake.info:setfilename automake17.info:' \
+ automake.texi
+ perl -pi -e 's|\* automake: \(automake\)|\* Automake v1\.7: \(automake\)|' \
+ automake.texi
+ perl -pi -e 's|\* aclocal:|\* aclocal v1.7:|' automake.texi
+ perl -pi -e 's:\(automake\):\(automake17\):' automake.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ # stupid configure script goes and run autoconf in a subdir,
+ # so 'ac-wrapper.pl' do not detect that it should use
+ # autoconf-2.5x
+ export WANT_AUTOCONF_2_5=1
+
+ cd ${OLD16_S}
+
+ perl -pi -e 's:setfilename automake.info:setfilename automake16.info:' \
+ automake.texi
+ perl -pi -e 's|\* automake: \(automake\)|\* Automake v1\.6: \(automake\)|' \
+ automake.texi
+ perl -pi -e 's|\* aclocal:|\* aclocal v1.6:|' automake.texi
+ perl -pi -e 's:\(automake\):\(automake16\):' automake.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+
+ #
+ # ************ automake-1.5x ************
+ #
+
+ cd ${OLD15_S}
+
+ perl -pi -e 's:setfilename automake.info:setfilename automake15.info:' \
+ automake.texi
+ perl -pi -e 's|\* automake: \(automake\)|\* Automake v1\.5: \(automake\)|' \
+ automake.texi
+ perl -pi -e 's|\* aclocal:|\* aclocal v1.5:|' automake.texi
+ perl -pi -e 's:\(automake\):\(automake15\):' automake.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+ unset WANT_AUTOCONF_2_5
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+ cd ${OLD14_S}
+
+ perl -pi -e 's|\* automake: \(automake\)|\* Automake v1\.4: \(automake\)|' \
+ automake.texi
+ perl -pi -e 's|\* aclocal:|\* aclocal v1.4:|' automake.texi
+ perl -pi -e 's:GNU admin:GNU programming tools:' automake.texi
+# perl -pi -e 's|\* automake: \(automake\)|\* Automake: \(automake\)|' \
+# automake.texi
+
+ ./configure --prefix=/usr \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ --target=${CHOST} || die
+
+ emake || die
+}
+
+# This basically fix aclocal and automake so that they
+# use the correct directories, and also adds the normal
+# /usr/share/aclocal for aclocal to include.
+fix_bins() {
+
+ for x in aclocal automake
+ do
+ perl -pi -e "s:share/automake\":share/automake-${1}\":g" ${x}
+ perl -pi -e "s:share/aclocal\":share/aclocal-${1}\":g" ${x}
+ done
+
+ # add "/usr/share/aclocal" to m4 search patch
+ cp aclocal aclocal.orig
+ sed -e '/&scan_m4_files (@dirlist);/i \push (@dirlist, \"/usr/share/aclocal\");' \
+ aclocal.orig > aclocal
+ # same as above, but 1.4 looks a bit differently
+ cp aclocal aclocal.orig
+ sed -e '/&scan_m4_files ($acdir, @dirlist);/i \push (@dirlist, \"/usr/share/aclocal\");' \
+ aclocal.orig > aclocal
+ # "aclocal --print-ac-dir" should return "/usr/share/aclocal"
+ cp aclocal aclocal.orig
+ sed -e 's:print $acdir:print "/usr/share/aclocal":' \
+ aclocal.orig > aclocal
+}
+
+src_install() {
+
+ # install wrapper script for autodetecting the proper version
+ # to use.
+ exeinto /usr/lib/${PN}
+ newexe ${FILESDIR}/am-wrapper.pl-1.7 am-wrapper.pl
+ # Name binaries to exact version, as they have limited support for
+ # more than one version installs
+ dosed "s:1\.7x:${NEW_PV}:g" /usr/lib/${PN}/am-wrapper.pl
+ dosed "s:1\.6x:${OLD16_PV_S}:g" /usr/lib/${PN}/am-wrapper.pl
+ dosed "s:1\.5x:${OLD15_PV}:g" /usr/lib/${PN}/am-wrapper.pl
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ cd ${S}
+# not needed for 1.7.2
+# fix_bins ${NEW_PV}
+
+ make DESTDIR=${D} \
+ install || die
+
+ for x in automake aclocal
+ do
+# mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${NEW_PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake17.info*
+
+ docinto ${PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.6x ************
+ #
+
+ cd ${OLD16_S}
+# not needed for 1.6.3
+# fix_bins ${NEW_PV}
+
+ make DESTDIR=${D} \
+ install || die
+
+ for x in automake aclocal
+ do
+# mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${NEW_PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake16.info*
+
+ docinto ${PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.5x ************
+ #
+
+ cd ${OLD15_S}
+ fix_bins ${OLD15_PV}
+
+ make DESTDIR=${D} \
+ pkgdatadir=/usr/share/automake-${OLD15_PV} \
+ m4datadir=/usr/share/aclocal-${OLD15_PV} \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-${OLD15_PV}
+ rm -f ${D}/usr/bin/${x}
+ done
+
+ doinfo automake15.info*
+
+ docinto ${OLD15_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ automake-1.4-p5 ************
+ #
+
+ cd ${OLD14_S}
+ fix_bins "1.4"
+
+ # Ignore duplicates like automake-1.5 and 1.6
+ patch -p0 <${FILESDIR}/${PN}-1.4_p5-ignore-duplicates.patch || die
+
+ make DESTDIR=${D} \
+ pkgdatadir=/usr/share/automake-1.4 \
+ m4datadir=/usr/share/aclocal-1.4 \
+ install || die
+
+ for x in automake aclocal
+ do
+ mv ${D}/usr/bin/${x} ${D}/usr/bin/${x}-1.4
+ dosym ../lib/${PN}/am-wrapper.pl /usr/bin/${x}
+ done
+
+ docinto ${OLD14_PV}
+ dodoc COPYING NEWS README THANKS TODO AUTHORS ChangeLog
+
+ #
+ # ************ misc stuff ****************
+
+ # Some packages needs a /usr/share/automake directory
+ dosym automake-1.4 /usr/share/automake
+
+ # This is the default macro directory that apps use ..
+ dodir /usr/share/aclocal
+ touch ${D}/usr/share/aclocal/.keep
+}
+
+pkg_preinst() {
+
+ # remove these to make sure symlinks install properly if old versions
+ # was binaries
+ for x in automake aclocal
+ do
+ if [ -e ${ROOT}/usr/bin/${x} ]
+ then
+ rm -f ${ROOT}/usr/bin/${x}
+ fi
+ done
+
+ # nuke this if it is a directory, as the new one is a symlink
+ if [ -d ${ROOT}/usr/share/automake ]
+ then
+ rm -rf ${ROOT}/usr/share/automake
+ fi
+
+ # Make sure we move all the macros not installed with automake
+ # to the non version specific aclocal dir.
+ if [ ! -d ${ROOT}/usr/share/aclocal ]
+ then
+ mkdir -p ${ROOT}/usr/share/aclocal
+ fi
+ if [ -d ${OLD14_S}/m4 ] && [ -d ${ROOT}/usr/share/aclocal-1.4 ]
+ then
+ for x in ${ROOT}/usr/share/aclocal-1.4/*.m4
+ do
+ if [ ! -f ${OLD14_S}/m4/${x##*/} ]
+ then
+ if [ ! -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ einfo "Moving ${x} to aclocal..."
+ mv -f ${x} ${ROOT}/usr/share/aclocal
+ else
+ einfo "Deleting duplicate ${x}..."
+ rm -f ${x}
+ fi
+ fi
+ done
+ fi
+ if [ -d ${OLD15_S}/m4 ] && [ -d ${ROOT}/usr/share/aclocal-${OLD15_PV} ]
+ then
+ for x in ${ROOT}/usr/share/aclocal-${OLD15_PV}/*.m4
+ do
+ if [ ! -f ${OLD15_S}/m4/${x##*/} ]
+ then
+ if [ ! -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ einfo "Moving ${x} to aclocal..."
+ mv -f ${x} ${ROOT}/usr/share/aclocal
+ else
+ einfo "Deleting duplicate ${x}..."
+ rm -f ${x}
+ fi
+ fi
+ done
+ fi
+ if [ -d ${OLD16_S}/m4 ] && [ -d ${ROOT}/usr/share/aclocal-${OLD16_PV_S} ]
+ then
+ for x in ${ROOT}/usr/share/aclocal-${OLD16_PV_S}/*.m4
+ do
+ if [ ! -f ${OLD16_S}/m4/${x##*/} ]
+ then
+ if [ ! -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ einfo "Moving ${x} to aclocal..."
+ mv -f ${x} ${ROOT}/usr/share/aclocal
+ else
+ einfo "Deleting duplicate ${x}..."
+ rm -f ${x}
+ fi
+ fi
+ done
+ fi
+ if [ -d ${S}/m4 ] && [ -d ${ROOT}/usr/share/aclocal-${NEW_PV} ]
+ then
+ for x in ${ROOT}/usr/share/aclocal-${NEW_PV}/*.m4
+ do
+ if [ ! -f ${S}/m4/${x##*/} ]
+ then
+ if [ ! -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ einfo "Moving ${x} to aclocal..."
+ mv -f ${x} ${ROOT}/usr/share/aclocal
+ else
+ einfo "Deleting duplicate ${x}..."
+ rm -f ${x}
+ fi
+ fi
+ done
+ fi
+}
+
+pkg_postinst() {
+
+ # nuke duplicate macros
+ for x in ${ROOT}/usr/share/aclocal-1.4/*.m4
+ do
+ if [ -f ${ROOT}/usr/share/aclocal/${x##*/} ]
+ then
+ rm -f ${ROOT}/usr/share/aclocal/${x##*/}
+ fi
+ done
+
+ echo
+ einfo "Please note that the 'WANT_AUTOMAKE_1_?=1' have changed to:"
+ echo
+ einfo " WANT_AUTOMAKE=<required version>"
+ echo
+ einfo "For instance: WANT_AUTOMAKE=1.6"
+ echo
+}
+
diff --git a/sys-devel/automake/files/am-wrapper.pl-1.7 b/sys-devel/automake/files/am-wrapper.pl-1.7
new file mode 100644
index 000000000000..0bd13a36616d
--- /dev/null
+++ b/sys-devel/automake/files/am-wrapper.pl-1.7
@@ -0,0 +1,119 @@
+#!/usr/bin/perl
+#
+#
+# Author: Guillaume Cottenceau (gc@mandrakesoft.com)
+# Modified by: Martin Schlemmer (azarah@gentoo.org)
+#
+# Copyright 2001 MandrakeSoft
+#
+# This software may be freely redistributed under the terms of the GNU
+# public license.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program; if not, write to the Free Software
+# Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
+#
+#
+# Executes the correct autoconf version.
+#
+# - defaults to automake-1.4
+# - runs automake-1.7 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.7'
+# -or-
+# - `Makefile.in' was generated by automake-1.7 or superior, which
+# specifically needs automake-1.7
+# -or_
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifying the use of 1.7
+# - runs automake-1.6 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.6'
+# -or-
+# - `Makefile.in' was generated by automake-1.6 or superior, which
+# specifically needs automake-1.6
+# -or-
+# - 'aclocal.m4' contain AM_AUTOMAKE_VERSION, specifyint the use of 1.6
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.53c'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.53c'
+# - runs automake-1.5 if it exists and...
+# - envvar WANT_AUTOMAKE is set to `1.5'
+# -or-
+# - configure.ac is present
+# -or-
+# - `configure.in' contains AC_PREREQ and the value's 3 first letters
+# are stringwise greater than '2.1'
+# -or-
+# - `configure' is already present and was generated by autoconf greater than
+# '2.1'
+# -or-
+# - `Makefile.in' was generated by automake-1.5 or superior, which
+# specifically needs automake-1.5
+#
+#use MDK::Common;
+
+sub cat_ { local *F; open F, $_[0] or return; my @l = <F>; wantarray ? @l : join '', @l }
+
+my $binary = "$0-1.4";
+my $binary_1_5 = "$0-1.5x";
+my $binary_1_6 = "$0-1.6x";
+my $binary_1_7 = "$0-1.7x";
+
+# Automake is really getting out of hand, so rather start supporting
+# WANT_AUTOMAKE = "1.7" the like. Unfortunately it override the old
+# variables, so if not set, just convert the old variables ....
+if ($ENV{WANT_AUTOMAKE} eq "") {
+ if ($ENV{WANT_AUTOMAKE_1_4}) {
+ $ENV{WANT_AUTOMAKE} = '1.4';
+ } elsif ($ENV{WANT_AUTOMAKE_1_6}) {
+ $ENV{WANT_AUTOMAKE} = '1.6';
+ } elsif ($ENV{WANT_AUTOMAKE_1_5}) {
+ $ENV{WANT_AUTOMAKE} = '1.5';
+ }
+}
+
+# question here is do we really want 1.5 or 1.6? Out of a KDE outlook, it
+# should rather be 1.5, and since most people would rather have migrated to
+# 1.5, and then stay with it for a bit (those 1.4 die hards ..), only have
+# the 'configure.ac' test for 1.5 ...
+if ($ENV{WANT_AUTOMAKE} ne '1.4') {
+ if (-x $binary_1_7 # user may not have _1_7 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.7')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.7'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.7'
+ || (cat_('aclocal.m4') =~ /^\s*\[?AM_AUTOMAKE_VERSION\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') ge '1.7')) {
+ $ENV{WANT_AUTOMAKE} = '1.7'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_7;
+ } elsif (-x $binary_1_6 # user may not have 1.6 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.6')
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.6'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.6'
+ || (cat_('aclocal.m4') =~ /^\s*\[?AM_AUTOMAKE_VERSION\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') ge '1.6'
+ # Autoconf 2.53d and later need automake-1.6c, so enable 1.6 for 2.53
+ # and up .....
+ || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{4})[^\)]*\]?\)/m ? $1 : '') gt '2.52'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.52'
+ || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{4})[^\)]*\]?\)/m ? $1 : '') gt '2.52')) {
+ $ENV{WANT_AUTOMAKE} = '1.6'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_6;
+ } elsif (-x $binary_1_5 # user may have only 1.4 ...
+ && (($ENV{WANT_AUTOMAKE} eq '1.5')
+ || -r 'configure.ac'
+ || (cat_('Makefile.in') =~ /^# Makefile\.in generated by automake (\S+)/ ? $1 : '') ge '1.5'
+ || (cat_('aclocal.m4') =~ /^# aclocal.m4 generated automatically by aclocal (\S+)/ ? $1 : '') ge '1.5'
+ || (cat_('configure.in') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1'
+ || (cat_('configure') =~ /^# Generated by Autoconf (\S+)/m ? $1 : '') gt '2.1'
+ || (cat_('aclocal.m4') =~ /^\s*AC_PREREQ\(\[?([^\)]{3})[^\)]*\]?\)/m ? $1 : '') gt '2.1')) {
+ $ENV{WANT_AUTOMAKE} = '1.5'; # to prevent further "cats" and to enhance consistency (possible cwd etc)
+ $binary = $binary_1_5;
+ } else {
+ $ENV{WANT_AUTOMAKE} = '1.4'; # for further consistency
+ }
+}
+
+$ENV{WANT_AMWRAPPER_DEBUG} and print STDERR "am-wrapper: will execute <$binary>\n";
+
+exec $binary, @ARGV;
+
+die "am-wrapper: ouch, couldn't call binary ($binary).\n";
diff --git a/sys-devel/automake/files/automake-1.7.2-infopage-namechange.patch b/sys-devel/automake/files/automake-1.7.2-infopage-namechange.patch
new file mode 100644
index 000000000000..58151d1eb4f4
--- /dev/null
+++ b/sys-devel/automake/files/automake-1.7.2-infopage-namechange.patch
@@ -0,0 +1,14 @@
+--- automake-1.7.2/Makefile.in.orig 2003-01-21 05:48:48.000000000 +0200
++++ automake-1.7.2/Makefile.in 2003-01-21 05:49:34.000000000 +0200
+@@ -197,8 +197,9 @@
+
+ .texi.info:
+ @rm -f $@ $@-[0-9] $@-[0-9][0-9]
+- $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) \
+- -o $@ `test -f '$<' || echo '$(srcdir)/'`$<
++ cd $(srcdir) \
++ && $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) \
++ `echo $< | sed 's,.*/,,'`
+
+ .texi.dvi:
+ TEXINPUTS="$(am__TEXINFO_TEX_DIR)$(PATH_SEPARATOR)$$TEXINPUTS" \
diff --git a/sys-devel/automake/files/digest-automake-1.7.2 b/sys-devel/automake/files/digest-automake-1.7.2
new file mode 100644
index 000000000000..7d3fe5e43715
--- /dev/null
+++ b/sys-devel/automake/files/digest-automake-1.7.2
@@ -0,0 +1,4 @@
+MD5 753647afe9db0ec52c69c6b9bb7dd106 automake-1.7.2.tar.gz 677283
+MD5 2bd506db63b6d10458cb644b6171ce93 automake-1.6.3.tar.gz 609618
+MD5 74a22ac0581378e807ecb334a55c5bab automake-1.5.tar.gz 526934
+MD5 e10679bba411f8602eed004012d915e3 automake-1.4-p5.tar.gz 376992