summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-12-09 23:51:56 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-12-09 23:51:56 +0000
commiteee3d50ab405ce51d4347872f3156f9f6f40e47c (patch)
tree84a0d38f42597c36f69d45a7c2088346b1c98dc2 /sys-devel
parentFix build with freetype-2.5.1, bug 493634 by Thomas Axelsson. (diff)
downloadgentoo-2-eee3d50ab405ce51d4347872f3156f9f6f40e47c.tar.gz
gentoo-2-eee3d50ab405ce51d4347872f3156f9f6f40e47c.tar.bz2
gentoo-2-eee3d50ab405ce51d4347872f3156f9f6f40e47c.zip
Disable seg ss check which breaks lilo, bug #491828
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/bin86/ChangeLog8
-rw-r--r--sys-devel/bin86/bin86-0.16.20-r1.ebuild (renamed from sys-devel/bin86/bin86-0.16.20.ebuild)3
-rw-r--r--sys-devel/bin86/files/bin86-0.16.20-remove-seg-ss-check.patch22
3 files changed, 31 insertions, 2 deletions
diff --git a/sys-devel/bin86/ChangeLog b/sys-devel/bin86/ChangeLog
index 8ac1da28d7cb..a910d4032c57 100644
--- a/sys-devel/bin86/ChangeLog
+++ b/sys-devel/bin86/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/bin86
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.27 2013/11/10 11:07:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/ChangeLog,v 1.28 2013/12/09 23:51:56 blueness Exp $
+
+*bin86-0.16.20-r1 (09 Dec 2013)
+
+ 09 Dec 2013; Anthony G. Basile <blueness@gentoo.org> +bin86-0.16.20-r1.ebuild,
+ +files/bin86-0.16.20-remove-seg-ss-check.patch, -bin86-0.16.20.ebuild:
+ Disable seg ss check which breaks lilo, bug #491828
*bin86-0.16.20 (10 Nov 2013)
diff --git a/sys-devel/bin86/bin86-0.16.20.ebuild b/sys-devel/bin86/bin86-0.16.20-r1.ebuild
index 7a0ff2a52ee0..7fe01ad70a33 100644
--- a/sys-devel/bin86/bin86-0.16.20.ebuild
+++ b/sys-devel/bin86/bin86-0.16.20-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.16.20.ebuild,v 1.1 2013/11/10 11:07:02 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/bin86/bin86-0.16.20-r1.ebuild,v 1.1 2013/12/09 23:51:56 blueness Exp $
EAPI="5"
@@ -24,6 +24,7 @@ src_prepare() {
-e "/^LDFLAGS/s:=.*:=${LDFLAGS}:" \
Makefile || die
epatch "${FILESDIR}"/${PN}-0.16.17-amd64-build.patch
+ epatch "${FILESDIR}"/${PN}-0.16.20-remove-seg-ss-check.patch
tc-export CC
}
diff --git a/sys-devel/bin86/files/bin86-0.16.20-remove-seg-ss-check.patch b/sys-devel/bin86/files/bin86-0.16.20-remove-seg-ss-check.patch
new file mode 100644
index 000000000000..146b42f9063e
--- /dev/null
+++ b/sys-devel/bin86/files/bin86-0.16.20-remove-seg-ss-check.patch
@@ -0,0 +1,22 @@
+This check leads to false positives for lilo. We disable it.
+
+From: Anthony G. Basile <blueness@gentoo.org>
+
+diff -Naur bin86-0.16.20.orig/as/assemble.c bin86-0.16.20/as/assemble.c
+--- bin86-0.16.20.orig/as/assemble.c 2013-10-29 11:45:37.000000000 -0400
++++ bin86-0.16.20/as/assemble.c 2013-12-09 18:43:45.018184693 -0500
+@@ -325,12 +325,14 @@
+ /* We handle "rep[ne]" refix as separate instruction; check if it's valid */
+ if (prevop == 0xF2 && (opcode&0xF6) != 0xA6) /* REPNE CMPS/SCAS */
+ error (REPNE_STRING);
++#if 0
+ if (prevop == 0xF3 && !((opcode&0xFC) == 0x6C || /* REP INS/OUTS */
+ (opcode&0xFC) == 0xA4 || /* REP MOVS/CMPS */
+ (opcode&0xFC) == 0xAC || /* REP SCAS/LODS */
+ (opcode&0xFE) == 0xAA)) /* REP STOS */
+ error (REP_STRING);
+ #endif
++#endif
+ routine = rout_table[symptr->value_reg_or_op.op.routine];
+ getsym();
+ (*routine)();