summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrandon Low <lostlogic@gentoo.org>2003-03-01 22:12:47 +0000
committerBrandon Low <lostlogic@gentoo.org>2003-03-01 22:12:47 +0000
commitf2c7c52a29944f674d74a92ee4f3eac4e1e75592 (patch)
tree805ab67254226b62944d009e50c6b20acd9fbc66 /sys-devel
parentemake and stuff (diff)
downloadgentoo-2-f2c7c52a29944f674d74a92ee4f3eac4e1e75592.tar.gz
gentoo-2-f2c7c52a29944f674d74a92ee4f3eac4e1e75592.tar.bz2
gentoo-2-f2c7c52a29944f674d74a92ee4f3eac4e1e75592.zip
emake
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/libperl/ChangeLog5
-rw-r--r--sys-devel/libperl/libperl-5.8.0.ebuild10
-rw-r--r--sys-devel/perl/ChangeLog6
-rw-r--r--sys-devel/perl/perl-5.8.0-r10.ebuild10
-rw-r--r--sys-devel/perl/perl-5.8.0-r9.ebuild10
5 files changed, 24 insertions, 17 deletions
diff --git a/sys-devel/libperl/ChangeLog b/sys-devel/libperl/ChangeLog
index 847d298c499f..42796190c7c9 100644
--- a/sys-devel/libperl/ChangeLog
+++ b/sys-devel/libperl/ChangeLog
@@ -1,6 +1,6 @@
# ChangeLog for sys-devel/libperl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.7 2003/02/27 01:50:23 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/ChangeLog,v 1.8 2003/03/01 22:10:36 lostlogic Exp $
11 Feb 2003; Guy Martin <gmsoft@gentoo.org> libperl-5.8.0.ebuild :
Added hppa to keywords.
@@ -10,6 +10,9 @@
*libperl-5.8.0 (06 Jan 2003)
+ 01 Mar 2003; Brandon Low <lostlogic@gentoo.org> libperl-5.8.0.ebuild:
+ Make->emake still not parallel where needed
+
26 Feb 2003; Zach Welch <zwelch@gentoo.org> libperl-5.8.0.ebuild:
add arm keyword
diff --git a/sys-devel/libperl/libperl-5.8.0.ebuild b/sys-devel/libperl/libperl-5.8.0.ebuild
index 94681a3bfab9..3ab47fd87f2f 100644
--- a/sys-devel/libperl/libperl-5.8.0.ebuild
+++ b/sys-devel/libperl/libperl-5.8.0.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.0.ebuild,v 1.8 2003/02/27 01:50:23 zwelch Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/libperl/libperl-5.8.0.ebuild,v 1.9 2003/03/01 22:10:36 lostlogic Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -223,8 +223,8 @@ src_compile() {
-Ud_csh \
${myconf} || die
- make -f Makefile depend || die "Couldn't make libperl.so depends"
- make -f Makefile ${LIBPERL} || die "Unable to make libperl.so"
+ emake -f Makefile depend || die "Couldn't make libperl.so depends"
+ emake -f Makefile ${LIBPERL} || die "Unable to make libperl.so"
mv ${LIBPERL} ${WORKDIR}
else
cat > config.over <<EOF
@@ -262,9 +262,9 @@ sleep 10
-Ud_csh \
${myconf} || die "Unable to configure"
- make || die "Unable to make"
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "Unable to make"
- make -i test CCDLFLAGS=
+ emake -i test CCDLFLAGS=
fi
}
diff --git a/sys-devel/perl/ChangeLog b/sys-devel/perl/ChangeLog
index 400bbbea0201..3a031332443c 100644
--- a/sys-devel/perl/ChangeLog
+++ b/sys-devel/perl/ChangeLog
@@ -1,9 +1,13 @@
# ChangeLog for sys-devel/perl
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.60 2003/03/01 00:36:05 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/ChangeLog,v 1.61 2003/03/01 22:08:16 lostlogic Exp $
*perl-5.8.0-r10 (28 Feb 2003)
+ 01 Mar 2003; Brandon Low <lostlogic@gentoo.org> perl-5.8.0-r10.ebuild,
+ perl-5.8.0-r9.ebuild:
+ Make use emake instead of make, but still use 1 process build where needed
+
28 Feb 2003; <rac@gentoo.org> perl-5.8.0-r10.ebuild:
Ensure that libpthread is linked against by perl, so that runtime
signal handling works correctly (bug #14380).
diff --git a/sys-devel/perl/perl-5.8.0-r10.ebuild b/sys-devel/perl/perl-5.8.0-r10.ebuild
index eaf07e94ac02..01db5968a89e 100644
--- a/sys-devel/perl/perl-5.8.0-r10.ebuild
+++ b/sys-devel/perl/perl-5.8.0-r10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r10.ebuild,v 1.1 2003/03/01 00:36:05 rac Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r10.ebuild,v 1.2 2003/03/01 22:08:16 lostlogic Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -235,8 +235,8 @@ src_compile() {
-Ud_csh \
${myconf} || die
- make -f Makefile depend || die "Couldn't make libperl.so depends"
- make -f Makefile ${LIBPERL} || die "Unable to make libperl.so"
+ emake -f Makefile depend || die "Couldn't make libperl.so depends"
+ emake -f Makefile ${LIBPERL} || die "Unable to make libperl.so"
mv ${LIBPERL} ${WORKDIR}
else
cat > config.over <<EOF
@@ -274,9 +274,9 @@ sleep 10
-Ud_csh \
${myconf} || die "Unable to configure"
- make || die "Unable to make"
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "Unable to make"
- make -i test CCDLFLAGS=
+ emake -i test CCDLFLAGS=
fi
}
diff --git a/sys-devel/perl/perl-5.8.0-r9.ebuild b/sys-devel/perl/perl-5.8.0-r9.ebuild
index 57e36655a593..76d90736ff4a 100644
--- a/sys-devel/perl/perl-5.8.0-r9.ebuild
+++ b/sys-devel/perl/perl-5.8.0-r9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2003 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r9.ebuild,v 1.10 2003/02/23 00:01:21 gmsoft Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/perl/perl-5.8.0-r9.ebuild,v 1.11 2003/03/01 22:08:16 lostlogic Exp $
# The basic theory based on comments from Daniel Robbins <drobbins@gentoo.org>.
#
@@ -225,8 +225,8 @@ src_compile() {
-Ud_csh \
${myconf} || die
- make -f Makefile depend || die "Couldn't make libperl.so depends"
- make -f Makefile ${LIBPERL} || die "Unable to make libperl.so"
+ emake -f Makefile depend || die "Couldn't make libperl.so depends"
+ emake -f Makefile ${LIBPERL} || die "Unable to make libperl.so"
mv ${LIBPERL} ${WORKDIR}
else
cat > config.over <<EOF
@@ -264,9 +264,9 @@ sleep 10
-Ud_csh \
${myconf} || die "Unable to configure"
- make || die "Unable to make"
+ MAKEOPTS="${MAKEOPTS} -j1" emake || die "Unable to make"
- make -i test CCDLFLAGS=
+ emake -i test CCDLFLAGS=
fi
}