summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-02-18 15:08:43 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-02-18 15:08:43 +0000
commitf415568f755c6ed409d674e8ec8090fd90150645 (patch)
tree9ee2ecb870f929854f65bc3701b6057eae46fdae /sys-devel
parentMake dep on webkit-gtk mandatory, bug 516256. Drop old. (diff)
downloadgentoo-2-f415568f755c6ed409d674e8ec8090fd90150645.tar.gz
gentoo-2-f415568f755c6ed409d674e8ec8090fd90150645.tar.bz2
gentoo-2-f415568f755c6ed409d674e8ec8090fd90150645.zip
go bindings do not integrate with autoconf build system, disable for now
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog6
-rw-r--r--sys-devel/llvm/llvm-3.6.0_rc3.ebuild11
-rw-r--r--sys-devel/llvm/metadata.xml1
3 files changed, 10 insertions, 8 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 34e67af52a5f..9b1e5d315bcf 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.227 2015/02/18 13:26:00 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.228 2015/02/18 15:08:43 voyageur Exp $
+
+ 18 Feb 2015; Bernard Cafarelli <voyageur@gentoo.org> llvm-3.6.0_rc3.ebuild,
+ metadata.xml:
+ go bindings do not integrate with autoconf build system, disable for now
*llvm-3.6.0_rc3 (18 Feb 2015)
diff --git a/sys-devel/llvm/llvm-3.6.0_rc3.ebuild b/sys-devel/llvm/llvm-3.6.0_rc3.ebuild
index e5b757ad0e6e..8b056dab008d 100644
--- a/sys-devel/llvm/llvm-3.6.0_rc3.ebuild
+++ b/sys-devel/llvm/llvm-3.6.0_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.0_rc3.ebuild,v 1.1 2015/02/18 13:26:00 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-3.6.0_rc3.ebuild,v 1.2 2015/02/18 15:08:43 voyageur Exp $
EAPI=5
@@ -20,7 +20,7 @@ SRC_URI="http://llvm.org/pre-releases/${PV/_rc*}/${PV/3.6.0_}/${P/_}.src.tar.xz
LICENSE="UoI-NCSA"
SLOT="0/3.5"
KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
-IUSE="clang debug doc go gold libedit +libffi multitarget ncurses ocaml python
+IUSE="clang debug doc gold libedit +libffi multitarget ncurses ocaml python
+static-analyzer test xml video_cards_radeon
kernel_Darwin kernel_FreeBSD"
@@ -34,7 +34,6 @@ COMMON_DEPEND="
)
xml? ( dev-libs/libxml2:2= )
)
- go? ( >=dev-lang/go-1.2 )
gold? ( >=sys-devel/binutils-2.22:*[cxx] )
libedit? ( dev-libs/libedit:0=[${MULTILIB_USEDEP}] )
libffi? ( >=virtual/libffi-3.0.13-r1:0=[${MULTILIB_USEDEP}] )
@@ -147,6 +146,7 @@ src_prepare() {
epatch "${FILESDIR}"/${PN}-3.2-nodoctargz.patch
epatch "${FILESDIR}"/${PN}-3.5-gcc-4.9.patch
epatch "${FILESDIR}"/${PN}-3.6-gentoo-install.patch
+ epatch "${FILESDIR}"/${P/_rc*}-go_bindings.patch
# Make ocaml warnings non-fatal, bug #537308
sed -e "/RUN/s/-warn-error A//" -i test/Bindings/OCaml/*ml || die
@@ -231,7 +231,6 @@ multilib_src_configure() {
if multilib_is_native_abi; then
use gold && conf_flags+=( --with-binutils-include="${EPREFIX}"/usr/include/ )
# extra commas don't hurt
- use go && bindings+=',go'
use ocaml && bindings+=',ocaml'
fi
@@ -393,9 +392,9 @@ multilib_src_install() {
dohtml -r "${S}"/docs/_build/html/
else
if ! use clang; then
- rm "${WORKDIR}"/${PN}-3.5.0-manpages/clang.1 || die
+ rm "${WORKDIR}"/${P/_rc*}-manpages/clang.1 || die
fi
- doman "${WORKDIR}"/${PN}-3.5.0-manpages/*.1
+ doman "${WORKDIR}"/${P/_rc*}-manpages/*.1
fi
# Symlink the gold plugin.
diff --git a/sys-devel/llvm/metadata.xml b/sys-devel/llvm/metadata.xml
index a27c489fdc69..1a630669f376 100644
--- a/sys-devel/llvm/metadata.xml
+++ b/sys-devel/llvm/metadata.xml
@@ -18,7 +18,6 @@
<flag name='clang'>Build the clang C/C++ compiler</flag>
<flag name='cmake'>Enable cmake support (experimental)</flag>
<flag name='doc'>Build and install the HTML documentation and regenerate the man pages</flag>
- <flag name='go'>Build the <pkg>dev-lang/go</pkg> bindings</flag>
<flag name='gold'>Build the gold linker plugin</flag>
<flag name='llvm-gcc'>Build LLVM with <pkg>sys-devel/llvm-gcc</pkg></flag>
<flag name='multitarget'>Build all host targets (default: host only)</flag>