summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-10-13 07:44:58 +0000
committerMichał Górny <mgorny@gentoo.org>2013-10-13 07:44:58 +0000
commitfa649879c2a7e80f13e990c73782b7bef9a280f4 (patch)
tree6d9926b7305285dfcd889e08f9166a6a93c01873 /sys-devel
parentStable for ppc64, wrt bug #480908 (diff)
downloadgentoo-2-fa649879c2a7e80f13e990c73782b7bef9a280f4.tar.gz
gentoo-2-fa649879c2a7e80f13e990c73782b7bef9a280f4.tar.bz2
gentoo-2-fa649879c2a7e80f13e990c73782b7bef9a280f4.zip
Disable embedding timestamps to increase ccache hit rate.
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/llvm/ChangeLog5
-rw-r--r--sys-devel/llvm/llvm-9999.ebuild6
2 files changed, 8 insertions, 3 deletions
diff --git a/sys-devel/llvm/ChangeLog b/sys-devel/llvm/ChangeLog
index 83a7fe6970b8..f5c8a7cbe27c 100644
--- a/sys-devel/llvm/ChangeLog
+++ b/sys-devel/llvm/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-devel/llvm
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.139 2013/10/13 07:34:11 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/ChangeLog,v 1.140 2013/10/13 07:44:58 mgorny Exp $
+
+ 13 Oct 2013; Michał Górny <mgorny@gentoo.org> llvm-9999.ebuild:
+ Disable embedding timestamps to increase ccache hit rate.
13 Oct 2013; Michał Górny <mgorny@gentoo.org>
+files/clang-3.3-gcc-header-path.patch, llvm-3.3-r1.ebuild:
diff --git a/sys-devel/llvm/llvm-9999.ebuild b/sys-devel/llvm/llvm-9999.ebuild
index 765858170d66..27dee3f1f798 100644
--- a/sys-devel/llvm/llvm-9999.ebuild
+++ b/sys-devel/llvm/llvm-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.55 2013/10/04 15:43:44 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/llvm/llvm-9999.ebuild,v 1.56 2013/10/13 07:44:58 mgorny Exp $
EAPI=5
@@ -178,7 +178,9 @@ src_prepare() {
}
multilib_src_configure() {
- local CONF_FLAGS="--enable-keep-symbols
+ # disable timestamps since they confuse ccache
+ local CONF_FLAGS="--disable-timestamps
+ --enable-keep-symbols
--enable-shared
--with-optimize-option=
$(use_enable !debug optimized)