summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRoy Marples <uberlord@gentoo.org>2007-10-15 09:03:09 +0000
committerRoy Marples <uberlord@gentoo.org>2007-10-15 09:03:09 +0000
commitffb334d4c7dcfe74f1262166d4672e10966860eb (patch)
tree36cda70ec2363c2b5df050118cea3e324ede097a /sys-devel
parent(#152141) Fix an error message 'Invalid colour specification for setting colo... (diff)
downloadgentoo-2-ffb334d4c7dcfe74f1262166d4672e10966860eb.tar.gz
gentoo-2-ffb334d4c7dcfe74f1262166d4672e10966860eb.tar.bz2
gentoo-2-ffb334d4c7dcfe74f1262166d4672e10966860eb.zip
Pull upstream fix for BSD systems.
(Portage version: 2.1.3.13)
Diffstat (limited to 'sys-devel')
-rw-r--r--sys-devel/m4/ChangeLog8
-rw-r--r--sys-devel/m4/files/digest-m4-1.4.10-r13
-rw-r--r--sys-devel/m4/files/m4-1.4.10-seek.patch13
-rw-r--r--sys-devel/m4/m4-1.4.10-r1.ebuild49
4 files changed, 72 insertions, 1 deletions
diff --git a/sys-devel/m4/ChangeLog b/sys-devel/m4/ChangeLog
index 1ea8daff89e4..3481c4b3a053 100644
--- a/sys-devel/m4/ChangeLog
+++ b/sys-devel/m4/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for sys-devel/m4
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.99 2007/10/12 20:19:38 pylon Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/ChangeLog,v 1.100 2007/10/15 09:03:09 uberlord Exp $
+
+*m4-1.4.10-r1 (15 Oct 2007)
+
+ 15 Oct 2007; Roy Marples <uberlord@gentoo.org>
+ +files/m4-1.4.10-seek.patch, +m4-1.4.10-r1.ebuild:
+ Pull upstream fix for BSD systems.
12 Oct 2007; Lars Weiler <pylon@gentoo.org> m4-1.4.10.ebuild:
stable ppc, bug #195257
diff --git a/sys-devel/m4/files/digest-m4-1.4.10-r1 b/sys-devel/m4/files/digest-m4-1.4.10-r1
new file mode 100644
index 000000000000..6fffe4cf2239
--- /dev/null
+++ b/sys-devel/m4/files/digest-m4-1.4.10-r1
@@ -0,0 +1,3 @@
+MD5 0a35bab2f5d605e08083d7e3cbd4b8b0 m4-1.4.10.tar.bz2 739154
+RMD160 db9e91a01104a7543e69527da6d4f059a56ffefb m4-1.4.10.tar.bz2 739154
+SHA256 b2b66e645cd566a95d9714848a5d084427f3130ace5c5a0c6cb5544f11b7cbd7 m4-1.4.10.tar.bz2 739154
diff --git a/sys-devel/m4/files/m4-1.4.10-seek.patch b/sys-devel/m4/files/m4-1.4.10-seek.patch
new file mode 100644
index 000000000000..572d266373f1
--- /dev/null
+++ b/sys-devel/m4/files/m4-1.4.10-seek.patch
@@ -0,0 +1,13 @@
+diff -ur a/src/output.c b/src/output.c
+--- a/src/output.c 2007-07-05 04:56:06 +0100
++++ b/src/output.c 2007-10-15 09:56:23 +0100
+@@ -252,6 +252,9 @@
+ else if (set_cloexec_flag (fileno (file), true) != 0)
+ M4ERROR ((warning_status, errno,
+ "Warning: cannot protect diversion across forks"));
++ else if (fseeko (file, 0, SEEK_SET) != 0)
++ M4ERROR ((EXIT_FAILURE, errno,
++ "cannot seek to beginning of diversion"));
+ return file;
+ }
+
diff --git a/sys-devel/m4/m4-1.4.10-r1.ebuild b/sys-devel/m4/m4-1.4.10-r1.ebuild
new file mode 100644
index 000000000000..96071a324b40
--- /dev/null
+++ b/sys-devel/m4/m4-1.4.10-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-devel/m4/m4-1.4.10-r1.ebuild,v 1.1 2007/10/15 09:03:09 uberlord Exp $
+
+inherit eutils
+
+DESCRIPTION="GNU macro processor"
+HOMEPAGE="http://www.gnu.org/software/m4/m4.html"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.bz2
+ ftp://ftp.seindal.dk/gnu/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="examples nls"
+
+# remember: cannot dep on autoconf since it needs us
+DEPEND="nls? ( sys-devel/gettext )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix for BSD systems pulled from upstream.
+ epatch "${FILESDIR}/${P}"-seek.patch
+}
+
+src_compile() {
+ local myconf=""
+ [ "${USERLAND}" != "GNU" ] && myconf="--program-prefix=g"
+ econf \
+ $(use_enable nls) \
+ --enable-changeword \
+ ${myconf} \
+ || die
+ emake || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc BACKLOG ChangeLog NEWS README* THANKS TODO
+ if use examples ; then
+ docinto examples
+ dodoc examples/*
+ rm -f "${D}"/usr/share/doc/${PF}/examples/Makefile*
+ fi
+ rm -f "${D}"/usr/lib/charset.alias #172864
+}