summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-03-16 19:27:11 +0000
committerMike Frysinger <vapier@gentoo.org>2015-03-16 19:27:11 +0000
commitc213d6001b71187668f0d37b4339cb4d814852d5 (patch)
treebdcb2ab01cc2949ff1448093a77021d0351f9d76 /sys-firmware
parentCleanup. (diff)
downloadgentoo-2-c213d6001b71187668f0d37b4339cb4d814852d5.tar.gz
gentoo-2-c213d6001b71187668f0d37b4339cb4d814852d5.tar.bz2
gentoo-2-c213d6001b71187668f0d37b4339cb4d814852d5.zip
Switch to new tc-getOBJDUMP and fix quoting in ipxemake helper.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key D2E96200)
Diffstat (limited to 'sys-firmware')
-rw-r--r--sys-firmware/ipxe/ChangeLog5
-rw-r--r--sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/sys-firmware/ipxe/ChangeLog b/sys-firmware/ipxe/ChangeLog
index 3771258f60f9..186f13ca03fa 100644
--- a/sys-firmware/ipxe/ChangeLog
+++ b/sys-firmware/ipxe/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-firmware/ipxe
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.18 2015/03/16 18:49:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ChangeLog,v 1.19 2015/03/16 19:27:11 vapier Exp $
+
+ 16 Mar 2015; Mike Frysinger <vapier@gentoo.org> ipxe-1.0.0_p20130925.ebuild:
+ Switch to new tc-getOBJDUMP and fix quoting in ipxemake helper.
16 Mar 2015; Mike Frysinger <vapier@gentoo.org>
+files/ipxe-1.0.0_p20130925-git-version.patch, ipxe-1.0.0_p20130925.ebuild:
diff --git a/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild b/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
index 8522f068d56b..1d1762d04b81 100644
--- a/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
+++ b/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild,v 1.4 2015/03/16 18:49:47 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-firmware/ipxe/ipxe-1.0.0_p20130925.ebuild,v 1.5 2015/03/16 19:27:11 vapier Exp $
EAPI=5
@@ -56,14 +56,14 @@ src_compile() {
ipxemake() {
# Q='' makes the build verbose since that's what everyone loves now
emake Q='' \
- CC=$(tc-getCC) \
+ CC="$(tc-getCC)" \
LD="$(tc-getLD).bfd" \
- AR=$(tc-getAR) \
- OBJCOPY=$(tc-getOBJCOPY) \
- RANLIB=$(tc-getRANLIB) \
- OBJDUMP=$(tc-getPROG OBJDUMP objdump) \
- HOST_CC=$(tc-getBUILD_CC) \
- ${*}
+ AR="$(tc-getAR)" \
+ OBJCOPY="$(tc-getOBJCOPY)" \
+ RANLIB="$(tc-getRANLIB)" \
+ OBJDUMP="$(tc-getOBJDUMP)" \
+ HOST_CC="$(tc-getBUILD_CC)" \
+ "$@"
}
export NO_WERROR=1