summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2013-11-09 09:15:50 +0000
committerAlexis Ballier <aballier@gentoo.org>2013-11-09 09:15:50 +0000
commit63eb8f858a98e73a80731d6c4f64abf13ac7b9f0 (patch)
treeadd3bf7e95cfb727534e899700bdf457b2afa782 /sys-freebsd/boot0
parentsys-kernel/aufs-sources: Bump to latest aufs3, genpatches and linux release (diff)
downloadgentoo-2-63eb8f858a98e73a80731d6c4f64abf13ac7b9f0.tar.gz
gentoo-2-63eb8f858a98e73a80731d6c4f64abf13ac7b9f0.tar.bz2
gentoo-2-63eb8f858a98e73a80731d6c4f64abf13ac7b9f0.zip
bump to 9.2
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 160F534A)
Diffstat (limited to 'sys-freebsd/boot0')
-rw-r--r--sys-freebsd/boot0/ChangeLog7
-rw-r--r--sys-freebsd/boot0/boot0-9.2.ebuild72
2 files changed, 78 insertions, 1 deletions
diff --git a/sys-freebsd/boot0/ChangeLog b/sys-freebsd/boot0/ChangeLog
index 131cc0acbd47..4f9e3d38acda 100644
--- a/sys-freebsd/boot0/ChangeLog
+++ b/sys-freebsd/boot0/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for sys-freebsd/boot0
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.48 2013/08/27 23:08:11 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/ChangeLog,v 1.49 2013/11/09 09:15:50 aballier Exp $
+
+*boot0-9.2 (09 Nov 2013)
+
+ 09 Nov 2013; Alexis Ballier <aballier@gentoo.org> +boot0-9.2.ebuild:
+ bump to 9.2
27 Aug 2013; Alexis Ballier <aballier@gentoo.org> boot0-9.1.ebuild:
backport fix from 9.2 for bug #409815 by Yuta SATOH
diff --git a/sys-freebsd/boot0/boot0-9.2.ebuild b/sys-freebsd/boot0/boot0-9.2.ebuild
new file mode 100644
index 000000000000..e075c5ccc6ea
--- /dev/null
+++ b/sys-freebsd/boot0/boot0-9.2.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/boot0/boot0-9.2.ebuild,v 1.1 2013/11/09 09:15:50 aballier Exp $
+
+EAPI=2
+
+inherit bsdmk freebsd flag-o-matic toolchain-funcs
+
+DESCRIPTION="FreeBSD's bootloader"
+SLOT="0"
+
+IUSE="bzip2 ieee1394 tftp zfs"
+
+if [[ ${PV} != *9999* ]]; then
+ KEYWORDS="~amd64-fbsd ~sparc-fbsd ~x86-fbsd"
+ SRC_URI="mirror://gentoo/${SYS}.tar.bz2
+ mirror://gentoo/${LIB}.tar.bz2
+ mirror://gentoo/${CONTRIB}.tar.bz2"
+fi
+
+RDEPEND=""
+DEPEND="=sys-freebsd/freebsd-mk-defs-${RV}*
+ =sys-freebsd/freebsd-lib-${RV}*"
+
+S="${WORKDIR}/sys/boot"
+
+PATCHES=( "${FILESDIR}/${PN}-9.2-gcc46.patch" )
+
+boot0_use_enable() {
+ use ${1} && mymakeopts="${mymakeopts} LOADER_${2}_SUPPORT=\"yes\""
+}
+
+pkg_setup() {
+ boot0_use_enable ieee1394 FIREWIRE
+ boot0_use_enable zfs ZFS
+ boot0_use_enable tftp TFTP
+ boot0_use_enable bzip2 BZIP2
+}
+
+src_prepare() {
+ sed -e '/-fomit-frame-pointer/d' -e '/-mno-align-long-strings/d' \
+ -i "${S}"/i386/boot2/Makefile \
+ -i "${S}"/i386/gptboot/Makefile \
+ -i "${S}"/i386/gptzfsboot/Makefile \
+ -i "${S}"/i386/zfsboot/Makefile || die
+}
+
+src_compile() {
+ strip-flags
+ append-flags "-fno-strict-aliasing"
+
+ cd "${WORKDIR}/lib/libstand" || die
+ freebsd_src_compile
+
+ cd "${S}"
+ CFLAGS="${CFLAGS} -I${WORKDIR}/lib/libstand"
+ LDFLAGS="${LDFLAGS} -L${WORKDIR}/lib/libstand"
+ export LIBSTAND="${WORKDIR}/lib/libstand/libstand.a"
+ NOFLAGSTRIP="yes" freebsd_src_compile
+}
+
+src_install() {
+ dodir /boot/defaults
+ mkinstall FILESDIR=/boot || die "mkinstall failed"
+
+ cd "${WORKDIR}/sys/$(tc-arch-kernel)/conf" || die
+ insinto /boot
+ newins GENERIC.hints device.hints
+
+ echo 'CONFIG_PROTECT="/boot/device.hints"' > "${T}"/50boot0
+ doenvd "${T}"/50boot0
+}