summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2012-05-24 12:15:46 +0000
committerAlexis Ballier <aballier@gentoo.org>2012-05-24 12:15:46 +0000
commit6bcc2b4c2dcc4d77bc0d82cec7492c80e6a904f5 (patch)
tree821acea3f452c5e5787d522c2749f8d81dcf1b83 /sys-freebsd
parentVersion bump, acked by voyageur. Update SRC_URI, add toolchain-funcs.eclass f... (diff)
downloadgentoo-2-6bcc2b4c2dcc4d77bc0d82cec7492c80e6a904f5.tar.gz
gentoo-2-6bcc2b4c2dcc4d77bc0d82cec7492c80e6a904f5.tar.bz2
gentoo-2-6bcc2b4c2dcc4d77bc0d82cec7492c80e6a904f5.zip
build and install more libraries with multilib
(Portage version: 2.2.0_alpha107/cvs/Linux x86_64)
Diffstat (limited to 'sys-freebsd')
-rw-r--r--sys-freebsd/freebsd-lib/ChangeLog5
-rw-r--r--sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild15
2 files changed, 13 insertions, 7 deletions
diff --git a/sys-freebsd/freebsd-lib/ChangeLog b/sys-freebsd/freebsd-lib/ChangeLog
index cbf7b2fc97bb..76cd5de132f2 100644
--- a/sys-freebsd/freebsd-lib/ChangeLog
+++ b/sys-freebsd/freebsd-lib/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for sys-freebsd/freebsd-lib
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.139 2012/05/24 11:02:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/ChangeLog,v 1.140 2012/05/24 12:15:46 aballier Exp $
+
+ 24 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
+ build and install more libraries with multilib
24 May 2012; Alexis Ballier <aballier@gentoo.org> freebsd-lib-9.0-r2.ebuild:
Fix a typo and set MAKEOBJDIRPREFIX when installing too.
diff --git a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
index 42d8509ad66f..6dc31e551ac3 100644
--- a/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
+++ b/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.25 2012/05/24 11:02:31 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-freebsd/freebsd-lib/freebsd-lib-9.0-r2.ebuild,v 1.26 2012/05/24 12:15:46 aballier Exp $
EAPI=2
@@ -257,14 +257,17 @@ get_subdirs() {
ret="$(get_csudir $(tc-arch-kernel ${CTARGET})) ${ret}"
fi
elif use build ; then
- # For the non-native ABIs we only build the csu parts.
+ # For the non-native ABIs we only build the csu parts and very core
+ # libraries for now.
+ ret="lib/libcompiler_rt gnu/lib/libssp/libssp_nonshared"
if [ "${EBUILD_PHASE}" = "install" ]; then
- ret="$(get_csudir $(tc-arch-kernel ${CHOST}))"
+ ret="$(get_csudir $(tc-arch-kernel ${CHOST})) ${ret}"
fi
else
- # Only build the csu parts for now.
+ # Only build the csu parts and core libraries for now.
+ ret="lib/libcompiler_rt gnu/lib/libssp/libssp_nonshared"
if [ "${EBUILD_PHASE}" = "install" ]; then
- ret="$(get_csudir $(tc-arch-kernel ${CHOST}))"
+ ret="$(get_csudir $(tc-arch-kernel ${CHOST})) ${ret}"
fi
# Finally, with a non-native ABI without USE=build, we build everything
# too.
@@ -348,7 +351,7 @@ src_compile() {
einfo "Pre-installing includes in include_proper_${ABI}"
mkdir "${WORKDIR}/include_proper_${ABI}" || die
CTARGET="${CHOST}" install_includes "/include_proper_${ABI}"
- CC="${CC} -isystem ${WORKDIR}/include_proper_${ABI}"
+ CC="${CC} -I${WORKDIR}/include_proper_${ABI}"
else
use build && append-flags "-isystem '${WORKDIR}/include_proper'" ;
fi