summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2013-07-15 19:54:09 +0000
committerMichał Górny <mgorny@gentoo.org>2013-07-15 19:54:09 +0000
commiteea06884e953d981a95aa92fb0354498731ddb38 (patch)
tree4f78887958502268874fe1c7c8bcf29a9e99a84d /sys-fs/bedup/bedup-9999.ebuild
parentIntroduce contextlib2, a library providing backports and extensions to the co... (diff)
downloadgentoo-2-eea06884e953d981a95aa92fb0354498731ddb38.tar.gz
gentoo-2-eea06884e953d981a95aa92fb0354498731ddb38.tar.bz2
gentoo-2-eea06884e953d981a95aa92fb0354498731ddb38.zip
Introduce bedup, a btrfs deduplication tool.
(Portage version: 2.2.0_alpha188/cvs/Linux x86_64, signed Manifest commit with key 9627F456F9DA7643!)
Diffstat (limited to 'sys-fs/bedup/bedup-9999.ebuild')
-rw-r--r--sys-fs/bedup/bedup-9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/bedup/bedup-9999.ebuild b/sys-fs/bedup/bedup-9999.ebuild
new file mode 100644
index 000000000000..7a795f9638f6
--- /dev/null
+++ b/sys-fs/bedup/bedup-9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/bedup/bedup-9999.ebuild,v 1.1 2013/07/15 19:54:09 mgorny Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_2} )
+
+#if LIVE
+# Note: we ignore submodules since we use btrfs-progs-9999.
+EGIT_REPO_URI="git://github.com/g2p/bedup.git
+ https://github.com/g2p/bedup.git"
+inherit git-2
+#endif
+
+inherit distutils-r1
+
+DESCRIPTION="Btrfs file de-duplication tool"
+HOMEPAGE="https://github.com/g2p/bedup"
+SRC_URI="https://github.com/g2p/${PN}/archive/v${PV}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+# pycparser is indirect dep but <2.09.1 causes issues.
+# we need btrfs-progs with includes installed.
+DEPEND=">=dev-python/cffi-0.5[${PYTHON_USEDEP}]
+ >=dev-python/pycparser-2.09.1-r1[${PYTHON_USEDEP}]
+ >=sys-fs/btrfs-progs-9999"
+RDEPEND="${DEPEND}
+ dev-python/alembic[${PYTHON_USEDEP}]
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pyxdg[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[sqlite,${PYTHON_USEDEP}]
+ virtual/python-argparse[${PYTHON_USEDEP}]"
+
+#if LIVE
+SRC_URI=
+KEYWORDS=
+#endif