summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStuart Herbert <stuart@gentoo.org>2004-12-16 22:21:34 +0000
committerStuart Herbert <stuart@gentoo.org>2004-12-16 22:21:34 +0000
commit706f32a0df76e01eb9c7897221eec2437dfb301f (patch)
treeb9a6f292bf4b2a6e55a217fc8cc5535b79cba808 /sys-fs/copyfs/copyfs-1.0.ebuild
parentBump to new release. Add my self to the maintainers list. (Manifest recommit) (diff)
downloadgentoo-2-706f32a0df76e01eb9c7897221eec2437dfb301f.tar.gz
gentoo-2-706f32a0df76e01eb9c7897221eec2437dfb301f.tar.bz2
gentoo-2-706f32a0df76e01eb9c7897221eec2437dfb301f.zip
Initial import
Diffstat (limited to 'sys-fs/copyfs/copyfs-1.0.ebuild')
-rw-r--r--sys-fs/copyfs/copyfs-1.0.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/sys-fs/copyfs/copyfs-1.0.ebuild b/sys-fs/copyfs/copyfs-1.0.ebuild
new file mode 100644
index 000000000000..1593e8784bfa
--- /dev/null
+++ b/sys-fs/copyfs/copyfs-1.0.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/copyfs/copyfs-1.0.ebuild,v 1.1 2004/12/16 22:21:34 stuart Exp $
+
+inherit eutils
+DESCRIPTION="fuse-based filesystem for maintaining configuration files"
+HOMEPAGE="http://invaders.mars-attacks.org/~boklm/copyfs/"
+SRC_URI="${HOMEPAGE}/${P}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="-x86"
+IUSE=""
+#RESTRICT="nostrip"
+DEPEND=">=sys-fs/fuse-2.0
+ sys-apps/attr"
+#RDEPEND=""
+
+S=${WORKDIR}/${P}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S} || die
+
+ # this patch fixes sandbox violations
+ epatch ${FILESDIR}/${P}-gentoo.patch
+
+ # this patch adds support for cleaning up the versions directory
+ # the patch is experimental at best, but it's better than your
+ # versions directory filling up with unused files
+ #
+ # patch by stuart@gentoo.org
+ epatch ${FILESDIR}/${P}-unlink.patch
+}
+
+src_compile() {
+ econf || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}