summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlon Bar-Lev <alonbl@gentoo.org>2006-12-12 12:01:03 +0000
committerAlon Bar-Lev <alonbl@gentoo.org>2006-12-12 12:01:03 +0000
commit35299ca001e81019a2b43f7b99d7222ef5c15b8a (patch)
tree17c0088a73502640cc4ace25ba28d1d3988fbb2b /sys-fs/dazuko
parentupstream memory patch thanks to Zas (diff)
downloadgentoo-2-35299ca001e81019a2b43f7b99d7222ef5c15b8a.tar.gz
gentoo-2-35299ca001e81019a2b43f7b99d7222ef5c15b8a.tar.bz2
gentoo-2-35299ca001e81019a2b43f7b99d7222ef5c15b8a.zip
suspend2+2.6.19 fixups
(Portage version: 2.1.1-r2)
Diffstat (limited to 'sys-fs/dazuko')
-rw-r--r--sys-fs/dazuko/ChangeLog9
-rw-r--r--sys-fs/dazuko/dazuko-2.3.2-r2.ebuild60
-rw-r--r--sys-fs/dazuko/files/dazuko-2.3.1-suspend2.patch41
-rw-r--r--sys-fs/dazuko/files/digest-dazuko-2.3.2-r26
4 files changed, 98 insertions, 18 deletions
diff --git a/sys-fs/dazuko/ChangeLog b/sys-fs/dazuko/ChangeLog
index da17c65d9924..c0d10d71a5e2 100644
--- a/sys-fs/dazuko/ChangeLog
+++ b/sys-fs/dazuko/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for sys-fs/dazuko
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.11 2006/12/09 18:41:37 alonbl Exp $
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/ChangeLog,v 1.12 2006/12/12 12:01:03 alonbl Exp $
+
+*dazuko-2.3.2-r2 (12 Dec 2006)
+
+ 12 Dec 2006; Alon Bar-Lev <alonbl@gentoo.org>
+ files/dazuko-2.3.1-suspend2.patch, -dazuko-2.3.2.ebuild,
+ -dazuko-2.3.2-r1.ebuild, +dazuko-2.3.2-r2.ebuild:
+ suspend2+2.6.19 fixups
*dazuko-2.3.2-r1 (09 Dec 2006)
diff --git a/sys-fs/dazuko/dazuko-2.3.2-r2.ebuild b/sys-fs/dazuko/dazuko-2.3.2-r2.ebuild
new file mode 100644
index 000000000000..256634c691b7
--- /dev/null
+++ b/sys-fs/dazuko/dazuko-2.3.2-r2.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/dazuko/dazuko-2.3.2-r2.ebuild,v 1.1 2006/12/12 12:01:03 alonbl Exp $
+
+inherit linux-mod
+
+DESCRIPTION="Linux kernel module and interface providing file access control"
+MY_P="${P/_/-}" # for -preN versions
+SRC_URI="http://www.dazuko.org/files/${MY_P}.tar.gz
+ mirror://gentoo/${P}-linux-2.6.19.patch.bz2"
+HOMEPAGE="http://www.dazuko.org"
+LICENSE="GPL-2 BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE=""
+DEPEND=">=virtual/linux-sources-2.2"
+S="${WORKDIR}/${MY_P}"
+
+# kernel settings
+CONFIG_CHECK="SECURITY_CAPABILITIES"
+MODULE_NAMES="dazuko(misc:)"
+BUILD_TARGETS="dummy_rule"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-2.3.1-suspend2.patch"
+
+ if kernel_is 2 6 19; then
+ epatch "${WORKDIR}/${P}-linux-2.6.19.patch"
+ fi
+}
+
+src_compile() {
+ ./configure \
+ --without-dep \
+ --kernelsrcdir="${KERNEL_DIR}" \
+ --kernelobjdir="${KBUILD_OUTPUT}" \
+ || die "configure failed"
+ convert_to_m Makefile
+ linux-mod_src_compile
+
+ cd library
+ emake || die
+ cd ..
+}
+
+src_install() {
+ linux-mod_src_install
+
+ dolib.a library/libdazuko.a
+ insinto /usr/include
+ doins dazukoio.h
+
+ dodoc COPYING
+ dodoc README
+ dodoc README.linux26
+ dodoc README.trusted
+}
+
diff --git a/sys-fs/dazuko/files/dazuko-2.3.1-suspend2.patch b/sys-fs/dazuko/files/dazuko-2.3.1-suspend2.patch
index b54e2c043d6a..fa4df44c4830 100644
--- a/sys-fs/dazuko/files/dazuko-2.3.1-suspend2.patch
+++ b/sys-fs/dazuko/files/dazuko-2.3.1-suspend2.patch
@@ -1,6 +1,6 @@
-diff -urNp dazuko-2.3.1.org/configure dazuko-2.3.1/configure
---- dazuko-2.3.1.org/configure 2006-10-04 00:48:18.000000000 +0200
-+++ dazuko-2.3.1/configure 2006-11-08 15:11:38.000000000 +0200
+diff -urNp dazuko-2.3.2.org/configure dazuko-2.3.2/configure
+--- dazuko-2.3.2.org/configure 2006-10-04 00:48:18.000000000 +0200
++++ dazuko-2.3.2/configure 2006-12-12 13:49:04.000000000 +0200
@@ -590,21 +590,20 @@ do_linux26()
then
LINUX26_USE_SUSPEND=1
@@ -16,8 +16,7 @@ diff -urNp dazuko-2.3.1.org/configure dazuko-2.3.1/configure
+ grep "try_to_freeze.*(.*void.*)" "$SRC_PATH" > /dev/null 2>&1
if [ $? -eq 0 ]
then
-- LINUX26_USE_SUSPEND=2
-+ LINUX26_USE_SUSPEND=1
+ LINUX26_USE_SUSPEND=2
fi
fi
@@ -31,22 +30,25 @@ diff -urNp dazuko-2.3.1.org/configure dazuko-2.3.1/configure
if [ $LOCAL_DPATH -eq 2 ]
then
LOCAL_DPATH=1
-@@ -705,11 +704,6 @@ do_linux26()
+@@ -700,12 +699,12 @@ do_linux26()
+ echo "EXTRA_CFLAGS += -DNO_CAPABILITIES" >> Makefile
+ fi
+
+- if [ ${LINUX26_USE_SUSPEND} -eq 1 ]
++ if [ -n "${LINUX26_USE_SUSPEND}" ]
+ then
echo "EXTRA_CFLAGS += -DUSE_TRYTOFREEZEVOID" >> Makefile
fi
- if [ ${LINUX26_USE_SUSPEND} -eq 2 ]
-- then
-- echo "EXTRA_CFLAGS += -DUSE_SUSPEND2" >> Makefile
-- fi
--
- if [ ${LINUX26_USE_CLASS} -eq 1 ]
++ if [ "${LINUX26_USE_SUSPEND}" -eq 2 ]
then
- echo "EXTRA_CFLAGS += -DUSE_CLASS" >> Makefile
-diff -urNp dazuko-2.3.1.org/dazuko_linux26.c dazuko-2.3.1/dazuko_linux26.c
---- dazuko-2.3.1.org/dazuko_linux26.c 2006-07-29 12:13:03.000000000 +0300
-+++ dazuko-2.3.1/dazuko_linux26.c 2006-11-08 15:15:25.000000000 +0200
-@@ -37,7 +37,7 @@
+ echo "EXTRA_CFLAGS += -DUSE_SUSPEND2" >> Makefile
+ fi
+diff -urNp dazuko-2.3.2.org/dazuko_linux26.c dazuko-2.3.2/dazuko_linux26.c
+--- dazuko-2.3.2.org/dazuko_linux26.c 2006-11-15 10:11:20.000000000 +0200
++++ dazuko-2.3.2/dazuko_linux26.c 2006-12-12 13:51:04.000000000 +0200
+@@ -37,9 +37,12 @@
#include <linux/devfs_fs_kernel.h>
#endif
#include <linux/device.h>
@@ -54,8 +56,13 @@ diff -urNp dazuko-2.3.1.org/dazuko_linux26.c dazuko-2.3.1/dazuko_linux26.c
+#if !defined(USE_TRYTOFREEZEVOID)
#include <linux/suspend.h>
#endif
++#if USE_SUSPEND2
++#include <linux/freezer.h>
++#endif
#include <asm/uaccess.h>
-@@ -178,10 +178,7 @@ inline int xp_wait_until_condition(struc
+
+
+@@ -178,10 +181,7 @@ inline int xp_wait_until_condition(struc
{
ret = wait_event_interruptible(queue->queue, cfunction(cparam) != 0);
diff --git a/sys-fs/dazuko/files/digest-dazuko-2.3.2-r2 b/sys-fs/dazuko/files/digest-dazuko-2.3.2-r2
new file mode 100644
index 000000000000..fee1e7bfde35
--- /dev/null
+++ b/sys-fs/dazuko/files/digest-dazuko-2.3.2-r2
@@ -0,0 +1,6 @@
+MD5 e82799830e44dc2b5dfc9d355bcc5b2e dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
+RMD160 09a635922d364f73e6f32787397e3657d2ec8087 dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
+SHA256 239c514ddb4345d758706c50c286b125d3e35e476931bec0909bdf15c80c8d06 dazuko-2.3.2-linux-2.6.19.patch.bz2 4706
+MD5 bb32e24ad60a31dbfc419d3341287f68 dazuko-2.3.2.tar.gz 177134
+RMD160 57fd3dd45a61609a18829467966657ef658ed500 dazuko-2.3.2.tar.gz 177134
+SHA256 b396fc344cf1bad0d7dfb6675573a8ca189f34867fe1256c7f31c8ec9aab45bb dazuko-2.3.2.tar.gz 177134