summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDoug Goldstein <cardoe@gentoo.org>2007-10-09 14:19:55 +0000
committerDoug Goldstein <cardoe@gentoo.org>2007-10-09 14:19:55 +0000
commit54eed67fb2546eed4a32c41c47c92b40e4676318 (patch)
tree73bd265a92dbaf92fe68addd7ec0a5ce2bc0d1a7 /sys-fs/device-mapper/device-mapper-1.02.22-r4.ebuild
parentUnmask support for SSSE3 (pni) for media-video/mplayer (diff)
downloadgentoo-2-54eed67fb2546eed4a32c41c47c92b40e4676318.tar.gz
gentoo-2-54eed67fb2546eed4a32c41c47c92b40e4676318.tar.bz2
gentoo-2-54eed67fb2546eed4a32c41c47c92b40e4676318.zip
export format patch needed to include ctype.h
(Portage version: 2.1.3.12)
Diffstat (limited to 'sys-fs/device-mapper/device-mapper-1.02.22-r4.ebuild')
-rw-r--r--sys-fs/device-mapper/device-mapper-1.02.22-r4.ebuild69
1 files changed, 69 insertions, 0 deletions
diff --git a/sys-fs/device-mapper/device-mapper-1.02.22-r4.ebuild b/sys-fs/device-mapper/device-mapper-1.02.22-r4.ebuild
new file mode 100644
index 000000000000..eb9b63748342
--- /dev/null
+++ b/sys-fs/device-mapper/device-mapper-1.02.22-r4.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/sys-fs/device-mapper/device-mapper-1.02.22-r4.ebuild,v 1.1 2007/10/09 14:19:55 cardoe Exp $
+
+inherit eutils multilib toolchain-funcs
+
+DESCRIPTION="Device mapper ioctl library for use with LVM2 utilities"
+HOMEPAGE="http://sources.redhat.com/dm/"
+SRC_URI="ftp://sources.redhat.com/pub/dm/${PN}.${PV}.tgz
+ ftp://sources.redhat.com/pub/dm/old/${PN}.${PV}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="selinux"
+
+DEPEND="selinux? ( sys-libs/libselinux )"
+
+S="${WORKDIR}/${PN}.${PV}"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/device-mapper-1.02.22-export-format-r1.diff
+}
+
+src_compile() {
+ econf --sbindir=/sbin $(use_enable selinux) --enable-dmeventd || die "econf failed"
+ emake || die "compile problem"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+
+ # move shared libs to /
+ mv "${D}"/usr/$(get_libdir) "${D}"/ || die "move libdir"
+ dolib.a lib/ioctl/libdevmapper.a || die "dolib.a"
+ gen_usr_ldscript libdevmapper.so
+
+ insinto /etc
+ doins "${FILESDIR}"/dmtab
+ insinto /lib/rcscripts/addons
+ doins "${FILESDIR}"/dm-start.sh
+
+ newinitd "${FILESDIR}"/device-mapper.rc-1.02.22-r3 device-mapper || die
+ newconfd "${FILESDIR}"/device-mapper.conf-1.02.22-r3 device-mapper || die
+
+ newinitd "${FILESDIR}"/1.02.22-dmeventd.initd dmeventd || die
+ dolib.a dmeventd/libdevmapper-event.a || die
+ gen_usr_ldscript libdevmapper-event.so
+
+ insinto /etc/udev/rules.d/
+ newins "${FILESDIR}"/64-device-mapper.rules-1.02.22 64-device-mapper.rules
+
+ dodoc INSTALL INTRO README VERSION WHATS_NEW
+}
+
+pkg_preinst() {
+ local l="${ROOT}"/$(get_libdir)/libdevmapper.so.1.01
+ [[ -e ${l} ]] && cp "${l}" "${D}"/$(get_libdir)/
+}
+
+pkg_postinst() {
+ preserve_old_lib_notify /$(get_libdir)/libdevmapper.so.1.01
+
+ elog "device-mapper volumes are no longer automatically created for"
+ elog "baselayout-2 users. If you are using baselayout-2, be sure to"
+ elog "run: # rc-update add device-mapper boot"
+}